A proposito di Plugins QGis 2.0

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

A proposito di Plugins QGis 2.0

geodrinx
Salve,

ho notato che non sembra più possibile creare un plugin che sia compatibile con tutte le versioni.

Mi spiego meglio:  una volta modificata la sintassi per renderla compatibile con la nuova versione delle api 2.0, ed aver inserito alcune istruzioni condizionali di controllo della versione, il plugin viene riconosciuto ed eseguito da QGis 2.0

Però, il plugin non parte sulla versione 1.8, perchè nel file metadata.txt la variabile

qgisMinimumVersion=2.0

Bene, se la imposto a 1.8, il plugin non viene riconosciuto più sulla versione 2.0

Mi sembra un gatto che si morde la coda.

La domanda è:  come si fa a far funzionare il plugin su entrambe le versioni, senza modificare il file metadata.txt  ?


Saluti

Roberto

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

Marco
Ritenendo che molte altre persone, come me, trovandosi bene, anzi benissimo, con la versione 1.8, rimanderanno, (così come si fa quando ci si trova comodi con un paio di scarpe che, anche se vecchie, si continuano a calzare), la migrazione alla versione 2.0 a "data da destinarsi" ...preso atto di questo, sarebbe opportuno, alla luce delle problematiche esposte nel post di GeoDrinx e in altri post analoghi che si leggono in questi giorni, che si creassero due Repository dei plugin ...un Repository per i plugin che girano sulle versioni precedenti alla 2.0, e attivabile solo dai QGIS precedenti al 2.0, e un'altro Repository ove depositare i plugin aggiornati alla 2.0 e attivabile solo da QGIS dalla 2.0 in su, in modo che chi opera da QGIS 1.8, ad esempio, involontariamente non vada a scaricarsi / installarsi dei plugin attivi solo sulla 2.0 ...e viceversa.
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

Luigi Pirelli-2
In reply to this post by geodrinx
Che mi risulti non è possibile istallare plugins della 2 sulla 1.8 e viceversa (a meno di bug)... il plugin installer manco te li fa vedere sulla 2.0. Sulla 1.8 credo ugualmente. Cosa del resto facile visto l'installer ha ha disposizione la versione min e max.  Altra cosa é installarli a manella... il plugin manager evidenzia in rosso le incompatibilità ma non lo blocca che io sappia.

Tu incontri problemi? Se si apri tikets... anche se trovare manutentori sulla 1.8 sarà via via più difficile.

Ciao ginetto2.0 ;)

Marco <[hidden email]> ha scritto:

>Ritenendo che molte altre persone, come me, trovandosi bene, anzi benissimo,
>con la versione 1.8, rimanderanno, (così come si fa quando ci si trova
>comodi con un paio di scarpe che, anche se vecchie, si continuano a
>calzare), la migrazione alla versione 2.0 a "data da destinarsi" ...preso
>atto di questo, sarebbe opportuno, alla luce delle problematiche esposte nel
>post di GeoDrinx e in altri post analoghi che si leggono in questi giorni,
>che si creassero due Repository dei plugin ...un Repository per i plugin che
>girano sulle versioni precedenti alla 2.0, e attivabile solo dai QGIS
>precedenti al 2.0, e un'altro Repository ove depositare i plugin aggiornati
>alla 2.0 e attivabile solo da QGIS dalla 2.0 in su, in modo che chi opera da
>QGIS 1.8, ad esempio, involontariamente non vada a scaricarsi / installarsi
>dei plugin attivi solo sulla 2.0 ...e viceversa.
>
>
>
>--
>View this message in context: http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/A-proposito-di-Plugins-QGis-2-0-tp7583594p7583595.html
>Sent from the Gfoss -- Geographic Free and Open Source Software - Italian mailing list mailing list archive at Nabble.com.
>_______________________________________________
>[hidden email]
>http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
>666 iscritti al 22.7.2013
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

Luigi Pirelli-2
In reply to this post by geodrinx
Ottima domanda... credo che ci sbatterò la testa anche io. Chiedo in chat (é aprerta a tutti anche la ml) e riferisco se non c'é giá scritto

Geo DrinX <[hidden email]> ha scritto:

>Salve,
>
>ho notato che non sembra più possibile creare un plugin che sia compatibile
>con tutte le versioni.
>
>Mi spiego meglio:  una volta modificata la sintassi per renderla
>compatibile con la nuova versione delle api 2.0, ed aver inserito alcune
>istruzioni condizionali di controllo della versione, il plugin viene
>riconosciuto ed eseguito da QGis 2.0
>
>Però, il plugin non parte sulla versione 1.8, perchè nel file metadata.txt
>la variabile
>
>qgisMinimumVersion=2.0
>
>Bene, se la imposto a 1.8, il plugin non viene riconosciuto più sulla
>versione 2.0
>
>Mi sembra un gatto che si morde la coda.
>
>La domanda è:  come si fa a far funzionare il plugin su entrambe le
>versioni, senza modificare il file metadata.txt  ?
>
>
>Saluti
>
>Roberto
>
>_______________________________________________
>[hidden email]
>http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
>666 iscritti al 22.7.2013
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

geodrinx
Sostanzialmente, a me succede questo:

ho creato un plugin che riesco a far funzionare sia sulla versione 1.8 che sulla versione 2.0, tramite istruzioni condizionali che controllano la versione.

Per "farlo girare", però, devo modificare "a manella" il file "metadata.txt", impostando la versione.
Il codice python, invece, rimane invariato.

Dato che si tratta di un problema abbastanza "stupido", mi sembrerebbe "stupido" lasciare questo bug limitante nella versione 2.0.


Come dicono a Napoli:  "Capisci a me "   :)


Ciao

Roberto



Il giorno 18 settembre 2013 12:56, ginetto <[hidden email]> ha scritto:
Ottima domanda... credo che ci sbatterò la testa anche io. Chiedo in chat (é aprerta a tutti anche la ml) e riferisco se non c'é giá scritto

Geo DrinX <[hidden email]> ha scritto:

>Salve,
>
>ho notato che non sembra più possibile creare un plugin che sia compatibile
>con tutte le versioni.
>
>Mi spiego meglio:  una volta modificata la sintassi per renderla
>compatibile con la nuova versione delle api 2.0, ed aver inserito alcune
>istruzioni condizionali di controllo della versione, il plugin viene
>riconosciuto ed eseguito da QGis 2.0
>
>Però, il plugin non parte sulla versione 1.8, perchè nel file metadata.txt
>la variabile
>
>qgisMinimumVersion=2.0
>
>Bene, se la imposto a 1.8, il plugin non viene riconosciuto più sulla
>versione 2.0
>
>Mi sembra un gatto che si morde la coda.
>
>La domanda è:  come si fa a far funzionare il plugin su entrambe le
>versioni, senza modificare il file metadata.txt  ?
>
>
>Saluti
>
>Roberto
>
>_______________________________________________
>[hidden email]
>http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
>666 iscritti al 22.7.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

Giuseppe Sucameli
Salve,
è stato aggiunto qgisMaximumVersion a tale scopo.

Ad es: 1.8  <= QGIS <= 2.99
qgisMinimumVersion=1.7
qgisMaximumVersion=2.99

Saluti.



2013/9/18 Geo DrinX <[hidden email]>
Sostanzialmente, a me succede questo:

ho creato un plugin che riesco a far funzionare sia sulla versione 1.8 che sulla versione 2.0, tramite istruzioni condizionali che controllano la versione.

Per "farlo girare", però, devo modificare "a manella" il file "metadata.txt", impostando la versione.
Il codice python, invece, rimane invariato.

Dato che si tratta di un problema abbastanza "stupido", mi sembrerebbe "stupido" lasciare questo bug limitante nella versione 2.0.


Come dicono a Napoli:  "Capisci a me "   :)


Ciao

Roberto



Il giorno 18 settembre 2013 12:56, ginetto <[hidden email]> ha scritto:

Ottima domanda... credo che ci sbatterò la testa anche io. Chiedo in chat (é aprerta a tutti anche la ml) e riferisco se non c'é giá scritto

Geo DrinX <[hidden email]> ha scritto:

>Salve,
>
>ho notato che non sembra più possibile creare un plugin che sia compatibile
>con tutte le versioni.
>
>Mi spiego meglio:  una volta modificata la sintassi per renderla
>compatibile con la nuova versione delle api 2.0, ed aver inserito alcune
>istruzioni condizionali di controllo della versione, il plugin viene
>riconosciuto ed eseguito da QGis 2.0
>
>Però, il plugin non parte sulla versione 1.8, perchè nel file metadata.txt
>la variabile
>
>qgisMinimumVersion=2.0
>
>Bene, se la imposto a 1.8, il plugin non viene riconosciuto più sulla
>versione 2.0
>
>Mi sembra un gatto che si morde la coda.
>
>La domanda è:  come si fa a far funzionare il plugin su entrambe le
>versioni, senza modificare il file metadata.txt  ?
>
>
>Saluti
>
>Roberto
>
>_______________________________________________
>[hidden email]
>http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
>666 iscritti al 22.7.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013



--
Giuseppe Sucameli

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

Giuseppe Sucameli
2013/9/18 Giuseppe Sucameli <[hidden email]>
Ad es: 1.8  <= QGIS <= 2.99
qgisMinimumVersion=1.7
qgisMaximumVersion=2.99

ovviamente doveva essere:
qgisMinimumVersion=1.8
altrimenti non torna :)


Saluti.



2013/9/18 Geo DrinX <[hidden email]>
Sostanzialmente, a me succede questo:

ho creato un plugin che riesco a far funzionare sia sulla versione 1.8 che sulla versione 2.0, tramite istruzioni condizionali che controllano la versione.

Per "farlo girare", però, devo modificare "a manella" il file "metadata.txt", impostando la versione.
Il codice python, invece, rimane invariato.

Dato che si tratta di un problema abbastanza "stupido", mi sembrerebbe "stupido" lasciare questo bug limitante nella versione 2.0.


Come dicono a Napoli:  "Capisci a me "   :)


Ciao

Roberto



Il giorno 18 settembre 2013 12:56, ginetto <[hidden email]> ha scritto:

Ottima domanda... credo che ci sbatterò la testa anche io. Chiedo in chat (é aprerta a tutti anche la ml) e riferisco se non c'é giá scritto

Geo DrinX <[hidden email]> ha scritto:

>Salve,
>
>ho notato che non sembra più possibile creare un plugin che sia compatibile
>con tutte le versioni.
>
>Mi spiego meglio:  una volta modificata la sintassi per renderla
>compatibile con la nuova versione delle api 2.0, ed aver inserito alcune
>istruzioni condizionali di controllo della versione, il plugin viene
>riconosciuto ed eseguito da QGis 2.0
>
>Però, il plugin non parte sulla versione 1.8, perchè nel file metadata.txt
>la variabile
>
>qgisMinimumVersion=2.0
>
>Bene, se la imposto a 1.8, il plugin non viene riconosciuto più sulla
>versione 2.0
>
>Mi sembra un gatto che si morde la coda.
>
>La domanda è:  come si fa a far funzionare il plugin su entrambe le
>versioni, senza modificare il file metadata.txt  ?
>
>
>Saluti
>
>Roberto
>
>_______________________________________________
>[hidden email]
>http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
>666 iscritti al 22.7.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013



--
Giuseppe Sucameli



--
Giuseppe Sucameli

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: A proposito di Plugins QGis 2.0

geodrinx
In reply to this post by Luigi Pirelli-2
OK.

qgisMinimumVersion=1.8
qgisMaximumVersion=2.99


Risolto, grazie !

:)

Roberto

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Coordinate Reference System

Novarese
In reply to this post by geodrinx
Geo DrinX wrote
ho creato un plugin
Se alludi a "GearthView", complimenti davvero!

Posso permettermi un appunto?

Se per sbaglio mi "dimentico" di settare il CRS corrente, ad es. perche' manca il .PRJ d'appoggio, il plug-in (giustamente) mi spara nella Fossa delle Marianne...

Sarebbe difficile per te implementare un controllo sull'avvenuto settaggio del CRS..?

Grazie, sei un grande.
Reply | Threaded
Open this post in threaded view
|

Re: Coordinate Reference System

geodrinx

Il giorno 20 settembre 2013 13:13, Novarese <[hidden email]> ha scritto:
Geo DrinX wrote/
> ho creato un plugin
/

Se alludi a "GearthView", complimenti davvero!

Thank you   ;)

Allora sei uno dei 295 che lo hanno installato finora, in due giorni.  Grazie ancora.
 

Posso permettermi un appunto?

Prego.  E' il bello dell'OpenSource.

 
Se per sbaglio mi "dimentico" di settare il CRS corrente, ad es. perche'
manca il .PRJ d'appoggio, il plug-in (giustamente) mi spara nella Fossa
delle Marianne...

mi dispiace di dissentire:  in quel caso si viene proiettati al largo del Golfo de Fonseca, coordinate 0 0 wgs84.

;)


Sarebbe difficile per te implementare un controllo sull'avvenuto settaggio
del CRS..?

Si potrebbe anche...

Personalmente, sono contrario ai messaggi di errore o alla necessità di impostare dei settaggi:  fanno perdere l'effetto "Sorpresa !"   :)

Forse potrebbe essere divertente usare un'immagine di default, tipo "Benvenuti nel Golfo di Fonseca coordinate  Lat 0.00 e Long 0.00 -   Non volevate venire qui ?...  Allora, per cortesia:  impostate un sistema di riferimento corretto !  ;)"

 
Grazie, sei un grande.

Alla prossima versione, con una serie di interessanti novità...
 

Ciao

Roberto

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013