CXF In - problemi di caricamento

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

CXF In - problemi di caricamento

lhomo
Salve a tutti.

Ho installato l'ultima versione (2.0) del suddetto plugin su Qgis 2.0.1.
Provando ad aprire un CXF che ho disponibile mi da sempre la seguente schermata d'errore

---------------------------------------------------------------------------------------------------
Errore durante l'esecuzione di codice Python:

Traceback (most recent call last):
  File "C:\Documents and Settings\Mauro/.qgis2/python/plugins\Cxf_in\cxf_in.py", line 66, in run load_cxf(str(f),os.path.basename (os.path.splitext( str(f))[0]))
  File "C:\Documents and Settings\Mauro/.qgis2/python/plugins\Cxf_in\cxf_in.py", line 154, in load_cxf
    "P_"+str(mappa.split("_",1)[1]), "memory")
IndexError: list index out of range

Versione Python:
2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]

Versione di QGIS:
2.0.1-Dufour Dufour, ebebdf3

Percorso Python: ['C:\\Documents and Settings\\Mauro/.qgis2/python/plugins\\processing', 'E:/OSGeo4W/apps/qgis/./python', 'C:\\Documents and Settings\\Mauro/.qgis2/python', 'C:\\Documents and Settings\\Mauro/.qgis2/python/plugins', 'E:/OSGeo4W/apps/qgis/./python/plugins', 'E:\\OSGeo4W\\bin\\python27.zip', 'E:\\OSGeo4W\\apps\\Python27\\DLLs', 'E:\\OSGeo4W\\apps\\Python27\\lib', 'E:\\OSGeo4W\\apps\\Python27\\lib\\plat-win', 'E:\\OSGeo4W\\apps\\Python27\\lib\\lib-tk', 'E:\\OSGeo4W\\bin', 'E:\\OSGeo4W\\apps\\Python27', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\PIL', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win32.egg', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode', 'C:\\Documents and Settings\\Mauro\\.qgis2\\python\\plugins\\mmqgis/forms', 'E:\\OSGeo4W\\apps\\qgis\\python\\plugins\\fTools\\tools']
--------------------------------------------------------------------------------------------------

Lo stesso identico errore me lo da su una macchina XP SP3 x32 e su una Win 8 x64, quindi penso non dipenda dal sistema.
Ho scoperto per altro che cambiando file CXF non mi da errore come sopra ma la schermata resta vuota (ovvero sembra non caricare niente). 

Qualcuno di più esperto sa darmi una spiegazione ?
Grazie comunque fin d'ora.

Mauro



Reply | Threaded
Open this post in threaded view
|

Re: CXF In - problemi di caricamento

geodrinx
In   CXF_IN  non sono gestite le sezioni catastali, ovvero il quinto carattere del nome del file deve essere sempre   _  .

Prova a rinominare il file, sostituendo il quinto carattere con un   _   e vedrai che funziona.


Ciao

Rob


2013/12/3 lhomo <[hidden email]>
Salve a tutti.

Ho installato l'ultima versione (2.0) del suddetto plugin su Qgis 2.0.1.
Provando ad aprire un CXF che ho disponibile mi da sempre la seguente schermata d'errore

---------------------------------------------------------------------------------------------------
Errore durante l'esecuzione di codice Python:

Traceback (most recent call last):
  File "C:\Documents and Settings\Mauro/.qgis2/python/plugins\Cxf_in\cxf_in.py", line 66, in run load_cxf(str(f),os.path.basename (os.path.splitext( str(f))[0]))
  File "C:\Documents and Settings\Mauro/.qgis2/python/plugins\Cxf_in\cxf_in.py", line 154, in load_cxf
    "P_"+str(mappa.split("_",1)[1]), "memory")
IndexError: list index out of range

Versione Python:
2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]

Versione di QGIS:
2.0.1-Dufour Dufour, ebebdf3

Percorso Python: ['C:\\Documents and Settings\\Mauro/.qgis2/python/plugins\\processing', 'E:/OSGeo4W/apps/qgis/./python', 'C:\\Documents and Settings\\Mauro/.qgis2/python', 'C:\\Documents and Settings\\Mauro/.qgis2/python/plugins', 'E:/OSGeo4W/apps/qgis/./python/plugins', 'E:\\OSGeo4W\\bin\\python27.zip', 'E:\\OSGeo4W\\apps\\Python27\\DLLs', 'E:\\OSGeo4W\\apps\\Python27\\lib', 'E:\\OSGeo4W\\apps\\Python27\\lib\\plat-win', 'E:\\OSGeo4W\\apps\\Python27\\lib\\lib-tk', 'E:\\OSGeo4W\\bin', 'E:\\OSGeo4W\\apps\\Python27', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\PIL', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win32.egg', 'E:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode', 'C:\\Documents and Settings\\Mauro\\.qgis2\\python\\plugins\\mmqgis/forms', 'E:\\OSGeo4W\\apps\\qgis\\python\\plugins\\fTools\\tools']
--------------------------------------------------------------------------------------------------

Lo stesso identico errore me lo da su una macchina XP SP3 x32 e su una Win 8 x64, quindi penso non dipenda dal sistema.
Ho scoperto per altro che cambiando file CXF non mi da errore come sopra ma la schermata resta vuota (ovvero sembra non caricare niente). 

Qualcuno di più esperto sa darmi una spiegazione ?
Grazie comunque fin d'ora.

Mauro





View this message in context: CXF In - problemi di caricamento
Sent from the Gfoss -- Geographic Free and Open Source Software - Italian mailing list mailing list archive at Nabble.com.

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: CXF In - problemi di caricamento

geodrinx
In reply to this post by lhomo

Ho scoperto per altro che cambiando file CXF non mi da errore come sopra ma la schermata resta vuota (ovvero sembra non caricare niente).

 Devi fare "Zoom all'estensione del layer".

Inoltre, devi spegnere "Abilita la riproiezione al volo", nel caso sia accesa, dato che CXF_IN non imposta nessuna proiezione dei  "memory layer" creati.


Ciao

Rob

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: CXF In - problemi di caricamento

Andrea Peri
La necessita' di fare zoom-all'estensione-del-layer, peraltro è comune a tutti gli strati che si carica, non solamente ai CXF


Il giorno 03 dicembre 2013 11:32, Geo DrinX <[hidden email]> ha scritto:

Ho scoperto per altro che cambiando file CXF non mi da errore come sopra ma la schermata resta vuota (ovvero sembra non caricare niente).

 Devi fare "Zoom all'estensione del layer".

Inoltre, devi spegnere "Abilita la riproiezione al volo", nel caso sia accesa, dato che CXF_IN non imposta nessuna proiezione dei  "memory layer" creati.


Ciao

Rob

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: CXF In - problemi di caricamento

lhomo
In reply to this post by geodrinx
Problema risolto !!!
Era proprio la sezione (ovvero il mancato underscore) a causare problemi.

Grazie infinite Rob !

Mauro
Reply | Threaded
Open this post in threaded view
|

Re: CXF In - problemi di caricamento

Saccon
In reply to this post by lhomo
Carica la 2.1