Compilare Qgis 2.0 su ubuntu14.04-64bit

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Compilare Qgis 2.0 su ubuntu14.04-64bit

Luca Lanteri
Ciao a tutti, 
ho necessità di compilare QGIS 2.0 su  ubuntu14.04-64bit.
quando lancio make la compilazione si ferma con questo errore:

Nessuna regola per generare l'obiettivo "/usr/lib/libspatialindex.so", necessario per "output/lib/libqgis_core.so.2.0.1".  Arresto.

Ho sempre compilato qgis  (compresa qesta versione) su questa macchina senza particolari problemi.  Sgoogolando non ho trovato nessuna soluzione. 
Qualcuno sa darmi indicazioni ?

Grazie mille
Luca


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: Compilare Qgis 2.0 su ubuntu14.04-64bit

a.furieri
On Mon, 1 Sep 2014 21:11:08 +0200, Luca Lanteri wrote:

> Ciao a tutti, 
> ho necessità di compilare QGIS 2.0 su  ubuntu14.04-64bit.
> quando lancio make la compilazione si ferma con questo errore:
>
> Nessuna regola per generare l'obiettivo
> "/usr/lib/libspatialindex.so",
> necessario per "output/lib/libqgis_core.so.2.0.1".  Arresto.
>
> Ho sempre compilato qgis  (compresa qesta versione) su questa
> macchina senza particolari problemi.  Sgoogolando non ho trovato
> nessuna soluzione. 
> Qualcuno sa darmi indicazioni ?
>

ciao Luca,

presumbilmente il package libspatialindex non e' istallato
sulla tua macchina; prova un po' se con questa aggiusti:

sudo apt-get install libspatialindex-dev

ciao Sandro
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: Compilare Qgis 2.0 su ubuntu14.04-64bit

Luca Lanteri
mi dice che libspatialindex-dev è già alla versione più recente, come mi aspettavo, infatti ho compilato qgis 2.4 senza problemi 


Il giorno 01 settembre 2014 21:32, <[hidden email]> ha scritto:
On Mon, 1 Sep 2014 21:11:08 +0200, Luca Lanteri wrote:
Ciao a tutti, 
ho necessità di compilare QGIS 2.0 su  ubuntu14.04-64bit.
quando lancio make la compilazione si ferma con questo errore:

Nessuna regola per generare l'obiettivo "/usr/lib/libspatialindex.so",
necessario per "output/lib/libqgis_core.so.2.0.1".  Arresto.

Ho sempre compilato qgis  (compresa qesta versione) su questa
macchina senza particolari problemi.  Sgoogolando non ho trovato
nessuna soluzione. 
Qualcuno sa darmi indicazioni ?


ciao Luca,

presumbilmente il package libspatialindex non e' istallato
sulla tua macchina; prova un po' se con questa aggiusti:

sudo apt-get install libspatialindex-dev

ciao Sandro
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: Compilare Qgis 2.0 su ubuntu14.04-64bit

Salvatore Larosa
Ciao,

2014-09-01 21:35 GMT+02:00 Luca Lanteri <[hidden email]>:
> mi dice che libspatialindex-dev è già alla versione più recente, come mi
> aspettavo, infatti ho compilato qgis 2.4 senza problemi

Può essere che SPATIALINDEX_LIBRARY sia rimasta vuota per qualche motivo?
Dovrebbe essere: SPATIALINDEX_LIBRARY=/usr/lib/libspatialindex.so

Saluti,
-SL

>
>
> Il giorno 01 settembre 2014 21:32, <[hidden email]> ha scritto:
>
>> On Mon, 1 Sep 2014 21:11:08 +0200, Luca Lanteri wrote:
>>>
>>> Ciao a tutti,
>>> ho necessità di compilare QGIS 2.0 su  ubuntu14.04-64bit.
>>> quando lancio make la compilazione si ferma con questo errore:
>>>
>>> Nessuna regola per generare l'obiettivo "/usr/lib/libspatialindex.so",
>>> necessario per "output/lib/libqgis_core.so.2.0.1".  Arresto.
>>>
>>> Ho sempre compilato qgis  (compresa qesta versione) su questa
>>> macchina senza particolari problemi.  Sgoogolando non ho trovato
>>> nessuna soluzione.
>>> Qualcuno sa darmi indicazioni ?
>>>
>>
>> ciao Luca,
>>
>> presumbilmente il package libspatialindex non e' istallato
>> sulla tua macchina; prova un po' se con questa aggiusti:
>>
>> sudo apt-get install libspatialindex-dev
>>
>> ciao Sandro
>> _______________________________________________
>> [hidden email]
>> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>> Questa e' una lista di discussione pubblica aperta a tutti.
>> I messaggi di questa lista non hanno relazione diretta con le posizioni
>> dell'Associazione GFOSS.it.
>> 666+40 iscritti al 5.6.2014
>
>
>
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 666+40 iscritti al 5.6.2014



--
Salvatore Larosa
linkedIn: http://linkedin.com/in/larosasalvatore
twitter: @lrssvt
skype: s.larosa
IRC: lrssvt on freenode
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: Compilare Qgis 2.0 su ubuntu14.04-64bit

Luca Lanteri
no, anche SPATIALINDEX_LIBRARY è corretta.
Provo a riscaricare i sorgenti...

l'unico problema che ho è che cmake mi dice 

CMake Warning (dev) at tests/src/python/CMakeLists.txt:1 (INCLUDE):
  Syntax Warning in cmake code at [...]

però sembrebbe solo un warning, infatti cmake va a buon fine.

^L^


    /home/luk/dev/QGIS-release-2_0/cmake/UsePythonTest.cmake:60:12


Il giorno 01 settembre 2014 21:46, Salvatore Larosa <[hidden email]> ha scritto:
Ciao,

2014-09-01 21:35 GMT+02:00 Luca Lanteri <[hidden email]>:
> mi dice che libspatialindex-dev è già alla versione più recente, come mi
> aspettavo, infatti ho compilato qgis 2.4 senza problemi

Può essere che SPATIALINDEX_LIBRARY sia rimasta vuota per qualche motivo?
Dovrebbe essere: SPATIALINDEX_LIBRARY=/usr/lib/libspatialindex.so

Saluti,
-SL

>
>
> Il giorno 01 settembre 2014 21:32, <[hidden email]> ha scritto:
>
>> On Mon, 1 Sep 2014 21:11:08 +0200, Luca Lanteri wrote:
>>>
>>> Ciao a tutti,
>>> ho necessità di compilare QGIS 2.0 su  ubuntu14.04-64bit.
>>> quando lancio make la compilazione si ferma con questo errore:
>>>
>>> Nessuna regola per generare l'obiettivo "/usr/lib/libspatialindex.so",
>>> necessario per "output/lib/libqgis_core.so.2.0.1".  Arresto.
>>>
>>> Ho sempre compilato qgis  (compresa qesta versione) su questa
>>> macchina senza particolari problemi.  Sgoogolando non ho trovato
>>> nessuna soluzione.
>>> Qualcuno sa darmi indicazioni ?
>>>
>>
>> ciao Luca,
>>
>> presumbilmente il package libspatialindex non e' istallato
>> sulla tua macchina; prova un po' se con questa aggiusti:
>>
>> sudo apt-get install libspatialindex-dev
>>
>> ciao Sandro
>> _______________________________________________
>> [hidden email]
>> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>> Questa e' una lista di discussione pubblica aperta a tutti.
>> I messaggi di questa lista non hanno relazione diretta con le posizioni
>> dell'Associazione GFOSS.it.
>> 666+40 iscritti al 5.6.2014
>
>
>
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 666+40 iscritti al 5.6.2014



--
Salvatore Larosa
linkedIn: http://linkedin.com/in/larosasalvatore
twitter: @lrssvt
skype: s.larosa
IRC: lrssvt on freenode


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: Compilare Qgis 2.0 su ubuntu14.04-64bit

Luca Lanteri
problema risolto cancellando la cache di cmake in /home/luk/.local/share/Trash/files/QGIS-release-2_0.

grazie come sempre del supporto real time !
a presto
Luca
 


Il giorno 01 settembre 2014 21:50, Luca Lanteri <[hidden email]> ha scritto:
no, anche SPATIALINDEX_LIBRARY è corretta.
Provo a riscaricare i sorgenti...

l'unico problema che ho è che cmake mi dice 

CMake Warning (dev) at tests/src/python/CMakeLists.txt:1 (INCLUDE):
  Syntax Warning in cmake code at [...]

però sembrebbe solo un warning, infatti cmake va a buon fine.

^L^


    /home/luk/dev/QGIS-release-2_0/cmake/UsePythonTest.cmake:60:12


Il giorno 01 settembre 2014 21:46, Salvatore Larosa <[hidden email]> ha scritto:

Ciao,

2014-09-01 21:35 GMT+02:00 Luca Lanteri <[hidden email]>:
> mi dice che libspatialindex-dev è già alla versione più recente, come mi
> aspettavo, infatti ho compilato qgis 2.4 senza problemi

Può essere che SPATIALINDEX_LIBRARY sia rimasta vuota per qualche motivo?
Dovrebbe essere: SPATIALINDEX_LIBRARY=/usr/lib/libspatialindex.so

Saluti,
-SL

>
>
> Il giorno 01 settembre 2014 21:32, <[hidden email]> ha scritto:
>
>> On Mon, 1 Sep 2014 21:11:08 +0200, Luca Lanteri wrote:
>>>
>>> Ciao a tutti,
>>> ho necessità di compilare QGIS 2.0 su  ubuntu14.04-64bit.
>>> quando lancio make la compilazione si ferma con questo errore:
>>>
>>> Nessuna regola per generare l'obiettivo "/usr/lib/libspatialindex.so",
>>> necessario per "output/lib/libqgis_core.so.2.0.1".  Arresto.
>>>
>>> Ho sempre compilato qgis  (compresa qesta versione) su questa
>>> macchina senza particolari problemi.  Sgoogolando non ho trovato
>>> nessuna soluzione.
>>> Qualcuno sa darmi indicazioni ?
>>>
>>
>> ciao Luca,
>>
>> presumbilmente il package libspatialindex non e' istallato
>> sulla tua macchina; prova un po' se con questa aggiusti:
>>
>> sudo apt-get install libspatialindex-dev
>>
>> ciao Sandro
>> _______________________________________________
>> [hidden email]
>> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
>> Questa e' una lista di discussione pubblica aperta a tutti.
>> I messaggi di questa lista non hanno relazione diretta con le posizioni
>> dell'Associazione GFOSS.it.
>> 666+40 iscritti al 5.6.2014
>
>
>
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 666+40 iscritti al 5.6.2014



--
Salvatore Larosa
linkedIn: http://linkedin.com/in/larosasalvatore
twitter: @lrssvt
skype: s.larosa
IRC: lrssvt on freenode



_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014