Errore visualizzazione vettori (scompaiono poligoni!) zoom in

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Errore visualizzazione vettori (scompaiono poligoni!) zoom in

Danilo Procaccini
Buon giorno,
lavorando con alcuni vettori (ne allego 1 come esempio) nell'effettuare lo
"zoom in" ad un certo punto alcuni poligoni (o tutto il vettore, dipende)
scompaiono (anche dai layout di stampa) per poi riapparire in "zoom out".
Sembrerebbe che questo problema si verifichi quando una parte (anche
ridottissima) di questi poligoni nelle operazioni di zoom Vanno a finire
fuori "estensione della mappa".
I vettori non hanno visualizzazioni dipendenti dalla scala.
Ho provato a cambiare le impostazioni di visualizzazione del progetto ma
niente.
Debian 8 - Qgis 2.18.7
Soluzioni?
Grazie in anticipo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
808 iscritti al 07/03/2017
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errore visualizzazione vettori (scompaiono poligoni!) zoom in

Andrea Peri
E' un difetto (almeno per me di qgis.)

Non so' perche', ma se QGIS visualizza un dataset che contiene una
geometria non valida e si va a zoomare ENTRANDO dentro questa
geometria,
qgis la fa' scomparire.

Sospetto che lo faccia per evitare di crashare.

Quindi se vuoi vedere ricomparire la geotria devi cercare una
geometria non valida (magari con spatialite) e renderla valida con il
comando MakeValid e poi vedrai che zoomando non sparisce piu'.

Hope this help.

A.


Il 14 giugno 2017 08:37, Danilo Procaccini
<[hidden email]> ha scritto:

> Buon giorno,
> lavorando con alcuni vettori (ne allego 1 come esempio) nell'effettuare lo
> "zoom in" ad un certo punto alcuni poligoni (o tutto il vettore, dipende)
> scompaiono (anche dai layout di stampa) per poi riapparire in "zoom out".
> Sembrerebbe che questo problema si verifichi quando una parte (anche
> ridottissima) di questi poligoni nelle operazioni di zoom Vanno a finire
> fuori "estensione della mappa".
> I vettori non hanno visualizzazioni dipendenti dalla scala.
> Ho provato a cambiare le impostazioni di visualizzazione del progetto ma
> niente.
> Debian 8 - Qgis 2.18.7
> Soluzioni?
> Grazie in anticipo
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
> 808 iscritti al 07/03/2017



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
808 iscritti al 07/03/2017
Loading...