Installare Qgis sotto Ubuntu 11.01

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installare Qgis sotto Ubuntu 11.01

mando
Salve a tutti,
sono sempre alle prime armi con ubuntu.

Cosa ho fatto: 

Ho installato ubuntu-11.10-desktop-amd64.iso su una virtualbox:

Dalla pagina di qgis del download ho preso questi link e li inseriti nel gestore di pacchetti:
Oneiric :
deb     http://qgis.org/debian oneiric main
deb-src http://qgis.org/debian oneiric main
Poi ho eseguito l'aggiornamento delle chiavi da terminale

gpg --keyserver keyserver.ubuntu.com --recv 1F9ADD375CA44993
gpg --export --armor 1F9ADD375CA44993 | sudo apt-key add -

Ho provato ad installare la versione 1.9 di qgis (giusto?)

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis

Ma nel terminale ricevo:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 qgis : Dipende: libgdal1-1.8.0 ma non sta per essere installato
        Dipende: libqgis1.7.3 ma non sta per essere installato
        Dipende: libqwt5-qt4 ma non è installabile
        Dipende: qgis-providers (= 1.7.3-2~oneiric1) ma non sta per essere installato
        Raccomanda: qgis-plugin-grass ma non sta per essere installato
        Raccomanda: python-qgis ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


Che pastrocchio ho fatto? E' grave?

Ciao e grazie

Luca

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012
Reply | Threaded
Open this post in threaded view
|

Re: Installare Qgis sotto Ubuntu 11.01

Marco Guiducci-2
On Fri, 3 Feb 2012 19:15:25 +0100
Luca Mandolesi <[hidden email]> wrote:


>
> Ma nel terminale ricevo:
>
> I seguenti pacchetti hanno dipendenze non soddisfatte:
>  qgis : Dipende: libgdal1-1.8.0 ma non sta per essere installato
>         Dipende: libqgis1.7.3 ma non sta per essere installato
>         Dipende: libqwt5-qt4 ma non è installabile
>         Dipende: qgis-providers (= 1.7.3-2~oneiric1) ma non sta per essere
> installato
>         Raccomanda: qgis-plugin-grass ma non sta per essere installato
>         Raccomanda: python-qgis ma non sta per essere installato
> E: Impossibile correggere i problemi, ci sono pacchetti danneggiati
> bloccati.
>
>
> Che pastrocchio ho fatto? E' grave?
>

Non credo. Io l'avevo installato poche settimane fa su lubuntu 11.10 esattamente come hai fatto tu ed è andato tutto liscio.
Oggi ho fatto un aggiornamento e non ce l'ho più sul pc! Provando a reinstallare ho ottenuto un risultato più o meno analogo.
Ho letto però, in qualche mail precedente, che ci sono problemi di compilazione.
NB: sono anch'io alle prime armi con linux e non capisco perché un aggiornamento del sistema mi possa aver tolto QGis! Che faccio, sto senza?
aspetto gli eventi.
marco

--
Marco Guiducci <[hidden email]>
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012
Reply | Threaded
Open this post in threaded view
|

Re: Installare Qgis sotto Ubuntu 11.01

mando
Dopo aver riabilitato ogni cosa nel gestore pacchetti, mi ha scaricato  Qgis 1.7.3...bene...almeno quello...

ora sto provando a capire come installare la versione unstable...visto che la chiave del launchpad scaricata tramite terminale è riferita al stable!

Intanto Spatacco, tanto c'è la neve fuori!

:)

Ciao e grazie

Luca

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012
Reply | Threaded
Open this post in threaded view
|

Re: Installare Qgis sotto Ubuntu 11.01

mando
Spetta!

Nella pagina del download dice: Current packages available for jaunty, karmic, lucid and maverick from...

Non c'è per oneiric quindi per la 11.10....giusto? Ho capito bene?

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012
Reply | Threaded
Open this post in threaded view
|

Re: Installare Qgis sotto Ubuntu 11.01

pcav
> Spetta!
>
> Nella pagina del download dice: Current packages available for jaunty,
> karmic, lucid and maverick from...
>
attenzione: usare una versione unstable e', ovviamente, una cosa
instabile, quindi non raccomandata per l'uso generale.
per quello esistono le versioni stabili.
in particolare, in questi giorni si e' rotto sip, che causano problemi
nella compilazione di qgis.
il problema e' identificato, ed a breve verra' risolto.
saluti.

--
Paolo Cavallini
See: http://www.faunalia.it/pc

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012
Reply | Threaded
Open this post in threaded view
|

Re: Installare Qgis sotto Ubuntu 11.01

Michele Beneventi
In reply to this post by mando
Ciao,
io uso questi repository e mi trovo benissimo



ciao
Michele

----------
Michele Beneventi
GIS Technologist
LAT: 39° 18' 25"; LONG: 08 °33' 20"
----------

http://www.michelebeneventi.it/
http://it.linkedin.com/in/michelebeneventi

?ui=2&view=att&th=125787ee7439bd8b&attid=0.1&disp=attd&realattid=ii_125787ee7439bd8b&zw


2012/2/3 Luca Mandolesi <[hidden email]>
Salve a tutti,
sono sempre alle prime armi con ubuntu.

Cosa ho fatto: 

Ho installato ubuntu-11.10-desktop-amd64.iso su una virtualbox:

Dalla pagina di qgis del download ho preso questi link e li inseriti nel gestore di pacchetti:
Oneiric :

deb     http://qgis.org/debian oneiric main
deb-src http://qgis.org/debian oneiric main
Poi ho eseguito l'aggiornamento delle chiavi da terminale


gpg --keyserver keyserver.ubuntu.com --recv 1F9ADD375CA44993
gpg --export --armor 1F9ADD375CA44993 | sudo apt-key add -

Ho provato ad installare la versione 1.9 di qgis (giusto?)

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis

Ma nel terminale ricevo:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 qgis : Dipende: libgdal1-1.8.0 ma non sta per essere installato
        Dipende: libqgis1.7.3 ma non sta per essere installato
        Dipende: libqwt5-qt4 ma non è installabile
        Dipende: qgis-providers (= 1.7.3-2~oneiric1) ma non sta per essere installato
        Raccomanda: qgis-plugin-grass ma non sta per essere installato
        Raccomanda: python-qgis ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


Che pastrocchio ho fatto? E' grave?

Ciao e grazie

Luca

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
569 iscritti al 4.1.2012