Installazione manuale librerie proj su Ubuntu 18.04

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Installazione manuale librerie proj su Ubuntu 18.04

Massimiliano Moraca
Salve a tutti, sto settando  GeoDjango
<https://docs.djangoproject.com/en/2.2/ref/contrib/gis/>   e tra le
impostazioni c'è la procedura di installazione delle librerie  proj
<https://docs.djangoproject.com/en/2.2/ref/contrib/gis/install/geolibs/#proj4>
.

Quando do il comando *./configure* mi viene restituito questo messaggio:

/checking for SQLITE3... configure: error: Package requirements (sqlite3 >=
3.7) were not met:

No package 'sqlite3' found/

Fecendo un check sulla versione di sqlite installata sul pc vedo che è la
3.27.2 e sul sito  ufficiale del db <https://www.sqlite.org/index.html>  
c'è scritto che l'ultima è la 3.28. Come è quindi possibile che le proj mi
chiedano la 3.7? Vi è mai capitata una cosa simile?

-----
Ingegnere, consulente GIS e ciclista urbano
--
Sent from: http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Ingegnere, consulente GIS e ciclista urbano
Reply | Threaded
Open this post in threaded view
|

Re: Installazione manuale librerie proj su Ubuntu 18.04

a.furieri
On Tue, 11 Jun 2019 23:59:46 -0700 (MST), Massimiliano Moraca wrote:

> Salve a tutti, sto settando  GeoDjango
> <https://docs.djangoproject.com/en/2.2/ref/contrib/gis/>   e tra le
> impostazioni c'è la procedura di installazione delle librerie  proj
>
> <https://docs.djangoproject.com/en/2.2/ref/contrib/gis/install/geolibs/#proj4>
>
> .
>
> Quando do il comando *./configure* mi viene restituito questo
> messaggio:
>
> /checking for SQLITE3... configure: error: Package requirements
> (sqlite3 >=
> 3.7) were not met:
>
> No package 'sqlite3' found/
>
> Fecendo un check sulla versione di sqlite installata sul pc vedo che
> è la
> 3.27.2 e sul sito  ufficiale del db
> <https://www.sqlite.org/index.html>
> c'è scritto che l'ultima è la 3.28. Come è quindi possibile che le
> proj mi
> chiedano la 3.7? Vi è mai capitata una cosa simile?
>

Massimiliano,

leggi attentamente gli errori ;-)

Package requirements (sqlite3 >= 3.7) were not met

ti sta dicendo che non e' riuscito a trovare una
sqlite3 UGUALE O SUCCESSIVA alla 3.7, quindi se tu
hai installato la 2.27.2 dovrebbe passare il test.
in sostanza, il ./configure della proj si rifiuta
di andare avanti se scopre che stai cercando di
usare una porcheria ultra-obsoleta (la 3.7 risale
al 2010, e si spera che ormai non la utilizzi
piu' nessuno).

suppongo quindi che tu sia inciampato nel classico
trappolone del packaging su Linux.
le librerie sono sempre pacchettizzate come due
diversi packages, uno per i componenti binari,
l'altro per gli header files.
il primo serve a tutti, il secondo serve solo
agli sviluppatori e quindi non viene mai
installato by default, devi chiedere esplicitamente
che venga installato.

verifica la situazione sul tuo Ubuntu; vedrai che
quasi certamente troverai installato un package che
si chiama libsqlite3-0 mentre non risultera' ancora
installato libsqlite3-dev (quello che appunto
contiene gli header files).

installati libsqlite3-dev e vedrai che poi ti
doverbbe girare tutto liscio.

ciao Sandro


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Reply | Threaded
Open this post in threaded view
|

Re: Installazione manuale librerie proj su Ubuntu 18.04

Massimiliano Moraca
Grazie Alessandro, in realtà sono incappato in due problemi. Uno è quello che
mi hai indicato con le librerie libsqlite3-dev mentre l'altro è che, non
venendo dal mondo DEV, non ero al corrente del fatto che 3.7 è settima
release della terza versione mentre 3.27 è quindi la ventisettesima release
della terza. Per cui effettivamente 3.27 >= di 3.7. Per come ragionavo io
3.7 è più grande di 3.27 ma il valore reale, per il mio modo di ragionare da
non sviluppatore(ancora), sarebbe 3.07. Ho acquisito questa informazione!

Ho seguito le tue indicazioni e l'installazione è andata a buon fine, grazie
di nuovo

-----
Ingegnere, consulente GIS e ciclista urbano
--
Sent from: http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Ingegnere, consulente GIS e ciclista urbano