Matplotlib v. 1.5 non compatibile con alcuni plugin

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Matplotlib v. 1.5 non compatibile con alcuni plugin

giuseppe.gua@libero.it
Ciao a tutti,

di recente con l'aggiornamento di Ubuntu 16 mi si è aggiornata anche la libreria di matplotlib alla versione 1.5.
Soltanto che per far funzionare alcuni plugin ho bisogno della versione 1.2 che non riesco più ad installare.
Inoltre, sia da terminale che da Synaptic disinstallando matplotlib, si disinstalla anche Qgis (in pratica Qgis è come se dipendesse da una libreria). Oppure se provo ad installare solo Qgis, in automatico si installa anche l'ultima versione di matplotlib.

Qualcuno sa come posso risolvere questo problema?

Grazie mille a tutti,
Giuseppe Guarino


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|

Re: Matplotlib v. 1.5 non compatibile con alcuni plugin

Marco Curreli
On  08/13/16     , [hidden email] wrote:
>
> di recente con l'aggiornamento di Ubuntu 16 mi si è aggiornata anche la libreria di matplotlib alla versione 1.5.
> Soltanto che per far funzionare alcuni plugin ho bisogno della versione 1.2 che non riesco più ad installare.

Qual è l'errore? Se non trova la libreria il problema è risolvibile
con un semplice collegamento simbolico; se invece c'è una vera
incompatibilità non saprei.

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|

Re: Matplotlib v. 1.5 non compatibile con alcuni plugin

pcav
Il 14/08/2016 00:14, Marco Curreli ha scritto:
> On  08/13/16     , [hidden email] wrote:
>>
>> di recente con l'aggiornamento di Ubuntu 16 mi si è aggiornata anche la libreria di matplotlib alla versione 1.5.
>> Soltanto che per far funzionare alcuni plugin ho bisogno della versione 1.2 che non riesco più ad installare.
>
> Qual è l'errore? Se non trova la libreria il problema è risolvibile
> con un semplice collegamento simbolico; se invece c'è una vera
> incompatibilità non saprei.

Salve.
Credo che la cosa migliore sia adeguare il plugin alla nuova versione di
Matplotlib. Non credo questo richieda molto lavoro, il primo passo è
come al solito fare una segnalazione precisa allo sviluppatore, tramite
un ticket o tramite la mailing list.
Cordiali saluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016