Problema a caricare il plugin Anaximandre su Qgis

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema a caricare il plugin Anaximandre su Qgis

francesco carpita
Salve a tutti, ho un problema su Qgis con il plugin Anaximandre:

ho istallato il plugin ma non mi compare tra i pulsanti, se vado nei
plugin, e provo a togliere o rimettere la spunta per attivarlo mi da questo
errore:


Impossibile caricare il plugin Anaximandre a causa di un errore chiamando
il metodo initGui()

AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'

Traceback (most recent call last):

  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 342, in
startPlugin

    plugins[packageName].initGui()

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
line 175, in initGui

    parent=self.iface.mainWindow())

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
line 142, in add_action

    self.dlg = AnaximandreDialog()

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre_dialog.py",
line 46, in __init__

    self.layerList()

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/AnaximandreDialog.py",
line 71, in layerList

    if layer.providerType()== 'delimitedtext':

AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'


Ho cercato un po' su internet ma non trovo soluzioni.

La versione di Qgis istallata è la 2.18.13 e il sistema operativo del
computer è Debian 9.2


grazie a tutti

Francesco
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017
Reply | Threaded
Open this post in threaded view
|

Re: Problema a caricare il plugin Anaximandre su Qgis

liste_girarsi
Il 30/10/2017 22:55, Francesco Carpita ha scritto:
> Salve a tutti, ho un problema su Qgis con il plugin Anaximandre:
>
> ho istallato il plugin ma non mi compare tra i pulsanti, se vado nei
> plugin, e provo a togliere o rimettere la spunta per attivarlo mi da questo
> errore:
>
>

Hai aggiornato di recente? distribuzione o programma?


--
_|_|_|_|_|_|_|_|_|_
|_|_|_|_|_|_|_|_|_|_|
Simone Girardelli
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017
Reply | Threaded
Open this post in threaded view
|

Re: Problema a caricare il plugin Anaximandre su Qgis

lhomo
In reply to this post by francesco carpita
Ho provato ad installare sulla 2.18.14 (Windows x64) ed è tutto ok.

Mauro



Il giorno 30 ottobre 2017 22:55, Francesco Carpita <
[hidden email]> ha scritto:

> Salve a tutti, ho un problema su Qgis con il plugin Anaximandre:
>
> ho istallato il plugin ma non mi compare tra i pulsanti, se vado nei
> plugin, e provo a togliere o rimettere la spunta per attivarlo mi da questo
> errore:
>
>
> Impossibile caricare il plugin Anaximandre a causa di un errore chiamando
> il metodo initGui()
>
> AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'
>
> Traceback (most recent call last):
>
>   File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 342, in
> startPlugin
>
>     plugins[packageName].initGui()
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
> line 175, in initGui
>
>     parent=self.iface.mainWindow())
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
> line 142, in add_action
>
>     self.dlg = AnaximandreDialog()
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/
> Anaximandre_dialog.py",
> line 46, in __init__
>
>     self.layerList()
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/
> AnaximandreDialog.py",
> line 71, in layerList
>
>     if layer.providerType()== 'delimitedtext':
>
> AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'
>
>
> Ho cercato un po' su internet ma non trovo soluzioni.
>
> La versione di Qgis istallata è la 2.18.13 e il sistema operativo del
> computer è Debian 9.2
>
>
> grazie a tutti
>
> Francesco
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 801 iscritti al 19/07/2017
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017
Reply | Threaded
Open this post in threaded view
|

Re: Problema a caricare il plugin Anaximandre su Qgis

Salvatore Larosa
In reply to this post by francesco carpita
Ciao,

presumo tu abbia caricato nella mappa qualche layer del plugin OpenLayers
(tipo qualche mappa di google). Prova a rimuoverlo e a rifare la procedura.

Per qualsiasi altro problema specifico a QGIS puoi fare riferimento alla
mailing list dedicata: https://lists.osgeo.org/mailman/listinfo/qgis-it-user

--
Sent from my mobile phone


Il 30 Ott 2017 10:55 PM, "Francesco Carpita" <[hidden email]>
ha scritto:

Salve a tutti, ho un problema su Qgis con il plugin Anaximandre:

ho istallato il plugin ma non mi compare tra i pulsanti, se vado nei
plugin, e provo a togliere o rimettere la spunta per attivarlo mi da questo
errore:


Impossibile caricare il plugin Anaximandre a causa di un errore chiamando
il metodo initGui()

AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'

Traceback (most recent call last):

  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 342, in
startPlugin

    plugins[packageName].initGui()

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
line 175, in initGui

    parent=self.iface.mainWindow())

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
line 142, in add_action

    self.dlg = AnaximandreDialog()

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/
Anaximandre_dialog.py",
line 46, in __init__

    self.layerList()

  File "/home/francesco/.qgis2/python/plugins/Anaximandre/
AnaximandreDialog.py",
line 71, in layerList

    if layer.providerType()== 'delimitedtext':

AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'


Ho cercato un po' su internet ma non trovo soluzioni.

La versione di Qgis istallata è la 2.18.13 e il sistema operativo del
computer è Debian 9.2


grazie a tutti

Francesco
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni
dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017
Reply | Threaded
Open this post in threaded view
|

Re: Problema a caricare il plugin Anaximandre su Qgis

francesco carpita
Salve, per quanto riguarda il plugin Anaximadre confermo, il problema che
ho descritto si verifica se nel progetto è stato precedentemente caricato
un layer sia da QuickMapSsrvices che da OpenLayers plugin. Se invece come
'sfondo' utilizzo un raster normale il plugin Anaximandre funziona. Qualcun
altro ha riscontrato questo problema o sono l'unico?

Saluti
Francesco

Il giorno 31 ottobre 2017 08:51, Salvatore Larosa <[hidden email]> ha
scritto:

> Ciao,
>
> presumo tu abbia caricato nella mappa qualche layer del plugin OpenLayers
> (tipo qualche mappa di google). Prova a rimuoverlo e a rifare la procedura.
>
> Per qualsiasi altro problema specifico a QGIS puoi fare riferimento alla
> mailing list dedicata: https://lists.osgeo.org/mailman/listinfo/qgis-it-
> user
>
> --
> Sent from my mobile phone
>
>
> Il 30 Ott 2017 10:55 PM, "Francesco Carpita" <[hidden email]>
> ha scritto:
>
> Salve a tutti, ho un problema su Qgis con il plugin Anaximandre:
>
> ho istallato il plugin ma non mi compare tra i pulsanti, se vado nei
> plugin, e provo a togliere o rimettere la spunta per attivarlo mi da questo
> errore:
>
>
> Impossibile caricare il plugin Anaximandre a causa di un errore chiamando
> il metodo initGui()
>
> AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'
>
> Traceback (most recent call last):
>
>   File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 342, in
> startPlugin
>
>     plugins[packageName].initGui()
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
> line 175, in initGui
>
>     parent=self.iface.mainWindow())
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximandre.py",
> line 142, in add_action
>
>     self.dlg = AnaximandreDialog()
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximand
> re_dialog.py",
> line 46, in __init__
>
>     self.layerList()
>
>   File "/home/francesco/.qgis2/python/plugins/Anaximandre/Anaximand
> reDialog.py",
> line 71, in layerList
>
>     if layer.providerType()== 'delimitedtext':
>
> AttributeError: 'OpenlayersLayer' object has no attribute 'providerType'
>
>
> Ho cercato un po' su internet ma non trovo soluzioni.
>
> La versione di Qgis istallata è la 2.18.13 e il sistema operativo del
> computer è Debian 9.2
>
>
> grazie a tutti
>
> Francesco
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 801 iscritti al 19/07/2017
>
>
>
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017
Reply | Threaded
Open this post in threaded view
|

Re: Problema a caricare il plugin Anaximandre su Qgis

Salvatore Larosa
2017-11-01 9:35 GMT+01:00 Francesco Carpita <[hidden email]>:

> Salve, per quanto riguarda il plugin Anaximadre confermo, il problema che
> ho descritto si verifica se nel progetto è stato precedentemente caricato
> un layer sia da QuickMapSsrvices che da OpenLayers plugin. Se invece come
> 'sfondo' utilizzo un raster normale il plugin Anaximandre funziona. Qualcun
> altro ha riscontrato questo problema o sono l'unico?
>

E' un piccolo bug del plugin, devi segnalarlo qui [0] per avvisare chi ha
sviluppato
il plugin in modo che possa risolverlo celermente.

Saluti!
-SL

[0] - https://github.com/FFouriauxEveha/Anaximandre/issues

--
Salvatore Larosa
linkedIn: http://linkedin.com/in/larosasalvatore
twitter: @lrssvt
skype: s.larosa
IRC: lrssvt on freenode
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
801 iscritti al 19/07/2017