Problema con mapserver

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema con mapserver

deinic1982@tin.it
 Salve a tutti,
avrei un problema di pubblicazione mappe attraverso map server.Poichè sono alle prime armi sto iniziando a studiare un primo  caso di studio di pubblicazione di due layers.Ho creato il file .map attraverso un progetto di Qgis.Poi è stato creato un file di inizializzazione ed un template, per rendere la mappa interattiva seguendo un tutorial.Purtroppo non riesco a visualizzare nulla,magari se posto il file d'inizializzazione e il template potreste darmi una dritta.

***File di Inizializzazione****

<html> 
  <body>   

      <center>         
          <FORM METHOD="GET" ACTION="/cgi-bin/mapserv.exe">
        <INPUT TYPE="hidden" NAME="map" VALUE="C:\mapserver\ms4w\Apache\htdocs\ProvaZoom\Layers_Mapserver.map">
                <INPUT TYPE="submit" VALUE="CREA LA CARTA">
       </FORM>

      </center>
   
  </body>
</html>


****Template****

<html>

<body>
<FORM METHOD="GET" ACTION="/cgi-bin/mapserv.exe">
  <INPUT TYPE="hidden" NAME="map" VALUE="C:\mapserver\ms4w\Apache\htdocs\ProvaZoom\Layers_Mapserver.map">
  <INPUT TYPE="hidden" NAME="imgext" VALUE="[mapext]">
  <INPUT TYPE="hidden" NAME="mode" VALUE="browse">

  <IMG SRC="[img]" ALT="Carta / Img" BORDER="1">

</FORM>
</body>

</html>


l'unica modifica fatta al file.map è stata quella di  inserire nella sezione WEB  il parametro TEMPLATE col nome del template.html.Grazie.Ciao.


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

R: Problema con mapserver

Giannini Pietro

Per capire cosa è successo prova a chiamare mapserver in modo cgi (se non l’hai già fatto), digitando nel navigatore una url tipo:

 

http://localhost/cgi-bin/mapserver.exe?map= C:\mapserver\ms4w\Apache\htdocs\ProvaZoom\Layers_Mapserver.map

(nche inserendo il percorso in modo *nix: “/mapserver/ms4w/Apache/htdocs/ProvaZoom/Layers_Mapserver.map” )

 

ti dovrebbe visualizzare un messaggio di errore

 

puoi anche aggiungere nella sezione WEB:

LOG       /percorso/al/file/di.log

Per registrarti l’output su file.

In questo caso puoi aggiungere

                DEBUG                 on

Nelle sezioni layer per registrare il debug a livello layer

 

Se non trovi nulla, postaci la mappa Layers_Mapserver.map

 

....................pg

 

 

 

 

Pietro Giannini

Bytewise srl - Area GIS

41°50'38.58"N 12°29'13.39"E

 

Da: [hidden email] [mailto:[hidden email]] Per conto di [hidden email]
Inviato: lunedì 30 novembre 2009 18.54
A: [hidden email]
Oggetto: [Gfoss] Problema con mapserver

 

 Salve a tutti,
avrei un problema di pubblicazione mappe attraverso map server.Poichè sono alle prime armi sto iniziando a studiare un primo  caso di studio di pubblicazione di due layers.Ho creato il file .map attraverso un progetto di Qgis.Poi è stato creato un file di inizializzazione ed un template, per rendere la mappa interattiva seguendo un tutorial.Purtroppo non riesco a visualizzare nulla,magari se posto il file d'inizializzazione e il template potreste darmi una dritta.

***File di Inizializzazione****

<html> 
  <body>   

      <center>         
          <FORM METHOD="GET" ACTION="/cgi-bin/mapserv.exe">
        <INPUT TYPE="hidden" NAME="map" VALUE="C:\mapserver\ms4w\Apache\htdocs\ProvaZoom\Layers_Mapserver.map">
                <INPUT TYPE="submit" VALUE="CREA LA CARTA">
       </FORM>

      </center>
   
  </body>
</html>


****Template****

<html>

<body>
<FORM METHOD="GET" ACTION="/cgi-bin/mapserv.exe">
  <INPUT TYPE="hidden" NAME="map" VALUE="C:\mapserver\ms4w\Apache\htdocs\ProvaZoom\Layers_Mapserver.map">
  <INPUT TYPE="hidden" NAME="imgext" VALUE="[mapext]">
  <INPUT TYPE="hidden" NAME="mode" VALUE="browse">

  <IMG SRC="[img]" ALT="Carta / Img" BORDER="1">

</FORM>
</body>

</html>


l'unica modifica fatta al file.map è stata quella di  inserire nella sezione WEB  il parametro TEMPLATE col nome del template.html.Grazie.Ciao.


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.