Problema proiezioni tra openstreetmap e un wms in un mapPanel di GeoExt

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema proiezioni tra openstreetmap e un wms in un mapPanel di GeoExt

Nicola De Innocentis
Ciao a tutti,
studiando l'oggetto mapPanel di GeoExt,osservo che questi due semplici layer li riesco a visualizzare sovrapposti correttamente soltanto se lo zoom non è cosi spinto (zomm circa pari a 4),
non appena aumento lo zoom il layer wms (che prelevo dal localhost da Geoserver) mi scompare. Non so se è un problema di proiezione ma mi sembra strano.Grazie anticipatamente.

--
Nicola De Innocentis

www.nicoladeinnocentis.it


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
527 iscritti al 7.7.2011
Reply | Threaded
Open this post in threaded view
|

Re: Problema proiezioni tra openstreetmap e un wms in un mapPanel di GeoExt

Nicola De Innocentis
Il codice è piccolo e abbastanza semplice, lo  giro, perchè non riesco a capire dove possa esserci l'errore:

        Ext.onReady(function(){

    var    map = new OpenLayers.Map ("map");
       
    var openstreetmap = new OpenLayers.Layer.OSM();
       
 
   var vecLayer= new OpenLayers.Layer.WMS(
                    "associazioni", "http://localhost/geoserver/wms",
                    {
                        width: '631',
                        srs: 'EPSG:4326',
                        layers: 'topp:associazioni',
                        format: 'image/gif',               
                    },
           
                    {displayInLayerSwitcher:true,isBaseLayer: false}
                );

        map.addControl(new OpenLayers.Control.LayerSwitcher());

        map.addLayers([openstreetmap,vecLayer]);

         var mapPanel= new GeoExt.MapPanel({
            renderTo:'mainpanel',
            height: 300,
            width: 950,
            map: map,
            center: new OpenLayers.LonLat(14.25080,40.84197).transform(new OpenLayers.Projection("EPSG:4326"), map.getProjectionObject()),
            maxExtent:new OpenLayers.Bounds(14.052,40.05,14.967,40.917).transform(new  OpenLayers.Projection("EPSG:4326"),map.getProjectionObject()),
            zoom:4,
            maxResolution: 0.00138671875,
            title: 'Mappa '
        });
   
    }); 

Il giorno 28 ottobre 2011 17:05, Luca Casagrande <[hidden email]> ha scritto:
Il 28/10/2011 16:34, Nicola De Innocentis ha scritto:
Ciao a tutti,
studiando l'oggetto mapPanel di GeoExt,osservo che questi due semplici layer li riesco a visualizzare sovrapposti correttamente soltanto se lo zoom non è cosi spinto (zomm circa pari a 4),
non appena aumento lo zoom il layer wms (che prelevo dal localhost da Geoserver) mi scompare. Non so se è un problema di proiezione ma mi sembra strano.Grazie anticipatamente.

--
Nicola De Innocentis

www.nicoladeinnocentis.it <http://www.nicoladeinnocentis.it>



Il problema è strano, ma purtroppo senza codice o altri dettagli non possiamo essere di aiuto.
Vale sempre installare FireBug e verificare la chiamata quando cambi lo zoom.

Ciao
Luca




--
Nicola De Innocentis

www.nicoladeinnocentis.it


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
527 iscritti al 7.7.2011
Reply | Threaded
Open this post in threaded view
|

Re: Problema proiezioni tra openstreetmap e un wms in un mapPanel di GeoExt

luca.casagrande@gmail.com

Puoi incollare la richiesta che viene passata a GeoServer quando vari lo
zoom?

L.

Il 28/10/2011 17:11, Nicola De Innocentis ha scritto:

> Il codice è piccolo e abbastanza semplice, lo  giro, perchè non riesco
> a capire dove possa esserci l'errore:
>
>         Ext.onReady(function(){
>
>     var    map = new OpenLayers.Map ("map");
>
>     var openstreetmap = new OpenLayers.Layer.OSM();
>
>
>    var vecLayer= new OpenLayers.Layer.WMS(
>                     "associazioni", "http://localhost/geoserver/wms",
>                     {
>                         width: '631',
>                         srs: 'EPSG:4326',
>                         layers: 'topp:associazioni',
>                         format: 'image/gif',
>                     },
>
>                     {displayInLayerSwitcher:true,isBaseLayer: false}
>                 );
>
>         map.addControl(new OpenLayers.Control.LayerSwitcher());
>
>         map.addLayers([openstreetmap,vecLayer]);
>
>          var mapPanel= new GeoExt.MapPanel({
>             renderTo:'mainpanel',
>             height: 300,
>             width: 950,
>             map: map,
>             center: new
> OpenLayers.LonLat(14.25080,40.84197).transform(new
> OpenLayers.Projection("EPSG:4326"), map.getProjectionObject()),
>             maxExtent:new
> OpenLayers.Bounds(14.052,40.05,14.967,40.917).transform(new  
> OpenLayers.Projection("EPSG:4326"),map.getProjectionObject()),
>             zoom:4,
>             maxResolution: 0.00138671875,
>             title: 'Mappa '
>         });
>
>     });
>
> Il giorno 28 ottobre 2011 17:05, Luca Casagrande
> <[hidden email] <mailto:[hidden email]>> ha scritto:
>
>     Il 28/10/2011 16:34, Nicola De Innocentis ha scritto:
>
>         Ciao a tutti,
>         studiando l'oggetto mapPanel di GeoExt,osservo che questi due
>         semplici layer li riesco a visualizzare sovrapposti
>         correttamente soltanto se lo zoom non è cosi spinto (zomm
>         circa pari a 4),
>         non appena aumento lo zoom il layer wms (che prelevo dal
>         localhost da Geoserver) mi scompare. Non so se è un problema
>         di proiezione ma mi sembra strano.Grazie anticipatamente.
>
>         --
>         Nicola De Innocentis
>
>         www.nicoladeinnocentis.it <http://www.nicoladeinnocentis.it>
>         <http://www.nicoladeinnocentis.it>
>
>
>
>     Il problema è strano, ma purtroppo senza codice o altri dettagli
>     non possiamo essere di aiuto.
>     Vale sempre installare FireBug e verificare la chiamata quando
>     cambi lo zoom.
>
>     Ciao
>     Luca
>
>
>
>
> --
> Nicola De Innocentis
>
> www.nicoladeinnocentis.it <http://www.nicoladeinnocentis.it>
>
>
>
> _______________________________________________
> Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> Non inviate messaggi commerciali.
> I messaggi di questa lista non rispecchiano necessariamente
> le posizioni dell'Associazione GFOSS.it.
> 527 iscritti al 7.7.2011

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
527 iscritti al 7.7.2011
Reply | Threaded
Open this post in threaded view
|

Re: Problema proiezioni tra openstreetmap e un wms in un mapPanel di GeoExt

Nicola De Innocentis
spero sia questo ciò che richiedevi,con firebug ho esplorato i vari div nel body,ho trovato questo:

<img id="OpenLayersDiv117" class="olTileImage" style="width: 256px; height: 256px; position: relative;" src="http://localhost/geoserver/wms?WIDTH=256&SRS=EPSG%3A900913&LAYERS=topp%3Aassociazioni&FORMAT=image%2Fgif&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&BBOX=-180,-90,2504508.5425,2504598.5425&HEIGHT=256">




Il giorno 28 ottobre 2011 17:17, Luca Casagrande <[hidden email]> ha scritto:

Puoi incollare la richiesta che viene passata a GeoServer quando vari lo zoom?

L.

Il 28/10/2011 17:11, Nicola De Innocentis ha scritto:
Il codice è piccolo e abbastanza semplice, lo  giro, perchè non riesco a capire dove possa esserci l'errore:

       Ext.onReady(function(){

   var    map = new OpenLayers.Map ("map");

   var openstreetmap = new OpenLayers.Layer.OSM();


  var vecLayer= new OpenLayers.Layer.WMS(
                   "associazioni", "http://localhost/geoserver/wms",
                   {
                       width: '631',
                       srs: 'EPSG:4326',
                       layers: 'topp:associazioni',
                       format: 'image/gif',
                   },

                   {displayInLayerSwitcher:true,isBaseLayer: false}
               );

       map.addControl(new OpenLayers.Control.LayerSwitcher());

       map.addLayers([openstreetmap,vecLayer]);

        var mapPanel= new GeoExt.MapPanel({
           renderTo:'mainpanel',
           height: 300,
           width: 950,
           map: map,
           center: new OpenLayers.LonLat(14.25080,40.84197).transform(new OpenLayers.Projection("EPSG:4326"), map.getProjectionObject()),
           maxExtent:new OpenLayers.Bounds(14.052,40.05,14.967,40.917).transform(new  OpenLayers.Projection("EPSG:4326"),map.getProjectionObject()),
           zoom:4,
           maxResolution: 0.00138671875,
           title: 'Mappa '
       });

   });

Il giorno 28 ottobre 2011 17:05, Luca Casagrande <[hidden email] <mailto:[hidden email]>> ha scritto:


   Il 28/10/2011 16:34, Nicola De Innocentis ha scritto:

       Ciao a tutti,
       studiando l'oggetto mapPanel di GeoExt,osservo che questi due
       semplici layer li riesco a visualizzare sovrapposti
       correttamente soltanto se lo zoom non è cosi spinto (zomm
       circa pari a 4),
       non appena aumento lo zoom il layer wms (che prelevo dal
       localhost da Geoserver) mi scompare. Non so se è un problema
       di proiezione ma mi sembra strano.Grazie anticipatamente.

       --         Nicola De Innocentis

       www.nicoladeinnocentis.it <http://www.nicoladeinnocentis.it>
       <http://www.nicoladeinnocentis.it>



   Il problema è strano, ma purtroppo senza codice o altri dettagli
   non possiamo essere di aiuto.
   Vale sempre installare FireBug e verificare la chiamata quando
   cambi lo zoom.

   Ciao
   Luca




--
Nicola De Innocentis

www.nicoladeinnocentis.it <http://www.nicoladeinnocentis.it>



_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
527 iscritti al 7.7.2011




--
Nicola De Innocentis

www.nicoladeinnocentis.it


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
Non inviate messaggi commerciali.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
527 iscritti al 7.7.2011