Problema visualizzazione raster in lizmap

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema visualizzazione raster in lizmap

Emanuele Tataranni
This post was updated on .
Sto realizzando un webGIS mediante Lizmap.
Dopo aver lavorato in locale su apache, ho lanciato online su un server centos 6.6 il mio webgis. Tuttavia ora riscontro i seguenti problemi.
Vengono visualizzati solo i file vettoriali (layer "punti"), mentre i raster non vengono visualizzati nonostante tutti i file sono stati copiati correttamente sul server ed i percorsi sono corretti.
La legenda del layer "punti" non viene visualizzata correttamente.
Inoltre avevo un file di tipo .asc (layer "maggio-dicembre") che veniva visualizzato correttamente in localhost mentre sul server online non viene visualizzato e non viene caricata la legenda.
Ho fatto ulteriori prove creando nuovi file e riscontro sempre lo stesso problema: online vengono sempre visualizzati i file vettoriali mentre non vengono mai visualizzati i file raster.
Ho controllato che a tutti i file siano garantiti tutti i permessi di lettura e scrittura ed inoltre in  /var/log/ di apache l'unico errore riscontrato è

[Mon Mar 23 15:44:56 2015] [error] [client 127.0.0.1] Premature end of script headers: qgis_mapserv.fcgi
[Mon Mar 23 15:44:56 2015] [error] [client 10.246.1.138] 2015-03-23 15:44:56\t10.246.1.138\twarning\t2015-03-23 15:44:56\t[2]\tfile_get_contents(http://127.0.0.1/cgi-bin/qgis_mapserv.fcgi?dpi=96&exceptions=application%2Fvnd%2Eogc%2Ese%5Finimage&format=image%2Fpng&iconlabelspace=2&itemfontsize=9&layerfontbold=FALSE&layerfontsize=0&layers=maggio%2Ddicembre&layerspace=0&layertitle=FALSE&map=%2Fhome%2Fwi%2Dgis%2Fpublic%5Fhtml%2Flizmap%2Dweb%2Dclient%2D2%2E10%2E0%2Flizmap%2Fwebgis%2Fprova%2Eqgs&request=GetLegendGraphic&service=WMS&symbolspace=1&transparent=TRUE&version=1%2E3%2E0&width=150): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error\r\n\t/home/wi-gis/public_html/lizmap-web-client-2.10.0/lizmap/modules/lizmap/classes/lizmapCache.class.php\t85\n, referer: http://wi-gis.pi.ingv.it/lizmap-web-client-2.10.0/lizmap/www/index.php/view/map/?repository=webgis&project=prova
[Mon Mar 23 15:48:47 2015] [error] [client 10.246.1.138] File does not exist: /home/wi-gis/public_html/lizmap-web-client-2.10.0/lizmap/www/webgis


Sarei grato se mi aiutaste a risolvere questi problemi!
Grazie infinite.

Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

pcav
Il 23/03/2015 17:16, Emanuele Tataranni ha scritto:

> La legenda del layer "punti" non viene visualizzata correttamente.

qui mi pare un problema di fonts, no?
Saluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

Emanuele Tataranni
Grazie ho risolto, è bastato installare i fonts sul server centos (che era un server non grafico) ed ora viene visualizzato correttamente tutto: legende, raster e file .asc.

Grazie mille!
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

pcav
Il 24/03/2015 11:48, Emanuele Tataranni ha scritto:
> Grazie ho risolto, è bastato installare i fonts sul server centos (che era un
> server non grafico) ed ora viene visualizzato correttamente tutto: legende,
> raster e file .asc.

ottimo. strano pero' che la mancanza di fonts impedisse la
visualizzazione dei raster. credo che questo sia un bug, puoi sollevare
la questione in mailing list qgis-dev?
Saluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

Emanuele Tataranni
Niente entusiasmo...ripresenta sempre lo stesso errore..
dallo stress mi sono sbagliato e ho visto la pagina in locale anziché quella online che come potete continuare a vedere presenta sempre gli stessi errori..
Sembra quindi che installare i fonts non abbia portato i frutti tanto desiderati.
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

Emanuele Tataranni
This post was updated on .
In reply to this post by Emanuele Tataranni
vi do una ulteriore informazione..
affinchè Lizmap potesse funzionare è stato necessario cambiare il path di alcuni file che sono stati installati automaticamente sul server centos

cd /var/www/cgi-bin (CARTELLA DI DESTINAZIONE)
cp /usr/libexec/qgis/qgis_mapserv.fcgi (QUESTA ERA LA CARTELLA DOVE ERA STATO INSTALLATO INIZIALMENTE) . 


Non vorrei che ci sia bisogno di cambiare il path di alcuni file di Lizmap per risolvere il problema della visualizzazione dei raster..
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

pcav
Il 25/03/2015 11:12, Emanuele Tataranni ha scritto:

> Non vorrei che ci sia bisogno di cambiare il path di alcuni file di Lizmap
> per risolvere il problema della visualizzazione dei raster..

probabile. t conviene partire da una sitazione piu' liscia e standard
possibile.
saluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

Emanuele Tataranni
Ho finalmente risolto il problema della visualizzazione dei file raster di tipo tif e jpg. Il problema era dovuto alla mia versione di Qgis mapserver installata che era troppo vecchia (1.8). L'ho aggiornata con una più recente ed ora si vedono online.
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

pcav
Il 26/03/2015 14:42, Emanuele Tataranni ha scritto:
> Ho finalmente risolto il problema della visualizzazione dei file raster di
> tipo tif e jpg. Il problema era dovuto alla mia versione di Qgis mapserver
> installata che era troppo vecchia (1.8). L'ho aggiornata con una più recente
> ed ora si vedono online.

1.8???? ripetete con me il mantra: aggiornare sempre :)
saluti, meglio cosi'.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

Paolo Corti
2015-03-26 14:46 GMT+01:00 Paolo Cavallini <[hidden email]>:
> Il 26/03/2015 14:42, Emanuele Tataranni ha scritto:
>> Ho finalmente risolto il problema della visualizzazione dei file raster di
>> tipo tif e jpg. Il problema era dovuto alla mia versione di Qgis mapserver
>> installata che era troppo vecchia (1.8). L'ho aggiornata con una più recente
>> ed ora si vedono online.
>
> 1.8???? ripetete con me il mantra: aggiornare sempre :)
> saluti, meglio cosi'.
>

su Centos 6.5 non esistono pacchetti ufficiali per QGIS > 1.8 ed e'
durissima installare le versioni successive.

Tempo fa ho provato a compilare con scarso successo il 2.6 e 2.8,
operazione improba a causa di numerose dipendenze non disponibili e
non ultimissima versione del compilatore [1].

Questo nell'ipotesi che per installare QGIS mapserver si debba
installare anche QGIS (non conosco la componente mapserver).
Emanuele come hai installato QGIS e che versione?

ciao
p

[1] http://lists.osgeo.org/pipermail/qgis-user/2015-February/030993.html

--
Paolo Corti
Geospatial software developer
web: http://www.paolocorti.net
twitter: @capooti
skype: capooti
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problema visualizzazione raster in lizmap

Emanuele Tataranni
x installare qgis ho seguito la procedura presente su http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial

per aggiornare mapserver mi ha aiutato un sistemista:

###update mapserver####
sudo wget fedora.vitu.ch/EL/qgis.repo -P /etc/yum.repos.d/
sudo rpm --import http://fedora.vitu.ch/Fedora/RPM-GPG-Key-vitu
sudo yum update
cp /usr/libexec/qgis/qgis_mapserv.fcgi /var/www/cgi-bin/
###fine update mapserver###