Problemi di Avvio PPT (python photogrammetry Toolbox)

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Problemi di Avvio PPT (python photogrammetry Toolbox)

Carlo Di Michele
Salve a tutti,
dopo varie peripezie sono riuscito a scaricare ed installare il PPT Versione Windows 64bit (ho aperto questo ticket perché diverso da quello Software per restituzione fotogrammetrica ed elaborazione dati)

Ho eseguito pedissequamente quanto riportato sul sito della arc_team http://184.106.205.13/arcteam/ppt.php ma quando lancio ppt_gui_start.bat esce il seguente errore:

"File "ppt_guy.py", line 15
self.tabWidget = QtGui.QTabWidget(self)

Tab error: inconsiste use of tabs and spaces in indentation

pause
premi un tasto per conitnuare...."

Qualcuno potrebbe aver capito quale sia il problema?

Grazie
Carlo

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problemi di Avvio PPT (python photogrammetry Toolbox)

geodrinx
Ciao Carlo,

Il giorno 09/ott/2015, alle ore 16:33, Carlo Di Michele <[hidden email]> ha scritto:

Ho eseguito pedissequamente quanto riportato sul sito della arc_team http://184.106.205.13/arcteam/ppt.php ma quando lancio ppt_gui_start.bat esce il seguente errore:

"File "ppt_guy.py", line 15
self.tabWidget = QtGui.QTabWidget(self)

Tab error: inconsiste use of tabs and spaces in indentation


Questo errore vuol dire che è stato modificato il sorgente python indicato, inserendo dei caratteri all'interno della riga 15. 
Per caso, hai fatto delle modifiche ?  Potresti aver salvato il file dopo aver inserito senza accorgertene uno spazio (oppure un tab). 
Python è molto sensibile riguardo all'indentazione (cioè all'incolonnamento). 
Oppure, è possibile che la versione attualmente in linea di PPT non sia stata testata (cioè provata), ma questo mi sembra meno probabile. 
Prova a ri-scaricare PPT (in un'altra directory, ovvero cartella) e confronta le due versioni di ppt_guy.py  (a proposito: è scritto proprio così, oppure lo hai ricopiato tu a memoria ? )

Fammi sapere l'esito dei tuoi controlli

A presto

Roberto

Ps: comunque, per risolvere l'errore, puoi copiare l'incolonnamento dalla linea precedente

.
pause
premi un tasto per conitnuare...."

Qualcuno potrebbe aver capito quale sia il problema?

Grazie
Carlo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problemi di Avvio PPT (python photogrammetry Toolbox)

Carlo Di Michele
Ciao Roberto,
io non ho toccato assolutamente niente del file come é stato scaricato ed ho già fatto la prova di rieseguire l'intera procedura di installazione cancellando quanto già installato.

Ho avuto qualche piccola esperienza in python e so che é molto sensibile all'indentatura.

Ho seguito il tuo consiglio del copia ed incolla ed adesso non da più questo errore :-) ma un'altro :-(

File "ppt_gui.py" Line 6
   From PyQt4 import QtGui
   Import error: no module named 'PyQt4'

Ho verificato nel "site-packages" del python26 se esiste PyQt4 e c'é;
Ho verificato se c'é un file chiamato QtGui ed ho trovato QtGui.pyd;

Altri suggerimenti?

Grazie
Saluti
Carlo



Il giorno 9 ottobre 2015 16:41, <[hidden email]> ha scritto:
Ciao Carlo,

Il giorno 09/ott/2015, alle ore 16:33, Carlo Di Michele <[hidden email]> ha scritto:

Ho eseguito pedissequamente quanto riportato sul sito della arc_team http://184.106.205.13/arcteam/ppt.php ma quando lancio ppt_gui_start.bat esce il seguente errore:

"File "ppt_guy.py", line 15
self.tabWidget = QtGui.QTabWidget(self)

Tab error: inconsiste use of tabs and spaces in indentation


Questo errore vuol dire che è stato modificato il sorgente python indicato, inserendo dei caratteri all'interno della riga 15. 
Per caso, hai fatto delle modifiche ?  Potresti aver salvato il file dopo aver inserito senza accorgertene uno spazio (oppure un tab). 
Python è molto sensibile riguardo all'indentazione (cioè all'incolonnamento). 
Oppure, è possibile che la versione attualmente in linea di PPT non sia stata testata (cioè provata), ma questo mi sembra meno probabile. 
Prova a ri-scaricare PPT (in un'altra directory, ovvero cartella) e confronta le due versioni di ppt_guy.py  (a proposito: è scritto proprio così, oppure lo hai ricopiato tu a memoria ? )

Fammi sapere l'esito dei tuoi controlli

A presto

Roberto

Ps: comunque, per risolvere l'errore, puoi copiare l'incolonnamento dalla linea precedente

.
pause
premi un tasto per conitnuare...."

Qualcuno potrebbe aver capito quale sia il problema?

Grazie
Carlo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problemi di Avvio PPT (python photogrammetry Toolbox)

Giuliano Curti
Il giorno Sat, 10 Oct 2015 13:38:18 +0100
Carlo Di Michele <[hidden email]> ha scritto:

ciao Carlo,


> ...... ma un'altro :-(
>
> File "ppt_gui.py" Line 6
>    From PyQt4 import QtGui
>    Import error: no module named 'PyQt4'
>
> Ho verificato nel "site-packages" del python26 se esiste PyQt4 e c'é;
> Ho verificato se c'é un file chiamato QtGui ed ho trovato QtGui.pyd;

questo è un errore che dà quando non trova un modulo, normalmente
perchè il path non è corretto; trattandosi però di un modulo di sistema
è molto strano: hai provato a dare il comando da una console python?

nel sistema che uso io (debian wheezy) ho installato il pacchetto
python-qt4 (ho notato che i moduli QtGui e QtCore sono *.so);


> Grazie
> Saluti
> Carlo

ciao,
giuliano
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problemi di Avvio PPT (python photogrammetry Toolbox)

Carlo Di Michele
Ciao a tutti,
il file ppt_gui_start.bat non mi funziona :-( . Dopo una serie di tentativi sono riuscito a farlo partire manualmente direttamente dalla Shell di Windows (peraltro come consigliato da Giuliano) dalla directory C:\osm-bundler\osm-bundlerWin64 ho digitato il seguente comando "c:\python26\python ppt_gui.py" ed é partito il software ppt.

Ho programmato la stessa cosa attraverso un file batch ma non ci sono riuscito  (forse sbaglio la sintassi).

Comunque sia manualmente in questa maniera ppt mi funziona.

Procedo quindi con il caricamento delle immagini che ho inserito in una cartella. Quando carico seleziono la cartella e le foto (mentre sono sulla linguetta di Bundler) e lancio il comando Run non succede niente sulla GUI di ppt (neanche un messaggio) ma nella console di windows c'é un errore alla linea 89:


SyntaxError: invalid syntax

 C:\osm-bundler\osm-bundlerWin64\osm-bundler\__init__.py

Raise exception, "'%s' is neither directory nor a file name" % self.photosArg


Questa volta é un SyntaxError che apparentemente é comunque legato  a come sarà scritto qualche percorso. Nessuno ha un tutorial passo passo di come utilizzarlo una guida che dica come procedere, un forum o qualcosa del genere?


Ringrazio anticipatamente per qualunque indizio o info.

Saluti
Carlo



Il giorno 10 ottobre 2015 15:23, giulianc51 <[hidden email]> ha scritto:
Il giorno Sat, 10 Oct 2015 13:38:18 +0100
Carlo Di Michele <[hidden email]> ha scritto:

ciao Carlo,


> ...... ma un'altro :-(
>
> File "ppt_gui.py" Line 6
>    From PyQt4 import QtGui
>    Import error: no module named 'PyQt4'
>
> Ho verificato nel "site-packages" del python26 se esiste PyQt4 e c'é;
> Ho verificato se c'é un file chiamato QtGui ed ho trovato QtGui.pyd;

questo è un errore che dà quando non trova un modulo, normalmente
perchè il path non è corretto; trattandosi però di un modulo di sistema
è molto strano: hai provato a dare il comando da una console python?

nel sistema che uso io (debian wheezy) ho installato il pacchetto
python-qt4 (ho notato che i moduli QtGui e QtCore sono *.so);


> Grazie
> Saluti
> Carlo

ciao,
giuliano
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: Problemi di Avvio PPT (python photogrammetry Toolbox)

mando
In reply to this post by Giuliano Curti

Secondo me devi scrivere in lista dai bezzi dell'arc team.

Il 10/ott/2015 16:31, "giulianc51" <[hidden email]> ha scritto:
Il giorno Sat, 10 Oct 2015 13:38:18 +0100
Carlo Di Michele <[hidden email]> ha scritto:

ciao Carlo,


> ...... ma un'altro :-(
>
> File "ppt_gui.py" Line 6
>    From PyQt4 import QtGui
>    Import error: no module named 'PyQt4'
>
> Ho verificato nel "site-packages" del python26 se esiste PyQt4 e c'é;
> Ho verificato se c'é un file chiamato QtGui ed ho trovato QtGui.pyd;

questo è un errore che dà quando non trova un modulo, normalmente
perchè il path non è corretto; trattandosi però di un modulo di sistema
è molto strano: hai provato a dare il comando da una console python?

nel sistema che uso io (debian wheezy) ho installato il pacchetto
python-qt4 (ho notato che i moduli QtGui e QtCore sono *.so);


> Grazie
> Saluti
> Carlo

ciao,
giuliano
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015