QGIS 2.8 per Win: errore di georeferenziazione per raster con valori di rotazione diversi da zero nel file wld

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS 2.8 per Win: errore di georeferenziazione per raster con valori di rotazione diversi da zero nel file wld

Marco
Sistema operativo Win 7 a 64bit.
QGIS 2.8 installato con OSGeo4W.
Ho creato un progetto orientato nel sistema di riferimento EPSG 3004, nel quale ho caricato diversi raster tematici (urbanistica) riguardanti il territorio del mio comune (CTR, Piano paesaggistico, PSAI, PRG, ecc.) oltre a vari layer vettoriali (Fogli catastali, ecc.).
Fino alla versione 2.6 ha sempre funzionato tutto alla perfezione.
Con la 2.8 però mi capita un problema “singolare”, nel senso che riguarda solo uno dei layer raster che vado a caricare nel progetto.
Più in dettaglio, all’apertura del progetto, mi carica correttamente tutti i layer ma non riesce a georeferenziare il layer del raster PRG e me lo posiziona con il vertice in basso a sinistra incardinato alla coordinata, più o meno, x = 0 e y = - 8000 e spicci.
Però, se lo stesso raster e con gli stessi wld lo apro con la 2.0 Portable fornita dall’ARPA (è l’unica versione ante 2.8 che mi ritrovo, avendo cancellato dal PC la 2.4 e la 2.6), tutto funziona perfettamente, (quindi vuol dire che il file wld non è corrotto e che il raster è leggibile).
Credo che il problema sia in qualche limite di interpretazione del file wld da parte della 2.8, che invece la 2.0 non ha (e la 2.4 e la 2.6, quando erano installate sul mio PC, non avevano). Infatti, a differenza di tutti gli altri wld (e tfw, ecc.) degli altri raster del mio archivio (che vengono aperti tranquillamente da QGIS 2.8), i wld del raster PRG in questione presentano dei valori di rotazione diversi da zero …visto che è l’unica cosa che differenzia questi wld dagli altri e, visto che gli altri si aprono e questi no, …secondo voi è possibile che il problema sia proprio questo?

Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.8 per Win: errore di georeferenziazione per raster con valori di rotazione diversi da zero nel file wld

Stefano Iacovella
Ciao Marco,

prova a farti una copia di backup del file wld e nell'altro elimina i valori di rotazione portandoli a 0.
Se funziona è probabile che il problema sia proprio li.

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

Il giorno 9 aprile 2015 16:27, Marco <[hidden email]> ha scritto:
Sistema operativo Win 7 a 64bit.
QGIS 2.8 installato con OSGeo4W.
Ho creato un progetto orientato nel sistema di riferimento EPSG 3004, nel
quale ho caricato diversi raster tematici (urbanistica) riguardanti il
territorio del mio comune (CTR, Piano paesaggistico, PSAI, PRG, ecc.) oltre
a vari layer vettoriali (Fogli catastali, ecc.).
Fino alla versione 2.6 ha sempre funzionato tutto alla perfezione.
Con la 2.8 però mi capita un problema “singolare”, nel senso che riguarda
solo uno dei layer raster che vado a caricare nel progetto.
Più in dettaglio, all’apertura del progetto, mi carica correttamente tutti i
layer ma non riesce a georeferenziare il layer del raster PRG e me lo
posiziona con il vertice in basso a sinistra incardinato alla coordinata,
più o meno, x = 0 e y = - 8000 e spicci.
Però, se lo stesso raster e con gli stessi wld lo apro con la 2.0 Portable
fornita dall’ARPA (è l’unica versione ante 2.8 che mi ritrovo, avendo
cancellato dal PC la 2.4 e la 2.6), tutto funziona perfettamente, (quindi
vuol dire che il file wld non è corrotto e che il raster è leggibile).
Credo che il problema sia in qualche limite di interpretazione del file wld
da parte della 2.8, che invece la 2.0 non ha (e la 2.4 e la 2.6, quando
erano installate sul mio PC, non avevano). Infatti, a differenza di tutti
gli altri wld (e tfw, ecc.) degli altri raster del mio archivio (che vengono
aperti tranquillamente da QGIS 2.8), i wld del raster PRG in questione
presentano dei valori di rotazione diversi da zero …visto che è l’unica cosa
che differenzia questi wld dagli altri e, visto che gli altri si aprono e
questi no, …secondo voi è possibile che il problema sia proprio questo?





--
View this message in context: http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/QGIS-2-8-per-Win-errore-di-georeferenziazione-per-raster-con-valori-di-rotazione-diversi-da-zero-neld-tp7592149.html
Sent from the Gfoss -- Geographic Free and Open Source Software - Italian mailing list mailing list archive at Nabble.com.
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.8 per Win: errore di georeferenziazione per raster con valori di rotazione diversi da zero nel file wld

pcav
In reply to this post by Marco
Il 09/04/2015 16:27, Marco ha scritto:

> presentano dei valori di rotazione diversi da zero …visto che è l’unica cosa
> che differenzia questi wld dagli altri e, visto che gli altri si aprono e
> questi no, …secondo voi è possibile che il problema sia proprio questo?

si', e' un bug noto di QGIS 2.8.1, gia' sistemato in master, in attesa
della 2.8.2 (sto lavorando perche' esca presto)
saluti

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.8 per Win: errore di georeferenziazione per raster con valori di rotazione diversi da zero nel file wld

Marco
In reply to this post by Stefano Iacovella
Stefano Iacovella wrote
Ciao Marco,

prova a farti una copia di backup del file wld e nell'altro elimina i
valori di rotazione portandoli a 0.
Se funziona è probabile che il problema sia proprio li.

Stefano
Ho provato e funziona.
Ovviamente ora i raster risultano leggermente spostati rispetto all'originale georeferenziazione, ma non sarà un problema rimetterli "a posto" con il georeferenziatore di QGIS, perchè si trattava di rotazioni blande e quindi lo scarto è di qualche decina di metri ...con due o tre punti ben assestati li "raddrizzo" subito subito.
Grazie.
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.8 per Win: errore di georeferenziazione per raster con valori di rotazione diversi da zero nel file wld

Marco
In reply to this post by pcav
pcav wrote
si', e' un bug noto di QGIS 2.8.1, gia' sistemato in master, in attesa
della 2.8.2 (sto lavorando perche' esca presto)
saluti
Paolo Cavallini - www.faunalia.eu
Grazie.
Volevo aggiungere, se può essere utile, che se nel file wld (o tfw, ecc.) ci sono valori di rotazione diversi da zero, allora QGIS (in questo caso non solo la 2.8 ma anche la 2.0, la 2.4 e la 2.6), oltre a manifestare il bug di cui sopra, non riesce a fare neanche il "Catalogo" di auto-mosaicazione di più raster.

P.S. Ho visto  http://qgis.it ...Ottimo !!!