QGIS TileLayer Plugin e Mapbox

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS TileLayer Plugin e Mapbox

Luca Moiana
Ciao,


seguendo questa guida:

Sto cercando di caricare, con TileLayer plugin, un progetto MapBox come mappa di sfondo, senza riuscirci.
Ho provato: OSX QGIS 2.8, Win7 QGIS 2.01 portable

Con Notepad++ creo un tsv, con questa linea:
Mapbox  Mapbox  http://api.tiles.mapbox.com/v4/{lucamoiana.jc4a9gcl}/{z}/{x}/{y}.png?access_token={XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX}

Tramite plugin aggiungo il tsv e setto il download time a 30esc.

Una volta dato ok, visualizzo il mapbox.tsv ma non c'è indirizzo della mappa e non carica nulla.

Ho provato a usare anche degli esempi:
Hôtels parisiens AdrienVH http://a.tiles.mapbox.com/v3/adrienvh.hf43flld/{z}/{x}/{y}.png 1 13 17
Arcgis  Arcgis  http://server.arcgisonline.com/ArcGIS/rest/services/World_Topo_Map/MapServer/tile/{z}/{y}/{x}.png   1   0   16  -180    -85.0   180.0   85.0

In questo caso, vedo indirizzo e aggiunge il layer ma da un errore in fase di download.

Cosa sbaglio?


GRAZIE


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

QGIS TileLayer Plugin e Mapbox

Luca Moiana
Ciao,


seguendo questa guida:

Sto cercando di caricare, con TileLayer plugin, un progetto MapBox come mappa di sfondo, senza riuscirci.
Ho provato: OSX QGIS 2.8, Win7 QGIS 2.01 portable

Con Notepad++ creo un tsv, con questa linea:
Mapbox  Mapbox  http://api.tiles.mapbox.com/v4/{lucamoiana.jc4a9gcl}/{z}/{x}/{y}.png?access_token={XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX}

Tramite plugin aggiungo il tsv e setto il download time a 30esc.

Una volta dato ok, visualizzo il mapbox.tsv ma non c'è indirizzo della mappa e non carica nulla.

Ho provato a usare anche degli esempi:
Hôtels parisiens AdrienVH http://a.tiles.mapbox.com/v3/adrienvh.hf43flld/{z}/{x}/{y}.png 1 13 17
Arcgis  Arcgis  http://server.arcgisonline.com/ArcGIS/rest/services/World_Topo_Map/MapServer/tile/{z}/{y}/{x}.png   1   0   16  -180    -85.0   180.0   85.0

In questo caso, vedo indirizzo e aggiunge il layer ma da un errore in fase di download.

Cosa sbaglio?


GRAZIE


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: QGIS TileLayer Plugin e Mapbox

aborruso
Administrator
In reply to this post by Luca Moiana
Ciao Luca,

Luca Moiana wrote
seguendo questa guida:https://www.mapbox.com/guides/georeferencing-imagery/
Sto cercando di caricare, con TileLayer plugin, un progetto MapBox come mappa di sfondo, senza riuscirci.Ho provato: OSX QGIS 2.8, Win7 QGIS 2.01 portable
non risponderò esattamente alla tua domanda, ma magari quanto ti scrivo ti sarà utile.

Se vuoi usare una base mapbox come sfondo in QGIS, puoi usare i gdal minidriver. Apri un notepad e scrivici dentro qualcosa di simile:
<GDAL_WMS>
    <Service name="TMS">        <ServerUrl>http://api.tiles.mapbox.com/v4/nomeutente.ilc3l20e/${z}/${x}/${y}.png?access_token=machebeltoken</ServerUrl>
    </Service>
    <DataWindow>
        <UpperLeftX>-20037508.34</UpperLeftX>
        <UpperLeftY>20037508.34</UpperLeftY>
        <LowerRightX>20037508.34</LowerRightX>
        <LowerRightY>-20037508.34</LowerRightY>
        <TileLevel>18</TileLevel>
        <TileCountX>1</TileCountX>
        <TileCountY>1</TileCountY>
        <YOrigin>top</YOrigin>
    </DataWindow>
    <Projection>EPSG:3857</Projection>
    <BlockSizeX>256</BlockSizeX>
    <BlockSizeY>256</BlockSizeY>
    <BandsCount>3</BandsCount>
    <Cache />
</GDAL_WMS>

Salva con nome (mapbox.wms) e fai il drag & drop di questo file su QGIS. Avrai come sfondo il tuo layer mapbox.

Saluti
Andrea Borruso

----------------------------------------------------
twitter: https://twitter.com/aborruso
website: https://medium.com/tantotanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: QGIS TileLayer Plugin e Mapbox

aborruso
Administrator
In reply to this post by Luca Moiana
Ciao Luca,

Luca Moiana wrote
Una volta dato ok, visualizzo il mapbox.tsv ma non c'è indirizzo della mappa e non carica nulla.
ho provato anche la tua procedura e funziona. Nel file tsv hai usato la tabulazione come separatore?
Andrea Borruso

----------------------------------------------------
twitter: https://twitter.com/aborruso
website: https://medium.com/tantotanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: QGIS TileLayer Plugin e Mapbox

Luca Moiana
In reply to this post by Luca Moiana
Facevo l'errore di lasciare le {} nella stringa:

Mapbox  Mapbox  http://api.tiles.mapbox.com/v4/{lucamoiana.jc4a9gcl}/{z}/{x}/{y}.png?access_token={XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX}

Eliminate quelle funziona alla grade; anche se resta il problema della risoluzione di stampa.

grazie

L



From: [hidden email]
To: [hidden email]
Date: Mon, 4 May 2015 10:26:09 +0000
Subject: [Gfoss] QGIS TileLayer Plugin e Mapbox

Ciao,


seguendo questa guida:

Sto cercando di caricare, con TileLayer plugin, un progetto MapBox come mappa di sfondo, senza riuscirci.
Ho provato: OSX QGIS 2.8, Win7 QGIS 2.01 portable

Con Notepad++ creo un tsv, con questa linea:
Mapbox  Mapbox  http://api.tiles.mapbox.com/v4/{lucamoiana.jc4a9gcl}/{z}/{x}/{y}.png?access_token={XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX}

Tramite plugin aggiungo il tsv e setto il download time a 30esc.

Una volta dato ok, visualizzo il mapbox.tsv ma non c'è indirizzo della mappa e non carica nulla.

Ho provato a usare anche degli esempi:
Hôtels parisiens AdrienVH http://a.tiles.mapbox.com/v3/adrienvh.hf43flld/{z}/{x}/{y}.png 1 13 17
Arcgis  Arcgis  http://server.arcgisonline.com/ArcGIS/rest/services/World_Topo_Map/MapServer/tile/{z}/{y}/{x}.png   1   0   16  -180    -85.0   180.0   85.0

In questo caso, vedo indirizzo e aggiunge il layer ma da un errore in fase di download.

Cosa sbaglio?


GRAZIE


_______________________________________________ [hidden email] http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss Questa e' una lista di discussione pubblica aperta a tutti. I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it. 750 iscritti al 18.3.2015

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015