QGIS e supporto a ESRI geodatabase

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS e supporto a ESRI geodatabase

Luca Lanteri
ciao a tutti,

da alcune prove che ho fatto mi è parso di capire che la versione standalone di QGS non supporti i geodatabase di ESRI in formato .mdb, mentre la versione OSGEO si.
Qualcuno conferma  o sto prendendo un abbaglio ?
Nel caso, è possibile aggiungere il support alla versione standalone in qualche modo ?

grazie a tutti
Luca


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

pcav
Il 08/04/2014 14:57, Luca Lanteri ha scritto:

> da alcune prove che ho fatto mi è parso di capire che la versione
> standalone di QGS non supporti i geodatabase di ESRI in formato .mdb,
> mentre la versione OSGEO si.
> Qualcuno conferma  o sto prendendo un abbaglio ?
> Nel caso, è possibile aggiungere il support alla versione standalone in
> qualche modo ?

la standalone e' semplicamente l'impacchettamento dell'osgeo, per cui se
il comportamento descritto e' confermato, la spiegazione piu' ovvia e'
che nello standalone manchi un pacchetto.
conferme, da chi ha dati in quel bizzarro formato?
saluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Mattia De Agostino
Sull'installazione tramite OSGEO, gli MDB vengono aperti correttamente dal menu:
"Layer > Aggiungi Vettore"
e selezionando come tipo file la voce:
"ESRI Personal GeoDatabase [OGR]"

Rispetto alle vecchie versioni di QGIS, la compatibilità con questo formato (bizzarro, per carità, ma ancora molto diffuso) è aumentata moltissimo.

Mattia
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Luca Lanteri
grazie Paolo, grazie Mattia

Tra l'altro ho provato ad installare il supporto degli mdb su linux ma con scarso successo. 
Purtroppo alcuni utenti hanno necessità di leggere i dati dal "bizzarro formato" e preferirei fargli utilizzare la versione standalone per semplicità di installazione. Ho provato a chiedere anche il liasta qgis-user. Se il problema viene confermato proverò a chiedere alla lista di sviluppo. 

grazie a presto
Luca


Il giorno 08 aprile 2014 16:31, Mattia De Agostino <[hidden email]> ha scritto:
Sull'installazione tramite OSGEO, gli MDB vengono aperti correttamente dal
menu:
"Layer > Aggiungi Vettore"
e selezionando come tipo file la voce:
"ESRI Personal GeoDatabase [OGR]"

Rispetto alle vecchie versioni di QGIS, la compatibilità con questo formato
(bizzarro, per carità, ma ancora molto diffuso) è aumentata moltissimo.

Mattia



--
View this message in context: http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/QGIS-e-supporto-a-ESRI-geodatabase-tp7587636p7587638.html
Sent from the Gfoss -- Geographic Free and Open Source Software - Italian mailing list mailing list archive at Nabble.com.
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Luca Lanteri
In reply to this post by Mattia De Agostino
Ciao,

giusto una correzione. 
Il problema sembra essere con la versione 64bit (OSGEO e standalone). Con entrambe le versioni 32bit funziona tutto.

Luca


Il giorno 08 aprile 2014 16:31, Mattia De Agostino <[hidden email]> ha scritto:
Sull'installazione tramite OSGEO, gli MDB vengono aperti correttamente dal
menu:
"Layer > Aggiungi Vettore"
e selezionando come tipo file la voce:
"ESRI Personal GeoDatabase [OGR]"

Rispetto alle vecchie versioni di QGIS, la compatibilità con questo formato
(bizzarro, per carità, ma ancora molto diffuso) è aumentata moltissimo.

Mattia



--
View this message in context: http://gfoss-geographic-free-and-open-source-software-italian-mailing.3056002.n2.nabble.com/QGIS-e-supporto-a-ESRI-geodatabase-tp7587636p7587638.html
Sent from the Gfoss -- Geographic Free and Open Source Software - Italian mailing list mailing list archive at Nabble.com.
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

pcav
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Il 08/04/2014 17:11, Luca Lanteri ha scritto:
> Ciao,
>
> giusto una correzione.
> Il problema sembra essere con la versione 64bit (OSGEO e standalone). Con
> entrambe le versioni 32bit funziona tutto.

allora torna: hai verificato che la lib manchi dal 64 bit?
hai controllato che ci sia un ticket aperto su osgeo4w?
saluti, e grazie.

- --
Paolo Cavallini - www.faunalia.eu
Corsi QGIS e PostGIS: http://www.faunalia.eu/training.html
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with Icedove - http://www.enigmail.net/

iEYEARECAAYFAlNEF5cACgkQ/NedwLUzIr7+4gCfRZGovkcEQU8LFxR6aKbbnprZ
ttIAoKw7y2ouFI2mwvOLgn8IwLzF/rYo
=dOSS
-----END PGP SIGNATURE-----
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Francesco P. Lovergine
In reply to this post by Luca Lanteri
On Tue, Apr 08, 2014 at 04:42:13PM +0200, Luca Lanteri wrote:
> grazie Paolo, grazie Mattia
>
> Tra l'altro ho provato ad installare il supporto degli mdb su linux ma con
> scarso successo.

Elabora prego, hai seguito:

http://www.gdal.org/ogr/drv_pgeo.html

con quale scarso successo?


--
Francesco P. Lovergine
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Luca Lanteri
Si, ho seguito le indicazioni di http://www.gdal.org/ogr/drv_pgeo.html

il problema principale è che ho qualche problema con ogr2ogr






Il giorno 15 aprile 2014 13:52, Francesco P. Lovergine <[hidden email]> ha scritto:
On Tue, Apr 08, 2014 at 04:42:13PM +0200, Luca Lanteri wrote:
> grazie Paolo, grazie Mattia
>
> Tra l'altro ho provato ad installare il supporto degli mdb su linux ma con
> scarso successo.

Elabora prego, hai seguito:

http://www.gdal.org/ogr/drv_pgeo.html

con quale scarso successo?


--
Francesco P. Lovergine


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Luca Lanteri
scusa Francesco, ho inviato il messaggio prima di finire.

al momento sono bloccato con un problema legato alle ogr

ogrinfo --formats
ERROR 1: ogrinfo was compiled against GDAL 1.9 but current library version is 1.10

però mi pare che il pacchetto delle gdal sia quello giusto: 
Pacchetto: gdal-bin                                 
Stato: installato
Installato automaticamente: no
Versione: 1.10.1+dfsg-2~saucy1

temo di avere qualche libreria errata ma non ho ancora trovato soluzione.

Luca

Il giorno 28 aprile 2014 22:04, Luca Lanteri <[hidden email]> ha scritto:
Si, ho seguito le indicazioni di http://www.gdal.org/ogr/drv_pgeo.html

il problema principale è che ho qualche problema con ogr2ogr






Il giorno 15 aprile 2014 13:52, Francesco P. Lovergine <[hidden email]> ha scritto:

On Tue, Apr 08, 2014 at 04:42:13PM +0200, Luca Lanteri wrote:
> grazie Paolo, grazie Mattia
>
> Tra l'altro ho provato ad installare il supporto degli mdb su linux ma con
> scarso successo.

Elabora prego, hai seguito:

http://www.gdal.org/ogr/drv_pgeo.html

con quale scarso successo?


--
Francesco P. Lovergine



_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Francesco P. Lovergine
On Mon, Apr 28, 2014 at 10:11:27PM +0200, Luca Lanteri wrote:

> scusa Francesco, ho inviato il messaggio prima di finire.
>
> al momento sono bloccato con un problema legato alle ogr
>
> ogrinfo --formats
> ERROR 1: ogrinfo was compiled against GDAL 1.9 but current library version
> is 1.10
>
> però mi pare che il pacchetto delle gdal sia quello giusto:
> Pacchetto: gdal-bin
> Stato: installato
> Installato automaticamente: no
> Versione: 1.10.1+dfsg-2~saucy1
>
> temo di avere qualche libreria errata ma non ho ancora trovato soluzione.

Devi vedere che libreria libgdal1 o libgdal1h hai installato invece, anche
se mi pare piuttosto incredibile tu abbia installato un gdal-bin nuovo
mantenendo in essere la sola libreria vecchia. Hai sicuramente forzato
qualcosa in modo poco consigliabile. Il tutto è completamente indipendente
dal supporto o meno del formato ESRI.

--
Francesco P. Lovergine
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Francesco P. Lovergine
On Tue, Apr 29, 2014 at 09:07:41AM +0200, Francesco P. Lovergine wrote:

> >
> > ogrinfo --formats
> > ERROR 1: ogrinfo was compiled against GDAL 1.9 but current library version
> > is 1.10
> >
> > però mi pare che il pacchetto delle gdal sia quello giusto:
> > Pacchetto: gdal-bin
> > Stato: installato
> > Installato automaticamente: no
> > Versione: 1.10.1+dfsg-2~saucy1
> >
> > temo di avere qualche libreria errata ma non ho ancora trovato soluzione.
>
> Devi vedere che libreria libgdal1 o libgdal1h hai installato invece, anche
> se mi pare piuttosto incredibile tu abbia installato un gdal-bin nuovo
> mantenendo in essere la sola libreria vecchia. Hai sicuramente forzato
> qualcosa in modo poco consigliabile. Il tutto è completamente indipendente
> dal supporto o meno del formato ESRI.
>

Banalmente potresti avere installato manualmente un set di binari sotto
/usr/local/bin e similari senza peraltro installare o puntare le librerie
richieste.

--
Francesco P. Lovergine
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Luca Lanteri
In reply to this post by Francesco P. Lovergine
Hai assolutamente ragione. Ho avuto qualche problema con la versione 1.10 delle GDAL su ubuntu (un problema riscontrato anche da altri) e nel tentativo di mettere le cose a posto devo aver fatto qualche pasticcio. Le librerie GDAL adesso sono a posto (1.10) ed anche i binari di GDAL mentre i binari di OGR sono per qualche strano motivo rimasti alla 1.9. Non riesco a capire perché visto che il pacchetto GDAL-OGR è unico, ho provato più volte a reinstallarlo e risulta correttamente installato.




Il giorno 29 aprile 2014 09:07, Francesco P. Lovergine <[hidden email]> ha scritto:
On Mon, Apr 28, 2014 at 10:11:27PM +0200, Luca Lanteri wrote:
> scusa Francesco, ho inviato il messaggio prima di finire.
>
> al momento sono bloccato con un problema legato alle ogr
>
> ogrinfo --formats
> ERROR 1: ogrinfo was compiled against GDAL 1.9 but current library version
> is 1.10
>
> però mi pare che il pacchetto delle gdal sia quello giusto:
> Pacchetto: gdal-bin
> Stato: installato
> Installato automaticamente: no
> Versione: 1.10.1+dfsg-2~saucy1
>
> temo di avere qualche libreria errata ma non ho ancora trovato soluzione.

Devi vedere che libreria libgdal1 o libgdal1h hai installato invece, anche
se mi pare piuttosto incredibile tu abbia installato un gdal-bin nuovo
mantenendo in essere la sola libreria vecchia. Hai sicuramente forzato
qualcosa in modo poco consigliabile. Il tutto è completamente indipendente
dal supporto o meno del formato ESRI.

--
Francesco P. Lovergine


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: QGIS e supporto a ESRI geodatabase

Luca Lanteri
In reply to this post by Francesco P. Lovergine
e anche in questo caso avevi ragione. Problema ogr risolto. 
adesso cercando di aprire la mia origine dati DSN mi da questo errore

ogrinfo Pgeo:cle
ERROR 1: PGeo: MDB Tools driver not found!

Warning 1: Unable to install MDB driver for ODBC, MDB access may not supported.

sulla mia macchina ho installato gli mdbtools versione 0.7-3
la libreria degli MDBTools è in /usr/lib/x86_64-linux-gnu/odbc/libmdbodbc.so.1

ed ho configurato il file /etc/odbcinst.ini come indicato 

[Microsoft Access Driver (*.mdb)]
Description = MDB Tools ODBC drivers
Driver = /usr/lib/x86_64-linux-gnu/odbc/libmdbodbc.so.1
Setup
FileUsage = 1
CPTimeout
CPReuse

ho letto che esiste anche un driver mdb java che dovrebbe dare meno problemi ma mi pare di capire che devo ricompilare le GDAL. 

Grazie mille del supporto
Luca


Il giorno 29 aprile 2014 09:15, Francesco P. Lovergine <[hidden email]> ha scritto:
On Tue, Apr 29, 2014 at 09:07:41AM +0200, Francesco P. Lovergine wrote:
> >
> > ogrinfo --formats
> > ERROR 1: ogrinfo was compiled against GDAL 1.9 but current library version
> > is 1.10
> >
> > però mi pare che il pacchetto delle gdal sia quello giusto:
> > Pacchetto: gdal-bin
> > Stato: installato
> > Installato automaticamente: no
> > Versione: 1.10.1+dfsg-2~saucy1
> >
> > temo di avere qualche libreria errata ma non ho ancora trovato soluzione.
>
> Devi vedere che libreria libgdal1 o libgdal1h hai installato invece, anche
> se mi pare piuttosto incredibile tu abbia installato un gdal-bin nuovo
> mantenendo in essere la sola libreria vecchia. Hai sicuramente forzato
> qualcosa in modo poco consigliabile. Il tutto è completamente indipendente
> dal supporto o meno del formato ESRI.
>

Banalmente potresti avere installato manualmente un set di binari sotto
/usr/local/bin e similari senza peraltro installare o puntare le librerie
richieste.

--
Francesco P. Lovergine


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013