QGis 1.4.0 e lentezza.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

QGis 1.4.0 e lentezza.

Andrea Peri
Salve,

sto cercando qualche conferma a un comportamento di qgis che sto' rilevando in questi giorni.

l'ultima versione trunk di qgis , la 1.4.0 e' stranamente molto lenta con i dati postgis.
Gia' lo avevo notato con la 1.3.0, ma in quel periodo ci lavoravo meno.
Ora che ci sto' lavorando di piu', sto notando una lentezza tale da renderla inusabile.

La 1.2.0 trunk era senz'altro piu' efficiente.
Questa versione 1.4.0 trunk e' lenta in maniera pazzesca (nell'accedere a dati su postgis).

Per cui sto operando con la 1.0.2 kore che invece e' rapida e efficiente.

In linea di massima mi potevo anche aspettare una maggior lentezza in una versione trunk, ma fino alla 1.2.0 questo
non succedeva, dalla 1.3.0 e ora addirittura aumentato, nella 1.4.0 e' divenuto eccessivo.

Risulta anche ad altri questo comportamento ?

Grazie,


--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: QGis 1.4.0 e lentezza.

Flavio Rigolon


Il giorno 22 settembre 2009 10.38, Andrea Peri <[hidden email]> ha scritto:
Salve,

sto cercando qualche conferma a un comportamento di qgis che sto' rilevando in questi giorni.

l'ultima versione trunk di qgis , la 1.4.0 e' stranamente molto lenta con i dati postgis.
Gia' lo avevo notato con la 1.3.0, ma in quel periodo ci lavoravo meno.
Ora che ci sto' lavorando di piu', sto notando una lentezza tale da renderla inusabile.

La 1.2.0 trunk era senz'altro piu' efficiente.
Questa versione 1.4.0 trunk e' lenta in maniera pazzesca (nell'accedere a dati su postgis).

Per cui sto operando con la 1.0.2 kore che invece e' rapida e efficiente.

In linea di massima mi potevo anche aspettare una maggior lentezza in una versione trunk, ma fino alla 1.2.0 questo
non succedeva, dalla 1.3.0 e ora addirittura aumentato, nella 1.4.0 e' divenuto eccessivo.

Risulta anche ad altri questo comportamento ?

ciao,
 nel mio caso non trovo alcuna differenza di velocita'. Lavoro attualmente su db postgis che risiede su altra macchina della LAN ma consultazione ed editing sono pressoche' immediati.
Lavoro su Debian Lenny con qgis 1.4.0 code revision 11695.

flavio


--
io uso Debian GNU/Linux
user #413018 counter.li.org

<<usiamo formati aperti!>>
http://it.wikipedia.org/wiki/Formato_aperto

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: QGis 1.4.0 e lentezza.

Andrea Peri
Ciao,

Questo mi fa' piacere.
Infatti significa che in qualche maniera dovrei riuscire a
riportarmi a una situazione di 1.4.0 trunk funzionante per benino...

Ora per poter cominciare a capire dove sta' il problema,
mi farebbe comodo alcune informazioni accessorie.

Hai fatto uso anche te dell' installatore osgeo ?

Che versione di SO hai ?
Io attualmente sto' usando windows.

Io avevo gia' fatto qualche prova usando due macchine windows differenti,
ma sempre di tipo windows.
(Questo mi aveva spinto a pensare che non fosse legato a specifici problemi di una singola macchina.)

Pero' in effetti in entrambe avevo nel tempo fatto l'evoluzione delle varie versioni di qgis fino alla 1.4.0, e puo'
darsi che la procedura osgeow abbia lasciato qualcosa di retrodatato che interferisce con la versione trunk di qgis.

Per eliminare questi dubbi provero' a installare il qgis 1.4.0 su una nuova macchina con SO XP , in cui qgis e company non e' mai stato installato .
Tanto per vedere se in tale situazione tutto funziona come si deve oppure no.

Grazie,


Il giorno 22 settembre 2009 23.16, flavio rigolon <[hidden email]> ha scritto:


Il giorno 22 settembre 2009 10.38, Andrea Peri <[hidden email]> ha scritto:

Salve,

sto cercando qualche conferma a un comportamento di qgis che sto' rilevando in questi giorni.

l'ultima versione trunk di qgis , la 1.4.0 e' stranamente molto lenta con i dati postgis.
Gia' lo avevo notato con la 1.3.0, ma in quel periodo ci lavoravo meno.
Ora che ci sto' lavorando di piu', sto notando una lentezza tale da renderla inusabile.

La 1.2.0 trunk era senz'altro piu' efficiente.
Questa versione 1.4.0 trunk e' lenta in maniera pazzesca (nell'accedere a dati su postgis).

Per cui sto operando con la 1.0.2 kore che invece e' rapida e efficiente.

In linea di massima mi potevo anche aspettare una maggior lentezza in una versione trunk, ma fino alla 1.2.0 questo
non succedeva, dalla 1.3.0 e ora addirittura aumentato, nella 1.4.0 e' divenuto eccessivo.

Risulta anche ad altri questo comportamento ?

ciao,
 nel mio caso non trovo alcuna differenza di velocita'. Lavoro attualmente su db postgis che risiede su altra macchina della LAN ma consultazione ed editing sono pressoche' immediati.
Lavoro su Debian Lenny con qgis 1.4.0 code revision 11695.

flavio


--
io uso Debian GNU/Linux
user #413018 counter.li.org

<<usiamo formati aperti!>>
http://it.wikipedia.org/wiki/Formato_aperto



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: QGis 1.4.0 e lentezza.

Flavio Rigolon

ciao,
 
Hai fatto uso anche te dell' installatore osgeo ?


No, non avevo inteso parlassi di windows.
 
Che versione di SO hai ?
Io attualmente sto' usando windows.

Sono su Debian Lenny. Qgis l'ho compilato 2 giorni fa dal trunk.
 

Io avevo gia' fatto qualche prova usando due macchine windows differenti,
ma sempre di tipo windows.
(Questo mi aveva spinto a pensare che non fosse legato a specifici problemi di una singola macchina.)

Pero' in effetti in entrambe avevo nel tempo fatto l'evoluzione delle varie versioni di qgis fino alla 1.4.0, e puo'
darsi che la procedura osgeow abbia lasciato qualcosa di retrodatato che interferisce con la versione trunk di qgis.

Per eliminare questi dubbi provero' a installare il qgis 1.4.0 su una nuova macchina con SO XP , in cui qgis e company non e' mai stato installato .
Tanto per vedere se in tale situazione tutto funziona come si deve oppure no.

 Su windows ho ancora la versione 1.1 e "viaggia" bene con postgis. Appena riesco vedo di aggiornare (lavoro quasi esclusivamente su Debian).

flavio



--
io uso Debian GNU/Linux
user #413018 counter.li.org

<<usiamo formati aperti!>>
http://it.wikipedia.org/wiki/Formato_aperto

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: QGis 1.4.0 e lentezza.

Niccolo Rigacci
In reply to this post by Andrea Peri
On Tue, Sep 22, 2009 at 10:38:50AM +0200, Andrea Peri wrote:
>
> sto cercando qualche conferma a un comportamento di qgis che sto' rilevando
> in questi giorni.
>
> l'ultima versione trunk di qgis , la 1.4.0 e' stranamente molto lenta con i
> dati postgis.

Vedi se per caso la differenza sta nella connessione con
cifratura ssl oppure in chiaro. Con l'1.4 la puoi configurare
nella dialog box di connessione.

Altra cosa che puoi fare à abilitare il logging delle query su
postgres e vedere se la query che arriva da QGIS diversi è uguale
o diversa.

Puoi vedere bene solo se è cambiata la sintassi, valutare le
performance non è facile perché QGIS fa un DECLARE CURSOR, ecc.
che con EXPLAIN ANALYZE di analizza male.

--
Niccolo Rigacci
Firenze - Italy
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.