QGis, postgis e campi int4

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

QGis, postgis e campi int4

The lone A
Salve,

e' un po' di tempo che mi trovo alle prese con un problemino fastidioso....

Riassumo brevemente la questione:

Ovunque leggo che per visualizzare una tabella con geometria con QGIS
occorre avere un campo di tipo int4 con valori univoci (mannaggia a
lui ..) ed e' meglio se e' anche dotata di indice univoco.

Orbene, le ho provate in lungo e in largo, ma non riesco a convincerlo
a visualizzare una tabella con geometria proveniente da un postgis
anche se gli fornisco un campo con le caratteristiche sopra riportate,
ovvero di tipio int4 con valori univoci.

Invece accetta di buon grado di visualizzare se il campo 'e di tipo "oid".

Cosa questa che mi da' enorme fastidio perche' il formato oid e' un
qualcosa di specifico di Postgres, mentre un int4 e' piu' generico (un
integer non si nega mai a nessuno).

Quello che non capisco e' come mai ovunque trovo scritto che basta
avere un campo int4 oppure di tipo oid.
Invece quello che io rilevo dalle prove e' che se e' int4 non ci pensa
proprio a visualizzare e presenta il solito messaggio di protesta.
Se il campo e' oid , invece visualizza tutto felice come una pasqua.

Evidentemente sbaglio qualcosa, ma non riesco proprio a capire cosa.
A questo punto prima di continuare a far prove, mi farebbe comodo
sapere se e' vero che con un campo "int4" si riesce a visualizzare su
qgis.

Grazie,


--
~~~~~~~~~~~~~~~~~
§       Andrea              §
§         Peri                 §
~~~~~~~~~~~~~~~~~
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: QGis, postgis e campi int4

The lone A
Ho risolto,

Alla fine sono riuscito a far funzionare qgis con un campop integer....

Era colpa di un valore duplicato inavvertitamente, ... la fretta ....
il caldo ....




--
~~~~~~~~~~~~~~~~~
§       Andrea              §
§         Peri                 §
~~~~~~~~~~~~~~~~~
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.