Qgis 2.11 non mi si avvia su Debian Testing.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Qgis 2.11 non mi si avvia su Debian Testing.

girarsi_liste
Oggi ho reinstallato credo una decina di volte, il motivo del perchè
non mi si avvia non lo so, è successo solo oggi, dopo aggiornamenti,
ed aggiungo pure casini miei di cui non mi risparmio le eventuali
tirate d'orecchie.

Però gli altri programmi che ho installato funzionano ed il problema lo
ho solo con qgis al momento.

Se lo avvio da riga di comando da utente, digitando semplicemente qgis
mi restituisce:

/usr/bin/qgis.bin: symbol lookup error: /usr/bin/qgis.bin: undefined
symbol: _ZN13QwtLegendItem16staticMetaObjectE

Cercando, sono capitato su questa discussione:
http://lists.osgeo.org/pipermail/qgis-developer/2012-May/020401.html

Però riguarda la versione compilata.

Devo precisare che anche reinstallando le versioni precedenti non si
avviava, ovvero la 2.8.2 e la 2.8.3, seppur mi danno errore diverso,
ovvero errore di segmentazione, di cui non ho approfondito.

Ho provato a disinstallare qgis più vlte, disinstallando tutte le
dipendenze, o almeno quelle con contenuto il nome qgis (python-qgis,
qgis-plugin-grass, ecc.), ma la situazione non cambia, non riesco a
trovare il bandolo della matassa.

Domani provo ad avviare qgis con gdb e vedo se mi da mior esito per il
mio problema.

Intanto grazie a chi mi risponderà.


Aggiungo anche l'output di dpkg -l | grep qgis per completezza:



simone@hostkdebian:~$ dpkg -l qgis
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H
(in attesa)
|
Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err:
maiuscolo=grave)
||/ Nome                          Versione            Architettura
    Descrizione
+++-=============================-===================-===================-================================================================
ii  qgis                          1:2.11.0+git2015073 amd64
    Geographic Information System (GIS)
simone@xxxxxxxxx:~$ dpkg -l | grep qgis
ii  libqgis-analysis2.11.0
1:2.11.0+git20150731+d722f5b+99unstable amd64        QGIS - shared
analysis library
ii  libqgis-analysis2.8.3                         2.8.3+dfsg-1~exp1
                    amd64        QGIS - shared analysis library
ii  libqgis-core2.11.0
1:2.11.0+git20150731+d722f5b+99unstable amd64        QGIS - shared
core library
ii  libqgis-core2.8.3                             2.8.3+dfsg-1~exp1
                    amd64        QGIS - shared core library
ii  libqgis-customwidgets
1:2.11.0+git20150731+d722f5b+99unstable amd64        QGIS custom
widgets for Qt Designer
ii  libqgis-gui2.11.0
1:2.11.0+git20150731+d722f5b+99unstable amd64        QGIS - shared gui
library
ii  libqgis-gui2.8.3                              2.8.3+dfsg-1~exp1
                    amd64        QGIS - shared gui library
ii  libqgis-networkanalysis2.11.0
1:2.11.0+git20150731+d722f5b+99unstable amd64        QGIS - shared
network analysis library
ii  libqgis-networkanalysis2.8.3                  2.8.3+dfsg-1~exp1
                    amd64        QGIS - shared network analysis library
ii  libqgis-server2.8.3                           2.8.3+dfsg-1~exp1
                    amd64        QGIS - shared server library
ii  libqgisgrass2.11.0
1:2.11.0+git20150731+d722f5b+99unstable amd64        QGIS - shared
grass library
ii  libqgispython2.8.3                            2.8.3+dfsg-1~exp1
                    amd64        QGIS - shared Python library
ii  python-qgis                                   2.8.3+dfsg-1~exp1
                    amd64        Python bindings to QGIS
ii  python-qgis-common                            2.8.3+dfsg-1~exp1
                    all          Python bindings to QGIS -
architecture-independent files
ii  qgis
1:2.11.0+git20150731+d722f5b+99unstable amd64        Geographic
Information System (GIS)
ii  qgis-common
1:2.11.0+git20150731+d722f5b+99unstable all          QGIS -
architecture-independent data
ii  qgis-plugin-globe
1:2.11.0+git20150731+d722f5b+99unstable amd64        OSG globe plugin
for QGIS
ii  qgis-plugin-globe-common
1:2.11.0+git20150731+d722f5b+99unstable all          OSG globe plugin
for QGIS - architecture-independent data
ii  qgis-plugin-grass
1:2.11.0+git20150731+d722f5b+99unstable amd64        GRASS plugin for QGIS
ii  qgis-plugin-grass-common
1:2.11.0+git20150731+d722f5b+99unstable all          GRASS plugin for
QGIS - architecture-independent data
ii  qgis-providers
1:2.11.0+git20150731+d722f5b+99unstable amd64        collection of
data providers to QGIS
ii  qgis-providers-common
1:2.11.0+git20150731+d722f5b+99unstable all          collection of
data providers to QGIS - architecture-independent files



--
Simone Girardelli
_|_|_|_|_|_|_|_|_|_
|_|_|_|_|_|_|_|_|_|_|


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis 2.11 non mi si avvia su Debian Testing.

pcav
Il 18/08/2015 23:49, girarsi_liste ha scritto:
> Oggi ho reinstallato credo una decina di volte, il motivo del perchè
> non mi si avvia non lo so, è successo solo oggi, dopo aggiornamenti,
> ed aggiungo pure casini miei di cui non mi risparmio le eventuali
> tirate d'orecchie.

Ciao,
evidentemente hai fatto un po' di confusione fra i repos. Miei consigli:
* tieni solo quelli di debian, ed aggiungi quello ufficiale di QGIS
* disinstalla tutto qgis
* controlla che non ci siano pacchetti che vengono da altre distribuzioni
* reinstalla solo la versione voluta.
Saluti.
--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis 2.11 non mi si avvia su Debian Testing.

girarsi_liste
Il 19/08/2015 09:22, Paolo Cavallini ha scritto:
> Ciao, evidentemente hai fatto un po' di confusione fra i repos.
> Miei consigli: * tieni solo quelli di debian, ed aggiungi quello
> ufficiale di QGIS

Sono repo di debian, ho solo cambiato da jessie, a unstable (sid) che
come codename sid non me lo accetta, solo come unstable.

Poi disintallando un paio di volte ho sostituito i repo con
nightly-release, sempre per debian, e poi non avendo successo,
disinstallando, ho cambiato i repo in nightly, ma ho sempre mantenuto
un solo repository deb + deb-src, non ho messo diverse righe nel
sources.list.

Comunque ritorno a quelli ufficiali per jessie, anche se mi spiace non
ci sia una versione per stretch (testing, jessie è stable, voce che
andrebbe aggiornata nella pagina dei download).

> * disinstalla tutto qgis * controlla che non ci siano pacchetti che
> vengono da altre distribuzioni

Non vedo come, ho sopra scritto il perchè, la mia impressione semmai è
che sia rimasta qualche vecchia configurazione non sostituita durante
l'installazione dei pacchetti, ad ogni modo oggi provo avviando gdb.

> * reinstalla solo la versione voluta.
Il problema è che non ne va neanche una di quella voluta..... :)

Pazienta, oggi vedo di essere più preciso per farmi aiutare meglio, a
meno che non risolva con gdb, cosa che spero.



--
Simone Girardelli
_|_|_|_|_|_|_|_|_|_
|_|_|_|_|_|_|_|_|_|_|


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis 2.11 non mi si avvia su Debian Testing.

pcav
Il 19/08/2015 11:57, girarsi_liste ha scritto:
> Il 19/08/2015 09:22, Paolo Cavallini ha scritto:
>> Ciao, evidentemente hai fatto un po' di confusione fra i repos.
>> Miei consigli: * tieni solo quelli di debian, ed aggiungi quello
>> ufficiale di QGIS
>
> Sono repo di debian, ho solo cambiato da jessie, a unstable (sid) che
> come codename sid non me lo accetta, solo come unstable.

Io ho questo:

deb http://ftp.no.debian.org/debian/ sid main contrib non-free
deb http://ftp.no.debian.org/debian/ experimental main contrib non-free
deb http://qgis.org/debian-nightly-ltr sid main

e funziona. Per la nightly, basta togliere -ltr e dovrebbe andare (la
usavo pochi giorni fa).
Sono sicuro che se fai pulizia funziona anche a te :)
Salluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis 2.11 non mi si avvia su Debian Testing.

girarsi_liste
On 19/08/2015 12:01, Paolo Cavallini wrote:

> Il 19/08/2015 11:57, girarsi_liste ha scritto:
>> Il 19/08/2015 09:22, Paolo Cavallini ha scritto:
>>> Ciao, evidentemente hai fatto un po' di confusione fra i repos.
>>> Miei consigli: * tieni solo quelli di debian, ed aggiungi quello
>>> ufficiale di QGIS
>>
>> Sono repo di debian, ho solo cambiato da jessie, a unstable (sid) che
>> come codename sid non me lo accetta, solo come unstable.
>
> Io ho questo:
>
> deb http://ftp.no.debian.org/debian/ sid main contrib non-free
> deb http://ftp.no.debian.org/debian/ experimental main contrib non-free
> deb http://qgis.org/debian-nightly-ltr sid main
>
> e funziona. Per la nightly, basta togliere -ltr e dovrebbe andare (la
> usavo pochi giorni fa).
> Sono sicuro che se fai pulizia funziona anche a te :)
> Salluti.
>

Per mettere a conoscenza:

Causa marea di casini con Debian Testing/Sid, intendo per la maggior
parte miei casini, qualcosa casino nei repository Debian a causa del
"passaggio" a Kde con Qt5, Kwin-X11 che crashava continuamente,
specialmente dopo la reinstallazione, sono passato  Debian con
interfaccia LXDE, più stabile, anche se minimale.

Avevo provato con display manager Wayland, bello, peccato non ancora
presente con strumenti di gestione finestre e compagnia bella.

Attualmente ho Qgis 2.8.2 (su Debian testing LXDE), funzionante, se
tento l'aggiornamento a 2.11, mi attira una marea di problemi in
anteprima da shell, con aptitude che mi evidenzia problemi sempre con le
Qt5, per cui aspetterò fra un mese o due, forse risolvono (repository
debian intendo).



--
Simone Girardelli
_|_|_|_|_|_|_|_|_|_
|_|_|_|_|_|_|_|_|_|_|


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis 2.11 non mi si avvia su Debian Testing.

nformica
In reply to this post by pcav
Ciao Paolo,
mi aggancio a questa discussione, per chiederti un consiglio in tema.

Premetto che fino a "ieri" non ho mai avuto problemi ad installare QGIS su Linux .... ma ora con le nuove versioni (la 2.8.3 o la 2.10) non riesco a fare un'installazione che abbia il plugin per GRASS perfettamente funzionante !
(... la vecchia QGIS 2.6 + GRASS 6.4 funzionava alla grande )
Ovviamente prima di fare una una nuova installazione, prima ho sempre ripulito  i pacchetti della precedente install.

Mi puoi consigliare cosa mi conviene installare su Ubuntu 14.04 LTS, QGIS 2.8.3 o 2.10.1 non importa, ,basta che abbia il plugin-GRASS funzionante ? ... quali repositories devo usare: debian o ubuntugis ?
GRASS (la 6.4.3)  lo installo prima oppure in contemporanea a QGIS ??

cari saluti
Nino