Qgis server richiesta info

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Qgis server richiesta info

Ruggero Bonisolli
Buon giorno,
sto cercando di utilizzare qgis server sotto W7/64.

Mi sono letto un po' di cose che sono girate qui nei mesi scorsi ma non riesco ad attivare la procedura per aprire un WMS su localhost.

Se qualcuno mi può dare le istruzioni sarei grato.
Posso dire che ho installato il Qgis server da OSGeo4W64; che trovo il qgis_mapserver.fgci.exe in OSGeo4W64\apps\qis\bin; che ho un apache installato in una cartella C:\ServerApp (Apache/2.2.15 (Win32) PHP/5.2.13); che riesco ad avviare, fermare e riavviare, apache; che ho cercato di modificare i file di configurazione secondo le indicazioni ..... ma che mi da sempre questo errore:
-----------------------------------------------
Impossibile scaricare le capabilities:Download di capabilities non riuscito: Error downloading http://localhost/OSGeo4W64/apps/qgis/bin/qgis_mapserv.fcgi?SERVICE=WMS&REQUEST=GetCapabilities - server replied: Not Found
-------------------------------------

ringrazio per suggerimenti.
r

--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Amedeo Fadini


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <[hidden email]> ha scritto:
Buon giorno,
sto cercando di utilizzare qgis server sotto W7/64.

Mi sono letto un po' di cose che sono girate qui nei mesi scorsi ma non riesco ad attivare la procedura per aprire un WMS su localhost.



-----------------------------------------------
Impossibile scaricare le capabilities:Download di capabilities non riuscito: Error downloading http://localhost/OSGeo4W64/apps/qgis/bin/qgis_mapserv.fcgi?SERVICE=WMS&REQUEST=GetCapabilities - server replied: Not Found
-------------------------------------
 
 Non ho mai provato su windows ma sei sicuro che no si debba aggiungere .exe dopo qgis_mapserv.fcgi    ?

Questo percorso presume la cartella OSGeo4W64 come sottocartella di httdocs, la root del server.  Prova a copiare una pagina html accanto a qgis_mapserv.fcgi e verificache te la visualizzi, in caso contrario devi configurare apache per raggiungere quella cartella.

Io credo sia più comodo spostare l'eseguibile di qgis server e il progetto da pubblicare direttamente nella cartella httdocs di apache.

Amefad




 

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Ruggero Bonisolli
Il 27/05/2015 10:52, Amedeo Fadini ha scritto:


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <[hidden email]> ha scritto:
Buon giorno,
sto cercando di utilizzare qgis server sotto W7/64.

Mi sono letto un po' di cose che sono girate qui nei mesi scorsi ma non riesco ad attivare la procedura per aprire un WMS su localhost.



-----------------------------------------------
Impossibile scaricare le capabilities:Download di capabilities non riuscito: Error downloading http://localhost/OSGeo4W64/apps/qgis/bin/qgis_mapserv.fcgi?SERVICE=WMS&REQUEST=GetCapabilities - server replied: Not Found
-------------------------------------
 
 Non ho mai provato su windows ma sei sicuro che no si debba aggiungere .exe dopo qgis_mapserv.fcgi    ?

Questo percorso presume la cartella OSGeo4W64 come sottocartella di httdocs, la root del server.  Prova a copiare una pagina html accanto a qgis_mapserv.fcgi e verificache te la visualizzi, in caso contrario devi configurare apache per raggiungere quella cartella.

Io credo sia più comodo spostare l'eseguibile di qgis server e il progetto da pubblicare direttamente nella cartella httdocs di apache.

Amefad




 
Non ho la cartella httdocs ..... ho inserito exe .... il risultato non cambia. Mi pare di capire che servono nozioni più approfondite sul funzionamento di apache .... nei doc di qgis server ho trovato una serie di passaggi per modificare alcuni .conf quello che manca è la stringa da inserire in URL della finestra di caricamento WMS ... questo passaggio è totalmente assente.
Che fare?
r


--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Andrea Peri
NOn conosco apache e quindi non posso darti certezze.
Ma alcune prove "sempreverdi".
Innanzi tutto sei sicurissimo che apache sta girando ?
La prova del 9 e' provare a invocare una pagina html.

Se si, verifica i diritti dell'utente con cui apache gira.
Potrebbe non avere diritti per eseguire il file eseguibile che te invochi.
Tieni presente che i sistemi internet come apache sono progettati per funzionare in un ambiente ad alto rischio.
Per cui non scherzano per niente con i diritti utente e se tutto non è sistemato a puntino non eseguono e basta.

Poi, in merito alla cartella.
Non ho ben capito cosa hai fatto, ma tieni presente che apache non accettera' mai di invocare un eseguibile che non si trovi nella cartella specificha da lui prevista per l'esecuzione dei cgi-bin.
Quindi, o imposti la cartella OSGeo4W64\apps\qis\bin
dentro il file di configurazione di apache dicendogli che e' la cartella da cui vuoi eseguire i cgi-bin, oppure sposyi i files nella cartella che ha gia' preimpostato apache.

Probabilmente questi settaggi potrebbero non essere attivi perche' commentati nel file di configurazione di apache.
Questo perche' la pratica delle cgi.bin e' una pratica considerata desueta da chi lavora con i server web.
Quindi molto probabilmente tengono questi settaggi commentati, per cui dovrai scommentarli, modificarli e fare prove .

Buona fortuna.



Il giorno 27 maggio 2015 11:13, Ruggero Bonisolli <[hidden email]> ha scritto:
Il 27/05/2015 10:52, Amedeo Fadini ha scritto:


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <[hidden email]> ha scritto:
Buon giorno,
sto cercando di utilizzare qgis server sotto W7/64.

Mi sono letto un po' di cose che sono girate qui nei mesi scorsi ma non riesco ad attivare la procedura per aprire un WMS su localhost.



-----------------------------------------------
Impossibile scaricare le capabilities:Download di capabilities non riuscito: Error downloading http://localhost/OSGeo4W64/apps/qgis/bin/qgis_mapserv.fcgi?SERVICE=WMS&REQUEST=GetCapabilities - server replied: Not Found
-------------------------------------
 
 Non ho mai provato su windows ma sei sicuro che no si debba aggiungere .exe dopo qgis_mapserv.fcgi    ?

Questo percorso presume la cartella OSGeo4W64 come sottocartella di httdocs, la root del server.  Prova a copiare una pagina html accanto a qgis_mapserv.fcgi e verificache te la visualizzi, in caso contrario devi configurare apache per raggiungere quella cartella.

Io credo sia più comodo spostare l'eseguibile di qgis server e il progetto da pubblicare direttamente nella cartella httdocs di apache.

Amefad




 
Non ho la cartella httdocs ..... ho inserito exe .... il risultato non cambia. Mi pare di capire che servono nozioni più approfondite sul funzionamento di apache .... nei doc di qgis server ho trovato una serie di passaggi per modificare alcuni .conf quello che manca è la stringa da inserire in URL della finestra di caricamento WMS ... questo passaggio è totalmente assente.
Che fare?
r


--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Qgis server richiesta info

Amedeo Fadini
In reply to this post by Ruggero Bonisolli


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;ruggero.bonisolli@polimi.it&#39;);" target="_blank">ruggero.bonisolli@...> ha scritto:
 
Non ho la cartella httdocs ..... ho inserito exe .... il risultato non cambia. Mi pare di capire che servono nozioni più approfondite sul funzionamento di apache .... 
Scusa ho sbagliato si chiama htdocs. 
Sì devi avere chiaro la corrispondenza tra l'indirizzo del browser e il percorso reale del file system. Leggi un pochino questa pagina:


Ci sono vari modi per impostare la DocumentRoot e eventuali alias, ha ragione Andrea che deve stare nella cartella cgi-bin.

Amefad

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Ruggero Bonisolli
In reply to this post by Andrea Peri
In c:\ServerApp\Apache\conf\http.conf ho inserito:
Listen 80
ServerName localhost:80
ScriptAlias /cgi-bin/ "C:/OSGeo4W64/apps/bin/"

in c:\OSGeo4W64
ho creato una cartella http.d e dentro ho messo il file http_qgis.conf con questa modifiche. L'indicazione di creare una cartella così l'ho trovata da qualche parte sui documenti che ho "spulciato".
------------------------------------
LoadModule cgi_module modules/mod_cgi.so

SetEnv PATH "C:\OSGeo4W64\bin;C:\OSGeo4W64\apps\qgis\bin;C:\OSGeo4W64\apps\grass\grass-6.4.3\bin;C:\OSGeo4W64\apps\grass\grass-6.4.3\lib;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem"
SetEnv QGIS_PREFIX_PATH "C:\OSGeo4W64\apps\qgis"
SetEnv QT_PLUGIN_PATH "C:\OSGeo4W64\apps\qgis\qtplugins;C:\OSGeo4W64\apps\qt4\plugins"
SetEnv TEMP "C:\Users\RBONIS~1\AppData\Local\Temp"
SetEnv LD_LIBRARY_PATH "c:\OSGeo4W/apps/qgis/bin/"
SetEnv PATH "c:\OSGeo4W/apps/qgis/bin/"

Alias /qgis/ C:\OSGeo4W64/apps/qgis/bin/

<Directory "C:\OSGeo4W64/apps/qgis/bin/">
    #SetHandler fcgid-script
    SetHandler cgi-script   
    Options ExecCGI
    Order allow,deny
    Allow from all
</Directory>
---------------------------------------

in c:\ServerApp\Apache\
ho una cartella http.d che non ricordo se creata da me o meno con dentro un file http_qgis.conf qui riportato:
-----------------
LoadModule cgi_module modules/mod_cgi.so

SetEnv PATH "C:\OSGeo4W64\bin;C:\OSGeo4W64\apps\qgis\bin;C:\OSGeo4W64\apps\grass\grass-6.4.3\bin;C:\OSGeo4W64\apps\grass\grass-6.4.3\lib;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem"
SetEnv QGIS_PREFIX_PATH "C:\OSGeo4W64\apps\qgis"
SetEnv QT_PLUGIN_PATH "C:\OSGeo4W64\apps\qgis\qtplugins;C:\OSGeo4W64\apps\qt4\plugins"
SetEnv TEMP "C:\Users\RBONIS~1\AppData\Local\Temp"

Alias /qgis/ C:\OSGeo4W64/apps/qgis/bin/

<Directory "C:\OSGeo4W64/apps/qgis/bin/">
    #SetHandler fcgid-script
    SetHandler cgi-script   
    Options ExecCGI
    Order allow,deny
    Allow from all
</Directory>


 # parse other apache conf files
 include "C:\ServerApp\apache\httpd.d\httpd_*.conf"
------------------------------------------------------------------------------

in c:\OSGeo4W64\apps\bin ho copiato un file qgs perchè trovavo l'indicazione che mettendo un progetto qgis nella stessa cartella dell'eseguibile qgis server il file veniva letto automaticamente.

Per quanto riguarda apache "gira" e mi compare alla sua attivazione una finestra nel browser.
Per quanto riguarda la cartella htdocs non esiste nella cartella di Apache e nemmeno altrove.

leggero il doc su Apache e se altri hanno idee ......

a presto
r


Il 27/05/2015 11:32, Andrea Peri ha scritto:
NOn conosco apache e quindi non posso darti certezze.
Ma alcune prove "sempreverdi".
Innanzi tutto sei sicurissimo che apache sta girando ?
La prova del 9 e' provare a invocare una pagina html.

Se si, verifica i diritti dell'utente con cui apache gira.
Potrebbe non avere diritti per eseguire il file eseguibile che te invochi.
Tieni presente che i sistemi internet come apache sono progettati per funzionare in un ambiente ad alto rischio.
Per cui non scherzano per niente con i diritti utente e se tutto non è sistemato a puntino non eseguono e basta.

Poi, in merito alla cartella.
Non ho ben capito cosa hai fatto, ma tieni presente che apache non accettera' mai di invocare un eseguibile che non si trovi nella cartella specificha da lui prevista per l'esecuzione dei cgi-bin.
Quindi, o imposti la cartella OSGeo4W64\apps\qis\bin
dentro il file di configurazione di apache dicendogli che e' la cartella da cui vuoi eseguire i cgi-bin, oppure sposyi i files nella cartella che ha gia' preimpostato apache.

Probabilmente questi settaggi potrebbero non essere attivi perche' commentati nel file di configurazione di apache.
Questo perche' la pratica delle cgi.bin e' una pratica considerata desueta da chi lavora con i server web.
Quindi molto probabilmente tengono questi settaggi commentati, per cui dovrai scommentarli, modificarli e fare prove .

Buona fortuna.



Il giorno 27 maggio 2015 11:13, Ruggero Bonisolli <[hidden email]> ha scritto:
Il 27/05/2015 10:52, Amedeo Fadini ha scritto:


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <[hidden email]> ha scritto:
Buon giorno,
sto cercando di utilizzare qgis server sotto W7/64.

Mi sono letto un po' di cose che sono girate qui nei mesi scorsi ma non riesco ad attivare la procedura per aprire un WMS su localhost.



-----------------------------------------------
Impossibile scaricare le capabilities:Download di capabilities non riuscito: Error downloading http://localhost/OSGeo4W64/apps/qgis/bin/qgis_mapserv.fcgi?SERVICE=WMS&REQUEST=GetCapabilities - server replied: Not Found
-------------------------------------
 
 Non ho mai provato su windows ma sei sicuro che no si debba aggiungere .exe dopo qgis_mapserv.fcgi    ?

Questo percorso presume la cartella OSGeo4W64 come sottocartella di httdocs, la root del server.  Prova a copiare una pagina html accanto a qgis_mapserv.fcgi e verificache te la visualizzi, in caso contrario devi configurare apache per raggiungere quella cartella.

Io credo sia più comodo spostare l'eseguibile di qgis server e il progetto da pubblicare direttamente nella cartella httdocs di apache.

Amefad




 
Non ho la cartella httdocs ..... ho inserito exe .... il risultato non cambia. Mi pare di capire che servono nozioni più approfondite sul funzionamento di apache .... nei doc di qgis server ho trovato una serie di passaggi per modificare alcuni .conf quello che manca è la stringa da inserire in URL della finestra di caricamento WMS ... questo passaggio è totalmente assente.
Che fare?
r


--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------


--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Amedeo Fadini


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <[hidden email]> ha scritto:


Alias /qgis/ C:\OSGeo4W64/apps/qgis/bin/

E quindi hai impostato un alias, così facendo l'indirizzo dovrebbe essere http://localhost/qgis/qgis_mapserver.fcgi.exe?.... Eccetera

Amefad

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Ruggero Bonisolli
Il 27/05/2015 13:06, Amedeo Fadini ha scritto:


Il mercoledì 27 maggio 2015, Ruggero Bonisolli <[hidden email]> ha scritto:


Alias /qgis/ C:\OSGeo4W64/apps/qgis/bin/

E quindi hai impostato un alias, così facendo l'indirizzo dovrebbe essere http://localhost/qgis/qgis_mapserver.fcgi.exe?.... Eccetera

Amefad
...... eccetera ....... mi puoi dire cosa inserire poi?
r


--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Amedeo Fadini


2015-05-27 13:10 GMT+02:00 Ruggero Bonisolli <[hidden email]>:

E quindi hai impostato un alias, così facendo l'indirizzo dovrebbe essere http://localhost/qgis/qgis_mapserver.fcgi.exe?.... Eccetera

Amefad
...... eccetera ....... mi puoi dire cosa inserire poi?
Dopo il punto interrogativo ci vanno i parametri della richiesta WMS, qundi nel tuo esmpio Service=WMS&Request=Getcapabilites.

Come diceva Andrea per assicurarti che l'alias funzioni carica una pagina html normale in quella cartella e visualizzala tramite l'alias.

Amefad

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Andrea Peri
Attenzione a un dettaglio.

Metti per esempio che la cartella dove sono collocati gli eseguibili e
che viene puntata dall' apache si chiami
"cgi-bin"


e nella cartella cgi-bin ci metti una pagina html e provi a invocarla
, ci sta benissimo che apache non la legga.
Si rifiuta di farlo e fa bene.

Nella cgibin  ci deve stare solo roba eseguibile, non risorse leggibili.

E' un must della sicurezza.

Per cui non puoi metterci una pagina html e provare a leggerla li' dentro.

Caso mai procurati una cgibn semplice , di quelle che eseguono "hello-world"
e prova a invocare quella li'.

In merito al perche' non ti funziona, le ragioni possono essere migliaia.

Provo a ipotizzarne una:

quando te esegui il qgis-server esso ha parecchie dipendenze con altre
dll, n ha tantissime.

Quando lo esegui da desktop , il file bat di partenza provvede lui a
impostare tutti i percorsi delle dipendenze, ma se lo fai eseguire a
un server apache, deve essere l'utente del server apache ad avere
tutte le dipendenze, altrimenti ti da' errore perche' non trova
qualche dll.

Le soluzioni che mi vengono in mente sono tre, ma se son fatttiibli non lo so'.:

o metti tutto nella cartella cgi-bin, ma lo vedo assurdo, o imposti le
dipendenze, o ti procuri un qgis-server compilato con tutte le dll
statiche, ma quest'ultima e' solo teorica, perche' nessuno al mondo e'
in grado di fare una cosa del genere .

Ma qui mi fermo.
Per poterti consigliare meglio servirebbe qualcuno che ha una vera e
reale esperienza su apache.

Saluti,

A.



Il 27 maggio 2015 16:56, Amedeo Fadini <[hidden email]> ha scritto:

>
>
> 2015-05-27 13:10 GMT+02:00 Ruggero Bonisolli <[hidden email]>:
>>
>>
>> E quindi hai impostato un alias, così facendo l'indirizzo dovrebbe essere
>> http://localhost/qgis/qgis_mapserver.fcgi.exe?.... Eccetera
>>
>> Amefad
>>
>> ...... eccetera ....... mi puoi dire cosa inserire poi?
>
> Dopo il punto interrogativo ci vanno i parametri della richiesta WMS, qundi
> nel tuo esmpio Service=WMS&Request=Getcapabilites.
>
> Come diceva Andrea per assicurarti che l'alias funzioni carica una pagina
> html normale in quella cartella e visualizzala tramite l'alias.
>
> Amefad



--
-----------------
Andrea Peri
. . . . . . . . .
qwerty àèìòù
-----------------
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: Qgis server richiesta info

Ruggero Bonisolli
In reply to this post by Amedeo Fadini
Il 27/05/2015 16:56, Amedeo Fadini ha scritto:


2015-05-27 13:10 GMT+02:00 Ruggero Bonisolli <[hidden email]>:

E quindi hai impostato un alias, così facendo l'indirizzo dovrebbe essere http://localhost/qgis/qgis_mapserver.fcgi.exe?.... Eccetera

Amefad
...... eccetera ....... mi puoi dire cosa inserire poi?
Dopo il punto interrogativo ci vanno i parametri della richiesta WMS, qundi nel tuo esmpio Service=WMS&Request=Getcapabilites.

Come diceva Andrea per assicurarti che l'alias funzioni carica una pagina html normale in quella cartella e visualizzala tramite l'alias.

Amefad
Ciao a tutti,
sono ancora incastrato dalla difficile relazione tra qgis e apache.
Per togliermi un pezzo di dubbi ho reinstallato una distribuzione di apache aggiornata, xampp. Lì ho trovato un po' di cose e ho provato a rifare la procedura controllandone i passaggi. Alcuni mi sfuggono ancora, evidentemente anche perchè ancora non funziona, però ora ho un paio di info in più.

Se cerco di avviare il qgis_mapserv.fgci.exe nella cartella dove viene messo dall'installazione standard (c:\OSGeo4W64\apps\qgis\bin) senza avere nella stessa cartella un file .qgis l'errore segnalato dal server è il 404 (file non trovato). Se metto un file .qgis nella stessa cartella, o in una sottocartella di apache dando i percorsi relativi l'errore è il 403 (accesso negato).

Quindi mi pare di capire che apache parte e riesce a lanciare l'eseguibile server di qgis ma che ci sia ancora un problema di diritti di accesso alle cartelle.
Forse bisogna inserire un login e password nella finestra di caricamento wms di qgis?
forse ci sono problemi tra admin e user che in W7 sono un po' misteriosi per il fatto che l'utente admin è nascosto?

Forse i problemi sono altri ma..... spulciando la rete trovo sempre pezzi di ragionamenti e di info e mai una scaletta completa per gestire la cosa con il significato dei vari passaggi (capire la gerarchia di cartelle, i parametri da passare, e meccanismi di controllo per gli errori...).
Mi domando:
- non si usa apache come server?
- è meglio usare una distribuzione piuttosto che un altra?
- ci sono distribuzioni apache già orientate a gestire server cartografici?
- non si usa qgis sotto Windows?
- non si usa qgis server?
- ... altro.

Se qualche utente di Qgis server e apache, e W7 64 mi può dare ulteriori consigli ringrazio anticipatamente.

a presto
r

--

Arch. Ruggero Bonisolli

(LPE) Laboratorio di Progettazione Ecologica – (LADeC) Laboratorio Analisi Dati e Cartografie

(DAStU) Dipartimento di Architettura e Studi Urbani

Politecnico di Milano

Via Bonardi, 9

20133 Milano

Tel 02239994 41/42

Fax 02 239994444

 


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015