R: wms geoserver e qgis

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

R: wms geoserver e qgis

alessandro.sarretta@inwind.it
Ciao Andrea,
mah, l'url mi pare giusta, l'unica cosa che mi viene in mente è
che magari geoserver non è installato nella porta 8080...
O qualcosa collegato
con il fatto che anche geonetwork ha il suo geoserver preinstallato...
hth
Ale


>----Messaggio originale----
>Da: [hidden email]
>Data: 19/01/2010
12.06
>A: <[hidden email]>
>Ogg: [Gfoss]  wms geoserver e qgis
>
>
>ciao a
tutti
>sto lavorando in locale con geoserver2.0-geonetwork-qgis1.3, ma non
riesco a
>far digerire a qgis la url del servizio wms di geoserver
>Con il
servizio wfs non ho problemi e la url che passo a qgis è
>http://localhost:
8080/geoserver/wfs
>se metto wms non lo accetta e mi dice :
>Risposta non
interpretabile. Il fornitore wms dice:
>Impossibile recuperare la lista delle
risorse WMS nel formato atteso (DTD):
>nessun WMS_Capabilities o
WMT_MS_Capabilities trovato
>Questo è causato probabilmente da un indirizzo URL
non corretto nella
>definizione del server WMS.
>URL provata:
>http://localhost:
8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities
>se provo con il
suggerimento non cambia nulla
>immaginando che la soluzione sia banale...chiedo
lumi!
>
>grazie ciao
>--
>View this message in context: http://old.nabble.
com/wms-geoserver-e-qgis-tp27224177p27224177.html
>Sent from the Gfoss mailing
list archive at Nabble.com.
>
>_______________________________________________

>Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione

>[hidden email]
>http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss

>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di
questa lista non rispecchiano necessariamente
>le posizioni dell'Associazione
GFOSS.it.
>


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: wms geoserver e qgis

Andrea Rosina
ciao
Ho appena fatto delle prove, e con il geoserver all'interno di geonetwork funziona tutto
Il problema rimane con geoserver 2.0. WFS funziona mentre WMS no






Il giorno 19 gennaio 2010 13.39, [hidden email] <[hidden email]> ha scritto:
Ciao Andrea,
mah, l'url mi pare giusta, l'unica cosa che mi viene in mente è
che magari geoserver non è installato nella porta 8080...
O qualcosa collegato
con il fatto che anche geonetwork ha il suo geoserver preinstallato...
hth
Ale


>----Messaggio originale----
>Da: [hidden email]
>Data: 19/01/2010
12.06
>A: <[hidden email]>
>Ogg: [Gfoss]  wms geoserver e qgis
>
>
>ciao a
tutti
>sto lavorando in locale con geoserver2.0-geonetwork-qgis1.3, ma non
riesco a
>far digerire a qgis la url del servizio wms di geoserver
>Con il
servizio wfs non ho problemi e la url che passo a qgis è
>http://localhost:
8080/geoserver/wfs
>se metto wms non lo accetta e mi dice :
>Risposta non
interpretabile. Il fornitore wms dice:
>Impossibile recuperare la lista delle
risorse WMS nel formato atteso (DTD):
>nessun WMS_Capabilities o
WMT_MS_Capabilities trovato
>Questo è causato probabilmente da un indirizzo URL
non corretto nella
>definizione del server WMS.
>URL provata:
>http://localhost:
8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities
>se provo con il
suggerimento non cambia nulla
>immaginando che la soluzione sia banale...chiedo
lumi!
>
>grazie ciao
>--
>View this message in context: http://old.nabble.
com/wms-geoserver-e-qgis-tp27224177p27224177.html
>Sent from the Gfoss mailing
list archive at Nabble.com.
>
>_______________________________________________

>Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione

>[hidden email]
>http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss

>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di
questa lista non rispecchiano necessariamente
>le posizioni dell'Associazione
GFOSS.it.
>




_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: wms geoserver e qgis

Stefano Salvador
potrei dire una bestialità ... ma ho avuto anch'io lo stesso problema
e dopo ore di ricerche in internet era venuto fuori che nella
definizione del layer devi specificare i "Metadata links", fatto
questo qgis è contento.

comunque mi è capitato abbastanza spesso che qgis mi da quell'errore
mentre altri client wms fanno tutto correttamente.

Ciao,

Stefano

Il 19 gennaio 2010 14.27, Andrea Rosina <[hidden email]> ha scritto:

> ciao
> Ho appena fatto delle prove, e con il geoserver all'interno di geonetwork
> funziona tutto
> Il problema rimane con geoserver 2.0. WFS funziona mentre WMS no
>
>
>
>
>
>
> Il giorno 19 gennaio 2010 13.39, [hidden email]
> <[hidden email]> ha scritto:
>>
>> Ciao Andrea,
>> mah, l'url mi pare giusta, l'unica cosa che mi viene in mente è
>> che magari geoserver non è installato nella porta 8080...
>> O qualcosa collegato
>> con il fatto che anche geonetwork ha il suo geoserver preinstallato...
>> hth
>> Ale
>>
>>
>> >----Messaggio originale----
>> >Da: [hidden email]
>> >Data: 19/01/2010
>> 12.06
>> >A: <[hidden email]>
>> >Ogg: [Gfoss]  wms geoserver e qgis
>> >
>> >
>> >ciao a
>> tutti
>> >sto lavorando in locale con geoserver2.0-geonetwork-qgis1.3, ma non
>> riesco a
>> >far digerire a qgis la url del servizio wms di geoserver
>> >Con il
>> servizio wfs non ho problemi e la url che passo a qgis è
>> >http://localhost:
>> 8080/geoserver/wfs
>> >se metto wms non lo accetta e mi dice :
>> >Risposta non
>> interpretabile. Il fornitore wms dice:
>> >Impossibile recuperare la lista delle
>> risorse WMS nel formato atteso (DTD):
>> >nessun WMS_Capabilities o
>> WMT_MS_Capabilities trovato
>> >Questo è causato probabilmente da un indirizzo URL
>> non corretto nella
>> >definizione del server WMS.
>> >URL provata:
>> >http://localhost:
>> 8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities
>> >se provo con il
>> suggerimento non cambia nulla
>> >immaginando che la soluzione sia banale...chiedo
>> lumi!
>> >
>> >grazie ciao
>> >--
>> >View this message in context: http://old.nabble.
>> com/wms-geoserver-e-qgis-tp27224177p27224177.html
>> >Sent from the Gfoss mailing
>> list archive at Nabble.com.
>> >
>> >_______________________________________________
>>
>> >Iscriviti all'associazione GFOSS.it:
>> > http://www.gfoss.it/drupal/iscrizione
>>
>> >[hidden email]
>> >http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
>>
>> >Questa e' una lista di discussione pubblica aperta a tutti.
>> >I messaggi di
>> questa lista non rispecchiano necessariamente
>> >le posizioni dell'Associazione
>> GFOSS.it.
>> >
>>
>>
>
>
> _______________________________________________
> Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
> [hidden email]
> http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non rispecchiano necessariamente
> le posizioni dell'Associazione GFOSS.it.
>
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.