Re: Configurazione Lizmap su ubuntu - Risolto!

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Configurazione Lizmap su ubuntu - Risolto!

gmusumeci
Caro Salvatore,

Ti ringrazio e molto del fix che hai postato. Da un primo test effettuato
sembra che il problema sia perfettamente risolto: per quel che ho visto
finora l'editing su postgis funziona bene.
La soluzione da te postata, per lo stato delle mie conoscenze, mi era
irraggiungibile. Mi piacerebbe sapere quale fosse  il problema.

Cordiali saluti

Giuseppe

Il giorno 4 luglio 2016 22:05, Salvatore Larosa <[hidden email]> ha
scritto:

> Ciao,
>
> 2016-07-04 18:31 GMT+02:00 giuseppe musumeci <[hidden email]
> >:
> > Gentile gruppo,
> >
> > premesso che qualche mese or sono avevo postato una richiesta simile a
> > quella in oggetto senza avere alcuna fortuna oggi, partendo dallo stesso
> > problema, provo a migliorare la richiesta sperando di avere miglior
> fortuna
> > nel trovare la soluzione.
> >
> > Al termine di un lungo (e per me che sono nuovissimo a Linux anche
> > complesso) processo di installazione/configurazione mi trovo nella
> seguente
> > situazione:
> >
> > Macchina Pc con windows 10 ho installato Qgis 2.14
> >
> > Macchina virtuale linux ubuntu trusty ho installato Qgis Server 2.14 +
> > PostgreSQL 9.5 + LizmapWebClient 2.12.6. + Apache
> >
> > L'idea a regime è di lavorare su windows (che conosco) trasferendo poi
> > tutti i file del progetto e di configurazione su un server Linux per
> > pubblicare delle mappe web con Lizmap
> >
> > In questa fase, per testare se Lizmap possa fare al caso mio, mi
> basterebbe
> > far girare Xubuntu su una macchina virtuale per fare delle prove.
> >
> > Tuttavia finora ogni volta che provo a fare editing su tabelle postgis
> > inevitabilmente il browser non risponde: nessuna feature viene
> selezionata
> > o creata.
> >
> > Posto di seguito il log odierno degli errori di Apache sperando che
> > qualcuno possa darmi delle indicazioni su come fare finalmente a far
> > funzionare il tutto
> >
> > Cordiali saluti
>
> non ti arrendere...a volte la soluzione è dietro l'angolo, dipende dal
> punto di vista :)
> Premesso che immagino tu abbia installato le relative estensione di
> PHP sia di SQLite che PostgreSQL, l'unico errore che vedo è quello
> relativo a SET AUTOCOMMIT..... gli altri sembrano solo warning.
>
> Per risolvere l'errore, prova a modificare il file
>
> var/www/lizmap-web-client-2.12.6/lib/jelix/plugins/db/pgsql/pgsql.dbconnection.php
> alla riga 203 copiando e sostituendo la funzione che trovi qui [0].
>
> Saluti!
>
> [0] - https://gist.github.com/slarosa/816d005014bedc86f31f3aa2c27823cd
>
>
> --
> Salvatore Larosa
> linkedIn: http://linkedin.com/in/larosasalvatore
> twitter: @lrssvt
> skype: s.larosa
> IRC: lrssvt on freenode
>

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|

Re: Configurazione Lizmap su ubuntu - Risolto!

Salvatore Larosa
Ciao,

2016-07-05 15:16 GMT+02:00 giuseppe musumeci <[hidden email]>:
> Caro Salvatore,
>
> Ti ringrazio e molto del fix che hai postato. Da un primo test effettuato
> sembra che il problema sia perfettamente risolto: per quel che ho visto
> finora l'editing su postgis funziona bene.
> La soluzione da te postata, per lo stato delle mie conoscenze, mi era
> irraggiungibile. Mi piacerebbe sapere quale fosse  il problema.

Bene, mi fa piacere che hai risolto :)

Il problema è dovuto al fatto che nella versione 2.12.6 non è presente
il controllo sulla versione di PostgreSQL usata quando viene eseguita
la query SET AUTOCOMMIT ON|OFF;. La query funziona solo con versioni
inferiori alla 7.4.
Per le versioni superiori alla 7.4 il comando funziona solo da shell
con: \set AUTOCOMMIT ON|OFF.

La cosa strana, che non ho ancora indagato, è perchè solo nel tuo caso
viene chiamata quella funzione, immagino che molti hanno una
configurazione simile alla tua con lizmap-web-client 2.12.6 e
PostgreSQL superiore alla 7.4.

Saluti.

>
> Cordiali saluti
>
> Giuseppe
>
> Il giorno 4 luglio 2016 22:05, Salvatore Larosa <[hidden email]> ha
> scritto:
>>
>> Ciao,
>>
>> 2016-07-04 18:31 GMT+02:00 giuseppe musumeci
>> <[hidden email]>:
>> > Gentile gruppo,
>> >
>> > premesso che qualche mese or sono avevo postato una richiesta simile a
>> > quella in oggetto senza avere alcuna fortuna oggi, partendo dallo stesso
>> > problema, provo a migliorare la richiesta sperando di avere miglior
>> > fortuna
>> > nel trovare la soluzione.
>> >
>> > Al termine di un lungo (e per me che sono nuovissimo a Linux anche
>> > complesso) processo di installazione/configurazione mi trovo nella
>> > seguente
>> > situazione:
>> >
>> > Macchina Pc con windows 10 ho installato Qgis 2.14
>> >
>> > Macchina virtuale linux ubuntu trusty ho installato Qgis Server 2.14 +
>> > PostgreSQL 9.5 + LizmapWebClient 2.12.6. + Apache
>> >
>> > L'idea a regime è di lavorare su windows (che conosco) trasferendo poi
>> > tutti i file del progetto e di configurazione su un server Linux per
>> > pubblicare delle mappe web con Lizmap
>> >
>> > In questa fase, per testare se Lizmap possa fare al caso mio, mi
>> > basterebbe
>> > far girare Xubuntu su una macchina virtuale per fare delle prove.
>> >
>> > Tuttavia finora ogni volta che provo a fare editing su tabelle postgis
>> > inevitabilmente il browser non risponde: nessuna feature viene
>> > selezionata
>> > o creata.
>> >
>> > Posto di seguito il log odierno degli errori di Apache sperando che
>> > qualcuno possa darmi delle indicazioni su come fare finalmente a far
>> > funzionare il tutto
>> >
>> > Cordiali saluti
>>
>> non ti arrendere...a volte la soluzione è dietro l'angolo, dipende dal
>> punto di vista :)
>> Premesso che immagino tu abbia installato le relative estensione di
>> PHP sia di SQLite che PostgreSQL, l'unico errore che vedo è quello
>> relativo a SET AUTOCOMMIT..... gli altri sembrano solo warning.
>>
>> Per risolvere l'errore, prova a modificare il file
>>
>> var/www/lizmap-web-client-2.12.6/lib/jelix/plugins/db/pgsql/pgsql.dbconnection.php
>> alla riga 203 copiando e sostituendo la funzione che trovi qui [0].
>>
>> Saluti!
>>
>> [0] - https://gist.github.com/slarosa/816d005014bedc86f31f3aa2c27823cd
>>
>>
>> --
>> Salvatore Larosa
>> linkedIn: http://linkedin.com/in/larosasalvatore
>> twitter: @lrssvt
>> skype: s.larosa
>> IRC: lrssvt on freenode
>
>



--
Salvatore Larosa
linkedIn: http://linkedin.com/in/larosasalvatore
twitter: @lrssvt
skype: s.larosa
IRC: lrssvt on freenode
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016