SAGA (Linux Mint - QGIS 2.4)

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

SAGA (Linux Mint - QGIS 2.4)

Daniele Bonaposta
Ciao a tutti,
come specificato in oggetto ho QGIS 2.4 installato su una macchina Linux Mint 16 e ho anche SAGA 2.1.1.
Non riesco a lavorare con gli strumenti di quest'ultimo da processing e ogni volta ottengo questo errore:

Missing dependency.This algorithm cannot be run :-(

This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS

Click here to know more about how to install and configure SAGA to be used with QGIS


da terminale ho:


 saga_cmd

Error: no arguments for saga call

Error: library


63 loaded module libraries (631 modules):

- shapes_tools

- ta_morphometry

- io_esri_e00

- imagery_classification

- io_grid_image

- ta_channels

- io_shapes

- io_grid_grib2

- grid_gridding

- imagery_rga

- pointcloud_viewer

- sim_ecosystems_hugget

- io_gdal

- imagery_tools

- ta_compound

- tin_viewer

- geostatistics_points

- imagery_svm

- tin_tools

- pj_proj4

- grid_calculus

- io_grid

- recreations_fractals

- geostatistics_regression

- grid_spline

- shapes_grid

- shapes_points

- shapes_polygons

- table_tools

- geostatistics_grid

- ta_profiles

- ihacres

- grid_analysis

- ta_preprocessor

- garden_webservices

- sim_cellular_automata

- io_table

- io_shapes_dxf

- pointcloud_tools

- pj_georeference

- ta_hydrology

- grid_tools

- docs_html

- io_gps

- docs_pdf

- io_odbc

- grid_visualisation

- imagery_segmentation

- sim_hydrology

- grid_calculus_bsl

- shapes_transect

- contrib_a_perego

- io_pgsql

- garden_3d_viewer

- ta_lighting

- geostatistics_kriging

- lectures_introduction

- recreations_games

- grid_filter

- shapes_lines

- climate_tools

- sim_erosion

- table_calculus



Come faccio a utilizzarlo tramite processing?

Ciao a tutti e grazie,

Daniele






--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: +39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: SAGA (Linux Mint - QGIS 2.4)

giohappy
Ciao Daniele,
saga è installato correttamente? Hai provato a lanciare saga_cmd da terminale?

giovanni

2014-11-07 9:44 GMT+01:00 Daniele Bonaposta <[hidden email]>:
Ciao a tutti,
come specificato in oggetto ho QGIS 2.4 installato su una macchina Linux Mint 16 e ho anche SAGA 2.1.1.
Non riesco a lavorare con gli strumenti di quest'ultimo da processing e ogni volta ottengo questo errore:

Missing dependency.This algorithm cannot be run :-(

This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS

Click here to know more about how to install and configure SAGA to be used with QGIS


da terminale ho:


 saga_cmd

Error: no arguments for saga call

Error: library


63 loaded module libraries (631 modules):

- shapes_tools

- ta_morphometry

- io_esri_e00

- imagery_classification

- io_grid_image

- ta_channels

- io_shapes

- io_grid_grib2

- grid_gridding

- imagery_rga

- pointcloud_viewer

- sim_ecosystems_hugget

- io_gdal

- imagery_tools

- ta_compound

- tin_viewer

- geostatistics_points

- imagery_svm

- tin_tools

- pj_proj4

- grid_calculus

- io_grid

- recreations_fractals

- geostatistics_regression

- grid_spline

- shapes_grid

- shapes_points

- shapes_polygons

- table_tools

- geostatistics_grid

- ta_profiles

- ihacres

- grid_analysis

- ta_preprocessor

- garden_webservices

- sim_cellular_automata

- io_table

- io_shapes_dxf

- pointcloud_tools

- pj_georeference

- ta_hydrology

- grid_tools

- docs_html

- io_gps

- docs_pdf

- io_odbc

- grid_visualisation

- imagery_segmentation

- sim_hydrology

- grid_calculus_bsl

- shapes_transect

- contrib_a_perego

- io_pgsql

- garden_3d_viewer

- ta_lighting

- geostatistics_kriging

- lectures_introduction

- recreations_games

- grid_filter

- shapes_lines

- climate_tools

- sim_erosion

- table_calculus



Come faccio a utilizzarlo tramite processing?

Ciao a tutti e grazie,

Daniele






--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: <a href="tel:%2B39.338.3377044" value="+393383377044" target="_blank">+39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014



--

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: SAGA (Linux Mint - QGIS 2.4)

Daniele Bonaposta
Ho lanciato il comando e ho postato la risposta.
Apparentemente è tutto ok se lo avvio dal menù.

Il giorno 07 novembre 2014 09:48, G. Allegri <[hidden email]> ha scritto:
Ciao Daniele,
saga è installato correttamente? Hai provato a lanciare saga_cmd da terminale?

giovanni

2014-11-07 9:44 GMT+01:00 Daniele Bonaposta <[hidden email]>:
Ciao a tutti,
come specificato in oggetto ho QGIS 2.4 installato su una macchina Linux Mint 16 e ho anche SAGA 2.1.1.
Non riesco a lavorare con gli strumenti di quest'ultimo da processing e ogni volta ottengo questo errore:

Missing dependency.This algorithm cannot be run :-(

This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS

Click here to know more about how to install and configure SAGA to be used with QGIS


da terminale ho:


 saga_cmd

Error: no arguments for saga call

Error: library


63 loaded module libraries (631 modules):

- shapes_tools

- ta_morphometry

- io_esri_e00

- imagery_classification

- io_grid_image

- ta_channels

- io_shapes

- io_grid_grib2

- grid_gridding

- imagery_rga

- pointcloud_viewer

- sim_ecosystems_hugget

- io_gdal

- imagery_tools

- ta_compound

- tin_viewer

- geostatistics_points

- imagery_svm

- tin_tools

- pj_proj4

- grid_calculus

- io_grid

- recreations_fractals

- geostatistics_regression

- grid_spline

- shapes_grid

- shapes_points

- shapes_polygons

- table_tools

- geostatistics_grid

- ta_profiles

- ihacres

- grid_analysis

- ta_preprocessor

- garden_webservices

- sim_cellular_automata

- io_table

- io_shapes_dxf

- pointcloud_tools

- pj_georeference

- ta_hydrology

- grid_tools

- docs_html

- io_gps

- docs_pdf

- io_odbc

- grid_visualisation

- imagery_segmentation

- sim_hydrology

- grid_calculus_bsl

- shapes_transect

- contrib_a_perego

- io_pgsql

- garden_3d_viewer

- ta_lighting

- geostatistics_kriging

- lectures_introduction

- recreations_games

- grid_filter

- shapes_lines

- climate_tools

- sim_erosion

- table_calculus



Come faccio a utilizzarlo tramite processing?

Ciao a tutti e grazie,

Daniele






--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: <a href="tel:%2B39.338.3377044" value="+393383377044" target="_blank">+39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014



--



--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: +39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: SAGA (Linux Mint - QGIS 2.4)

Sieradz
This post was updated on .
In reply to this post by Daniele Bonaposta
PROCESSING => OPZIONI => PROGRAMMI => SAGA => ATTIVA

Purtroppo, almeno sotto Windows, Saga di Processing e' affetto da un grave bug non risolto nella 2.6: alla fine del calcolo, non viene visualizzato alcun report.
Reply | Threaded
Open this post in threaded view
|

Re: SAGA (Linux Mint - QGIS 2.4)

giohappy
In reply to this post by Daniele Bonaposta
Scusa Daniele, l'email mi era stata mostrata troncata.
Vai su Processing -> Opziono di configurazione -> Programmi -> Saga, e togli la spunta da "Enable SAGA 2.0.8 compatibility".

giovanni

Il giorno 07 novembre 2014 09:52, Daniele Bonaposta <[hidden email]> ha scritto:
Ho lanciato il comando e ho postato la risposta.
Apparentemente è tutto ok se lo avvio dal menù.

Il giorno 07 novembre 2014 09:48, G. Allegri <[hidden email]> ha scritto:

Ciao Daniele,
saga è installato correttamente? Hai provato a lanciare saga_cmd da terminale?

giovanni

2014-11-07 9:44 GMT+01:00 Daniele Bonaposta <[hidden email]>:
Ciao a tutti,
come specificato in oggetto ho QGIS 2.4 installato su una macchina Linux Mint 16 e ho anche SAGA 2.1.1.
Non riesco a lavorare con gli strumenti di quest'ultimo da processing e ogni volta ottengo questo errore:

Missing dependency.This algorithm cannot be run :-(

This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS

Click here to know more about how to install and configure SAGA to be used with QGIS


da terminale ho:


 saga_cmd

Error: no arguments for saga call

Error: library


63 loaded module libraries (631 modules):

- shapes_tools

- ta_morphometry

- io_esri_e00

- imagery_classification

- io_grid_image

- ta_channels

- io_shapes

- io_grid_grib2

- grid_gridding

- imagery_rga

- pointcloud_viewer

- sim_ecosystems_hugget

- io_gdal

- imagery_tools

- ta_compound

- tin_viewer

- geostatistics_points

- imagery_svm

- tin_tools

- pj_proj4

- grid_calculus

- io_grid

- recreations_fractals

- geostatistics_regression

- grid_spline

- shapes_grid

- shapes_points

- shapes_polygons

- table_tools

- geostatistics_grid

- ta_profiles

- ihacres

- grid_analysis

- ta_preprocessor

- garden_webservices

- sim_cellular_automata

- io_table

- io_shapes_dxf

- pointcloud_tools

- pj_georeference

- ta_hydrology

- grid_tools

- docs_html

- io_gps

- docs_pdf

- io_odbc

- grid_visualisation

- imagery_segmentation

- sim_hydrology

- grid_calculus_bsl

- shapes_transect

- contrib_a_perego

- io_pgsql

- garden_3d_viewer

- ta_lighting

- geostatistics_kriging

- lectures_introduction

- recreations_games

- grid_filter

- shapes_lines

- climate_tools

- sim_erosion

- table_calculus



Come faccio a utilizzarlo tramite processing?

Ciao a tutti e grazie,

Daniele






--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: <a href="tel:%2B39.338.3377044" value="+393383377044" target="_blank">+39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014



--



--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: <a href="tel:%2B39.338.3377044" value="+393383377044" target="_blank">+39.338.3377044
e-mail:
[hidden email]


_____________________________



--

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: SAGA (Linux Mint - QGIS 2.4)

Daniele Bonaposta
grazie Gio!!!
funziona!

Il giorno 07 novembre 2014 10:06, G. Allegri <[hidden email]> ha scritto:
Scusa Daniele, l'email mi era stata mostrata troncata.
Vai su Processing -> Opziono di configurazione -> Programmi -> Saga, e togli la spunta da "Enable SAGA 2.0.8 compatibility".

giovanni

Il giorno 07 novembre 2014 09:52, Daniele Bonaposta <[hidden email]> ha scritto:

Ho lanciato il comando e ho postato la risposta.
Apparentemente è tutto ok se lo avvio dal menù.

Il giorno 07 novembre 2014 09:48, G. Allegri <[hidden email]> ha scritto:

Ciao Daniele,
saga è installato correttamente? Hai provato a lanciare saga_cmd da terminale?

giovanni

2014-11-07 9:44 GMT+01:00 Daniele Bonaposta <[hidden email]>:
Ciao a tutti,
come specificato in oggetto ho QGIS 2.4 installato su una macchina Linux Mint 16 e ho anche SAGA 2.1.1.
Non riesco a lavorare con gli strumenti di quest'ultimo da processing e ogni volta ottengo questo errore:

Missing dependency.This algorithm cannot be run :-(

This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS

Click here to know more about how to install and configure SAGA to be used with QGIS


da terminale ho:


 saga_cmd

Error: no arguments for saga call

Error: library


63 loaded module libraries (631 modules):

- shapes_tools

- ta_morphometry

- io_esri_e00

- imagery_classification

- io_grid_image

- ta_channels

- io_shapes

- io_grid_grib2

- grid_gridding

- imagery_rga

- pointcloud_viewer

- sim_ecosystems_hugget

- io_gdal

- imagery_tools

- ta_compound

- tin_viewer

- geostatistics_points

- imagery_svm

- tin_tools

- pj_proj4

- grid_calculus

- io_grid

- recreations_fractals

- geostatistics_regression

- grid_spline

- shapes_grid

- shapes_points

- shapes_polygons

- table_tools

- geostatistics_grid

- ta_profiles

- ihacres

- grid_analysis

- ta_preprocessor

- garden_webservices

- sim_cellular_automata

- io_table

- io_shapes_dxf

- pointcloud_tools

- pj_georeference

- ta_hydrology

- grid_tools

- docs_html

- io_gps

- docs_pdf

- io_odbc

- grid_visualisation

- imagery_segmentation

- sim_hydrology

- grid_calculus_bsl

- shapes_transect

- contrib_a_perego

- io_pgsql

- garden_3d_viewer

- ta_lighting

- geostatistics_kriging

- lectures_introduction

- recreations_games

- grid_filter

- shapes_lines

- climate_tools

- sim_erosion

- table_calculus



Come faccio a utilizzarlo tramite processing?

Ciao a tutti e grazie,

Daniele






--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: <a href="tel:%2B39.338.3377044" value="+393383377044" target="_blank">+39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014



--



--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: <a href="tel:%2B39.338.3377044" value="+393383377044" target="_blank">+39.338.3377044
e-mail:
[hidden email]


_____________________________



--
_____________________________

Daniele Bonaposta,
Cartografia - G.I.S.

via Don Minzoni 13a
40121 - Bologna
mobile: +39.338.3377044
e-mail:
[hidden email]


_____________________________

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666+40 iscritti al 5.6.2014
Reply | Threaded
Open this post in threaded view
|

Re: SAGA (Linux Mint - QGIS 2.4)

Sieradz
In reply to this post by giohappy
giohappy wrote
Processing -> Opziono di configurazione -> Programmi -> Saga, e
togli la spunta da "Enable SAGA 2.0.8 compatibility"

Ahi, nella versione Win non c'e' quest'opzione, forse per quello non visualizza i risultati del calcolo...