Spatialite - QgisServer problemi visualizzazione tabella punti

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Spatialite - QgisServer problemi visualizzazione tabella punti

gmusumeci
Gentile lista.
Sto lavorando con un progetto qgis con alla base un database spatialite
una delle tabelle spatialite è costituita da circa 4000 punti.

Ho installato su una macchina virtuale un server debian 9 e qgis server.
Quando carico il progetto Qgis ed il database non è in alcun modo possibile
visualizzare questa tabella di punti con una richiesta getmap
Ho verificato la correttezza e l'integrità dei dati ed ho altresì
verificato che trasformando i dati in shp oppure geojson il servizio wms
restituisce perfettamente i punti.

Evidenzio che questo tipo di problematica non è presente in altre tabelle
di punti presenti nello stesso database.

Qualcuno si é mai inbattuto in questa problematica?

Giuseppe
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Reply | Threaded
Open this post in threaded view
|

Re: Spatialite - QgisServer problemi visualizzazione tabella punti

Roberto Marzocchi
Due domande banali:  Hai installato le librerie spatialite / sqlite3 sul server? Tu parli di qgis server e non di di eventuali client ma potrebbero esserti comunque utili queste istruzioni, anche se un po datate [1]  R [1] -  http://www.gaia-gis.it/spatialite-2.4.0-4/splite-php.html  Eng. Roberto Marzocchi, PhD
GIS Project Coordinator
Gter srl (Unige spin-off)
Piazza De Marini 3/61 - 16123 Genova
P.IVA/CF 01998770992
ph: 010-8694830 - mob: 349-8786575
E-mail: [hidden email]
skype: roberto.marzocchi84
www.gter.it

--
Gter social
www.twitter.com/Gteronline - www.facebook.com/Gteronline - https://plus.google.com/+GterIt/posts 
www.linkedin.com/company/gter-srl-innovazione-in-geomatica-gnss-e-gis

-----------------------------------------------------------------
Please consider the environment before printing this email! ---- On Fri, 26 Oct 2018 11:48:50 +0200 giuseppe musumeci <[hidden email]> wrote ---- Gentile lista. Sto lavorando con un progetto qgis con alla base un database spatialite una delle tabelle spatialite è costituita da circa 4000 punti. Ho installato su una macchina virtuale un server debian 9 e qgis server. Quando carico il progetto Qgis ed il database non è in alcun modo possibile visualizzare questa tabella di punti con una richiesta getmap Ho verificato la correttezza e l'integrità dei dati ed ho altresì verificato che trasformando i dati in shp oppure geojson il servizio wms restituisce perfettamente i punti. Evidenzio che questo tipo di problematica non è presente in altre tabelle di punti presenti nello stesso database. Qualcuno si é mai inbattuto in questa problematica? Giuseppe _______________________________________________ [hidden email] http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss Questa e' una lista di discussione pubblica aperta a tutti. I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it. 796 iscritti al 28/12/2017
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Reply | Threaded
Open this post in threaded view
|

Re: Spatialite - QgisServer problemi visualizzazione tabella punti

gmusumeci
Si le librerie sono installate ed aggiornate all'ultima versione.
Ho anche visto le istruzioni al link
http://www.gaia-gis.it/spatialite-2.4.0-4/splite-php.html ma sono datate.
Ho trovato nella lista spatialite uno scambio di mail più aggiornato ma
anche seguendo quelle istruzioni il risultato non cambia.
il servizio WMS restituise un layer senza punti

Come client utilizzo Lizmap ma per essere certo che l'errore non fosse nel
client ho provato ad effettuare le richieste wms direttamente a qgis Server

Il giorno ven 26 ott 2018 alle ore 12:01 Roberto Marzocchi <
[hidden email]> ha scritto:

> Due domande banali:
>
> Hai installato le librerie spatialite / sqlite3 sul server?
>
> Tu parli di qgis server e non di di eventuali client ma potrebbero esserti
> comunque utili queste istruzioni, anche se un po datate [1]
>
> R
>
>
> [1] -
> http://www.gaia-gis.it/spatialite-2.4.0-4/splite-php.html
>
>
>
>
> Eng. Roberto Marzocchi, PhD
> GIS Project Coordinator
> Gter srl (Unige spin-off)
> Piazza De Marini 3/61 - 16123 GenovaP.IVA/CF 01998770992
> ph: 010-8694830 - mob: 349-8786575
> E-mail: [hidden email]
> skype: roberto.marzocchi84www.gter.it
>
> --
> Gter socialwww.twitter.com/Gteronline - www.facebook.com/Gteronline - https://plus.google.com/+GterIt/posts www.linkedin.com/company/gter-srl-innovazione-in-geomatica-gnss-e-gis
>
> -----------------------------------------------------------------
> Please consider the environment before printing this email!
>
>
>
>
> ---- On Fri, 26 Oct 2018 11:48:50 +0200 *giuseppe musumeci
> <[hidden email] <[hidden email]>>* wrote ----
>
> Gentile lista.
> Sto lavorando con un progetto qgis con alla base un database spatialite
> una delle tabelle spatialite è costituita da circa 4000 punti.
>
> Ho installato su una macchina virtuale un server debian 9 e qgis server.
> Quando carico il progetto Qgis ed il database non è in alcun modo possibile
> visualizzare questa tabella di punti con una richiesta getmap
> Ho verificato la correttezza e l'integrità dei dati ed ho altresì
> verificato che trasformando i dati in shp oppure geojson il servizio wms
> restituisce perfettamente i punti.
>
> Evidenzio che questo tipo di problematica non è presente in altre tabelle
> di punti presenti nello stesso database.
>
> Qualcuno si é mai inbattuto in questa problematica?
>
> Giuseppe
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 796 iscritti al 28/12/2017
>
>
>
>
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Reply | Threaded
Open this post in threaded view
|

Re: Spatialite - QgisServer problemi visualizzazione tabella punti

a.furieri
In reply to this post by gmusumeci
On Fri, 26 Oct 2018 11:48:50 +0200, giuseppe musumeci wrote:

> Gentile lista.
> Sto lavorando con un progetto qgis con alla base un database
> spatialite
> una delle tabelle spatialite è costituita da circa 4000 punti.
>
> Ho installato su una macchina virtuale un server debian 9 e qgis
> server.
> Quando carico il progetto Qgis ed il database non è in alcun modo
> possibile
> visualizzare questa tabella di punti con una richiesta getmap
> Ho verificato la correttezza e l'integrità dei dati ed ho altresì
> verificato che trasformando i dati in shp oppure geojson il servizio
> wms
> restituisce perfettamente i punti.
>
> Evidenzio che questo tipo di problematica non è presente in altre
> tabelle
> di punti presenti nello stesso database.
>
> Qualcuno si é mai inbattuto in questa problematica?
>

Giuseppe,

hai provato a verificare se QGIS Desktop riesce a visualizzarti
correttamente quel layer ?

magari hai semplicemene un problema di statistiche non aggiornate,
o qualche altro problemino di configurazione e/o vestizione, o
magari uno Spatial Index corrotto.
il test con l'app desktop dovrebbe verosimilmente aiutarti a
capire piu' facilmente cosa c'e' che non va in quel layer.

ciao Sandro
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017
Reply | Threaded
Open this post in threaded view
|

Re: Spatialite - QgisServer problemi visualizzazione tabella punti

gmusumeci
Si Sandro.
Il layer su qgis desktop viene perfettamente visualizzato
Con spatialite gui ho verificato le geometrie e sono ok
Lo ho importato in postgis e funziona.
Non mi raccapezzo

Il ven 26 ott 2018, 13:19 <[hidden email]> ha scritto:

> On Fri, 26 Oct 2018 11:48:50 +0200, giuseppe musumeci wrote:
> > Gentile lista.
> > Sto lavorando con un progetto qgis con alla base un database
> > spatialite
> > una delle tabelle spatialite è costituita da circa 4000 punti.
> >
> > Ho installato su una macchina virtuale un server debian 9 e qgis
> > server.
> > Quando carico il progetto Qgis ed il database non è in alcun modo
> > possibile
> > visualizzare questa tabella di punti con una richiesta getmap
> > Ho verificato la correttezza e l'integrità dei dati ed ho altresì
> > verificato che trasformando i dati in shp oppure geojson il servizio
> > wms
> > restituisce perfettamente i punti.
> >
> > Evidenzio che questo tipo di problematica non è presente in altre
> > tabelle
> > di punti presenti nello stesso database.
> >
> > Qualcuno si é mai inbattuto in questa problematica?
> >
>
> Giuseppe,
>
> hai provato a verificare se QGIS Desktop riesce a visualizzarti
> correttamente quel layer ?
>
> magari hai semplicemene un problema di statistiche non aggiornate,
> o qualche altro problemino di configurazione e/o vestizione, o
> magari uno Spatial Index corrotto.
> il test con l'app desktop dovrebbe verosimilmente aiutarti a
> capire piu' facilmente cosa c'e' che non va in quel layer.
>
> ciao Sandro
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 796 iscritti al 28/12/2017
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
796 iscritti al 28/12/2017