grass su ubuntu ?

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

grass su ubuntu ?

Sandro Santilli
Approfitto della lista per chiedere aiuto ai GRASSisti
(cosi' cerchiamo pure di riequilibrare lo sbilancio verso QGIS)

Ho installato grass-dev da package Ubuntu 13.04 (6.4.2-2build1)
ma quando provo ad usarlo, ottengo errori nella risoluzione di
simboli di GDAL _versionati_, tipo:

/usr/lib/grass64/lib/libgrass_gproj.so: undefined reference to `OSRExportToProj4@GDAL_1.8'

Sembrerebbe un bug nel packaging di grass per ubuntu.

Maintainer: Ubuntu Developers <[hidden email]>
Original-Maintainer: Debian GIS Project <[hidden email]>

Sapete se lo stesso bug e' presente nel pacchetto Debian ?

PS: ok confesso, stavo provando a compilare QGIS col supporto per GRASS :)

--strk;

 ()  ASCII ribbon campaign        - against html e-mail
 /\  http://www.asciiribbon.org   - against proprietary attachments
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Luca Delucchi
Ciao Sandro

2013/11/7 Sandro Santilli <[hidden email]>:
> Approfitto della lista per chiedere aiuto ai GRASSisti
> (cosi' cerchiamo pure di riequilibrare lo sbilancio verso QGIS)
>

scusa ma GRASS lo uso solo se lo compilo :-(

> Ho installato grass-dev da package Ubuntu 13.04 (6.4.2-2build1)
> ma quando provo ad usarlo, ottengo errori nella risoluzione di
> simboli di GDAL _versionati_, tipo:
>
> /usr/lib/grass64/lib/libgrass_gproj.so: undefined reference to `OSRExportToProj4@GDAL_1.8'
>
> Sembrerebbe un bug nel packaging di grass per ubuntu.
>

usi ubuntugis o pacchetti normali?

> Maintainer: Ubuntu Developers <[hidden email]>
> Original-Maintainer: Debian GIS Project <[hidden email]>
>
> Sapete se lo stesso bug e' presente nel pacchetto Debian ?
>

frankie ne sai qualcosa?

> PS: ok confesso, stavo provando a compilare QGIS col supporto per GRASS :)
>
> --strk;
>
>  ()  ASCII ribbon campaign        - against html e-mail
>  /\  http://www.asciiribbon.org   - against proprietary attachments
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
> 666 iscritti al 22.7.2013



--
ciao
Luca

http://gis.cri.fmach.it/delucchi/
www.lucadelu.org
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Francesco P. Lovergine
On Mon, Nov 11, 2013 at 12:38:54AM +0100, Luca Delucchi wrote:

> usi ubuntugis o pacchetti normali?
>
> > Maintainer: Ubuntu Developers <[hidden email]>
> > Original-Maintainer: Debian GIS Project <[hidden email]>
> >
> > Sapete se lo stesso bug e' presente nel pacchetto Debian ?
> >
>
> frankie ne sai qualcosa?
>
> > PS: ok confesso, stavo provando a compilare QGIS col supporto per GRASS :)
> >

Su sid non mi risultano al momento problemi sui binari. In compenso qgis 2.0
(il binario di qgis.org) va in segfault alla partenza.

--
Francesco P. Lovergine
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Sandro Santilli
In reply to this post by Luca Delucchi
On Mon, Nov 11, 2013 at 12:38:54AM +0100, Luca Delucchi wrote:

> scusa ma GRASS lo uso solo se lo compilo :-(

Eh, misa che mi tocca pure a me.

> > /usr/lib/grass64/lib/libgrass_gproj.so: undefined reference to `OSRExportToProj4@GDAL_1.8'
>
> usi ubuntugis o pacchetti normali?

Pacchetti normali. Ho provato a usare ubuntugis ma non sono
sicuro di essere stato capace (c'e' modo di sapere via apt-qualcosa
da quale repository un pacchetto verrebbe o e' stato installato?)

Scusate l'ignoranza :)

--strk;

 ()  ASCII ribbon campaign        - against html e-mail
 /\  http://www.asciiribbon.org   - against proprietary attachments
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Sandro Santilli
In reply to this post by Francesco P. Lovergine
On Mon, Nov 11, 2013 at 10:54:02AM +0100, Francesco P. Lovergine wrote:

> Su sid non mi risultano al momento problemi sui binari. In compenso qgis 2.0
> (il binario di qgis.org) va in segfault alla partenza.

QGIS lo compilo :)

Il segfault ha a che fare con la compatiblita' con GRASS/gdal, per caso ?
Hai un ticket ?

--strk;
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Paolo Corti
In reply to this post by Sandro Santilli
2013/11/11 Sandro Santilli <[hidden email]>:
>
> Pacchetti normali. Ho provato a usare ubuntugis ma non sono
> sicuro di essere stato capace (c'e' modo di sapere via apt-qualcosa
> da quale repository un pacchetto verrebbe o e' stato installato?)
>

apt-get show?
ciao
p

--
Paolo Corti
Geospatial software developer
web: http://www.paolocorti.net
twitter: @capooti
skype: capooti
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Sandro Santilli
On Mon, Nov 11, 2013 at 12:56:03PM +0100, Paolo Corti wrote:
> 2013/11/11 Sandro Santilli <[hidden email]>:
> >
> > Pacchetti normali. Ho provato a usare ubuntugis ma non sono
> > sicuro di essere stato capace (c'e' modo di sapere via apt-qualcosa
> > da quale repository un pacchetto verrebbe o e' stato installato?)
>
> apt-get show?

 $ apt-get show grass
 E: Invalid operation show

 $ apt-cache show grass
 ...
 Maintainer: Ubuntu Developers <[hidden email]>
 Filename: pool/universe/g/grass/grass_6.4.2-2build1_all.deb
 ...

Dal maintainer suppongo NON sia ubuntigis, ma non vedo una dicitura
chiara di quale sia il repository dal quale proviene, e del perche'
venga scelto un repo piuttosto che un'altro.

Una ricerca sembra darmi un solo pacchetto per ogni nome:

 $ apt-cache search --names-only ^grass
 grass - Geographic Resources Analysis Support System (GRASS GIS)
 grass-core - GRASS GIS core components
 grass-dev - GRASS GIS development files
 grass-dev-doc - GRASS GIS Programmers' Manual
 grass-doc - GRASS GIS user documentation
 grass-gui - GRASS GIS graphical user interfaces

Forse ho qualche policy che impedisce ad "apt-get update" di tirarsi
giu' i pacchetti da ubuntigis, boh.

Questa invece e' interessante:

 $ apt-cache showsrc grass | grep Uploaders
 Uploaders: Francesco Paolo Lovergine <[hidden email]>

E' inutile che faccia finta di nulla, lo abbiamo trovato ! :D

--strk;
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Francesco P. Lovergine
On Mon, Nov 11, 2013 at 01:52:00PM +0100, Sandro Santilli wrote:
>
>  $ apt-cache showsrc grass | grep Uploaders
>  Uploaders: Francesco Paolo Lovergine <[hidden email]>
>
> E' inutile che faccia finta di nulla, lo abbiamo trovato ! :D
>

E' finto, i binari di ubuntu, sono fatti di ubuntu e di chi fa la
maintainance. Piuttosto come ho detto in un'altra mail, c'è sicuramente
un problema di allineamento ABI, tipicamente occorre una dipendenza
con versionamento stretto che non è presente nel source package.
Questo fa si che una dipendenza cambiata di versione rompe il pacchetto
senza che sia evidente. I colpevoli possono essere :

- una libreria c++
- una libreria qt-schifezz

--
Francesco P. Lovergine
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Sandro Santilli
On Tue, Nov 12, 2013 at 10:11:13AM +0100, Francesco P. Lovergine wrote:

> On Mon, Nov 11, 2013 at 01:52:00PM +0100, Sandro Santilli wrote:
> >
> >  $ apt-cache showsrc grass | grep Uploaders
> >  Uploaders: Francesco Paolo Lovergine <[hidden email]>
> >
> > E' inutile che faccia finta di nulla, lo abbiamo trovato ! :D
> >
>
> E' finto, i binari di ubuntu, sono fatti di ubuntu e di chi fa la
> maintainance. Piuttosto come ho detto in un'altra mail, c'è sicuramente
> un problema di allineamento ABI, tipicamente occorre una dipendenza
> con versionamento stretto che non è presente nel source package.
> Questo fa si che una dipendenza cambiata di versione rompe il pacchetto
> senza che sia evidente. I colpevoli possono essere :
>
> - una libreria c++
> - una libreria qt-schifezz

Appunto, sospetto libgdal (c++, diversamente-versionato ;)
La dipendenza nel pacchetto che ho io e' lasca (gdal >= 1.8) ma invece
deve essere strettamente per la gdal 1.8.
I pacchetti debian sono corretti al riguardo ?

--strk;
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Stefano Iacovella
In reply to this post by Sandro Santilli

Ciao Sandro,

Una info veloce: le istruzioni per la compilazione di QGIS si trovano sul sito o stai sperimentando?

Grazie e buona giornata
Stefano

---------------------------------------------------
41.95581N 12.52854E

http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

Il 07/nov/2013 20:49 "Sandro Santilli" <[hidden email]> ha scritto:
Approfitto della lista per chiedere aiuto ai GRASSisti
(cosi' cerchiamo pure di riequilibrare lo sbilancio verso QGIS)

Ho installato grass-dev da package Ubuntu 13.04 (6.4.2-2build1)
ma quando provo ad usarlo, ottengo errori nella risoluzione di
simboli di GDAL _versionati_, tipo:

/usr/lib/grass64/lib/libgrass_gproj.so: undefined reference to `OSRExportToProj4@GDAL_1.8'

Sembrerebbe un bug nel packaging di grass per ubuntu.

Maintainer: Ubuntu Developers <[hidden email]>
Original-Maintainer: Debian GIS Project <[hidden email]>

Sapete se lo stesso bug e' presente nel pacchetto Debian ?

PS: ok confesso, stavo provando a compilare QGIS col supporto per GRASS :)

--strk;

 ()  ASCII ribbon campaign        - against html e-mail
 /\  http://www.asciiribbon.org   - against proprietary attachments
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Sandro Santilli
On Tue, Nov 12, 2013 at 02:03:31PM +0100, Stefano Iacovella wrote:

> Una info veloce: le istruzioni per la compilazione di QGIS si trovano sul
> sito o stai sperimentando?

Non capisco la domanda :)
Compilo QGIS senza problemi, stavo solo provando a compilarlo
con il supporto GRASS senza compilare GRASS.

--strk;
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Stefano Iacovella

Scusami Sandro

La mia richiesta era assai poco chiara.
Poiché di solito su Linux preferisco compilare gli applicativi  che uso più da power user volevo provare a farlo anche per QGIS. Mi chiedevo se le istruzioni per la compilazione erano abbastanza semplici, come ad esempio per GDAL o PostGIS, o se invece sono necessari hack particolari.

Ciao e grazie

Stefano

---------------------------------------------------
41.95581N 12.52854E

http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

Il 12/nov/2013 14:23 "Sandro Santilli" <[hidden email]> ha scritto:
On Tue, Nov 12, 2013 at 02:03:31PM +0100, Stefano Iacovella wrote:

> Una info veloce: le istruzioni per la compilazione di QGIS si trovano sul
> sito o stai sperimentando?

Non capisco la domanda :)
Compilo QGIS senza problemi, stavo solo provando a compilarlo
con il supporto GRASS senza compilare GRASS.

--strk;

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013
Reply | Threaded
Open this post in threaded view
|

Re: grass su ubuntu ?

Sandro Santilli
On Tue, Nov 12, 2013 at 02:46:36PM +0100, Stefano Iacovella wrote:
> Scusami Sandro
>
> La mia richiesta era assai poco chiara.
> Poiché di solito su Linux preferisco compilare gli applicativi  che uso più
> da power user volevo provare a farlo anche per QGIS. Mi chiedevo se le
> istruzioni per la compilazione erano abbastanza semplici, come ad esempio
> per GDAL o PostGIS, o se invece sono necessari hack particolari.

E' semplice, quando funziona ;)

  cmake . && make

Se preferisci, puoi usare una build directori esterna:

  cmake ../qgis && make

La chiamata che uso io:

 cmake \
   -D PYTHON_LIBRARY=/usr/lib/${DEB_BUILD_MULTIARCH}/libpython2.7.so \
   -D CMAKE_BUILD_TYPE=Debug \
   -D WITH_STAGED_PLUGINS=ON \
   -D CMAKE_CXX_COMPILER:FILEPATH=/usr/lib/ccache/g++ \
   ${srcdir} \
   $@

Non ho mai capito (ne' indagato) come chiedere a cmake la lista
delle opzioni accettate. Mi manca tanto il ./configure ;)

--strk;

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
666 iscritti al 22.7.2013