make valid - lwgeom - errori

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

make valid - lwgeom - errori

Danilo Procaccini
Salve,
in QGIS 2.18.2 non riesco a far funzionare Processing - LWGEOM - Make Valid.
Ho installato il plugin Processing LWGEOM Provider.
Lancio il comando Make Valid da Processing.
Ottengo subito:

avvio dell'algoritmo Make valid...::

In Windows 10
-  [Error 87] Parametro non corretto See log for more details

In Debian 8
- /usr/bin/qgis.bin: undefined symbol: lwgeom_set_handlers See log for
details

Qualcuno ha già risolto questo tipo di problema.
Ringrazio in anticipo.
Saluti

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make valid - lwgeom - errori

a.furieri
On Thu, 5 Jan 2017 10:40:07 +0100, Danilo Procaccini wrote:

> Salve,
> in QGIS 2.18.2 non riesco a far funzionare Processing - LWGEOM - Make
> Valid.
> Ho installato il plugin Processing LWGEOM Provider.
> Lancio il comando Make Valid da Processing.
> Ottengo subito:
>
> avvio dell'algoritmo Make valid...::
>
> In Windows 10
> -  [Error 87] Parametro non corretto See log for more details
>
> In Debian 8
> - /usr/bin/qgis.bin: undefined symbol: lwgeom_set_handlers See log
> for
> details
>
> Qualcuno ha già risolto questo tipo di problema.
>

ciao Danilo,

la MakeValid e' implementata internamente alla LWGEOM, una
libreria che fa parte integrante di PostGIS anche se e'
disponibile come componente a se stante (in altre parole:
PostGIS senza LWGEOM non puo' funzionare, ma LWGEOM senza
PostGIS funziona tranquillamente).

Purtroppo questo legame molto stretto tra PostGIS e LWGEOM
ha finito col causare nel corso degli anni un sacco di
inconvenienti per gli altri progetti GFOSS come SpatiaLite
o QGIS che utilizzano la LWGEOM, visto che le API di questa
libreria ballano in modo molto capriccioso da versione a
versione.
per inciso: e' esattamente quel che sta capitando a te:
QGIS cerca di lanciare una LWGEOM di versione differente
da quella installata nel tuo sistema, e si scontra con
problemi di API non definite.

per aggirare tutti i numerosi problemi della LWGEOM da qualche
tempo e' disponibile una nuova libreria RTTOPO (interamente
finanziata da Regione Toscana):
https://git.osgeo.org/gogs/rttopo/librttopo

la RTTOPO copre tutte le funzionalita' offerte dalla vecchia
LWGEOM (oltre ad un sacco di altra roba, come un potente motore
topologico ISO-compliant).
Ma soprattutto la RTTOPO assicura una robusta stabilita' delle
API tra le successive versioni, ed e' una libreria totalmente
svincolata da PostGIS.

Tutte le applicazioni che supportano p.es. la MakeValid
dovrebbero attrezzarsi in modo tale da utilizzare la RTTOPO
lasciando definitivamente  perdere la LWGEOM.
SpatiaLite ha gia' effettuato la transizione sulla RTTOPO;
se ti serve una MakeValid sicuramente funzionante basata
puoi sempre provare ad utilizzare SpatiaLite; gli EXE binari
per windows li puoi scaricare da qua:

win32: http://www.gaia-gis.it/gaia-sins/windows-bin-x86-test/
win64: http://www.gaia-gis.it/gaia-sins/windows-bin-amd64-test/

ciao Sandro
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make valid - lwgeom - errori

Luigi Pirelli-2
ottima iniziativa, RT ha pensato di finanziare anche il provider per
QGIS processing toolbox?

Luigi Pirelli

**************************************************************************************************
* Boundless QGIS Support/Development: lpirelli AT boundlessgeo DOT com
* LinkedIn: https://www.linkedin.com/in/luigipirelli
* Stackexchange: http://gis.stackexchange.com/users/19667/luigi-pirelli
* GitHub: https://github.com/luipir
* Mastering QGIS 2nd Edition:
* https://www.packtpub.com/big-data-and-business-intelligence/mastering-qgis-second-edition
**************************************************************************************************


2017-01-05 11:06 GMT+01:00  <[hidden email]>:

> On Thu, 5 Jan 2017 10:40:07 +0100, Danilo Procaccini wrote:
>>
>> Salve,
>> in QGIS 2.18.2 non riesco a far funzionare Processing - LWGEOM - Make
>> Valid.
>> Ho installato il plugin Processing LWGEOM Provider.
>> Lancio il comando Make Valid da Processing.
>> Ottengo subito:
>>
>> avvio dell'algoritmo Make valid...::
>>
>> In Windows 10
>> -  [Error 87] Parametro non corretto See log for more details
>>
>> In Debian 8
>> - /usr/bin/qgis.bin: undefined symbol: lwgeom_set_handlers See log for
>> details
>>
>> Qualcuno ha già risolto questo tipo di problema.
>>
>
> ciao Danilo,
>
> la MakeValid e' implementata internamente alla LWGEOM, una
> libreria che fa parte integrante di PostGIS anche se e'
> disponibile come componente a se stante (in altre parole:
> PostGIS senza LWGEOM non puo' funzionare, ma LWGEOM senza
> PostGIS funziona tranquillamente).
>
> Purtroppo questo legame molto stretto tra PostGIS e LWGEOM
> ha finito col causare nel corso degli anni un sacco di
> inconvenienti per gli altri progetti GFOSS come SpatiaLite
> o QGIS che utilizzano la LWGEOM, visto che le API di questa
> libreria ballano in modo molto capriccioso da versione a
> versione.
> per inciso: e' esattamente quel che sta capitando a te:
> QGIS cerca di lanciare una LWGEOM di versione differente
> da quella installata nel tuo sistema, e si scontra con
> problemi di API non definite.
>
> per aggirare tutti i numerosi problemi della LWGEOM da qualche
> tempo e' disponibile una nuova libreria RTTOPO (interamente
> finanziata da Regione Toscana):
> https://git.osgeo.org/gogs/rttopo/librttopo
>
> la RTTOPO copre tutte le funzionalita' offerte dalla vecchia
> LWGEOM (oltre ad un sacco di altra roba, come un potente motore
> topologico ISO-compliant).
> Ma soprattutto la RTTOPO assicura una robusta stabilita' delle
> API tra le successive versioni, ed e' una libreria totalmente
> svincolata da PostGIS.
>
> Tutte le applicazioni che supportano p.es. la MakeValid
> dovrebbero attrezzarsi in modo tale da utilizzare la RTTOPO
> lasciando definitivamente  perdere la LWGEOM.
> SpatiaLite ha gia' effettuato la transizione sulla RTTOPO;
> se ti serve una MakeValid sicuramente funzionante basata
> puoi sempre provare ad utilizzare SpatiaLite; gli EXE binari
> per windows li puoi scaricare da qua:
>
> win32: http://www.gaia-gis.it/gaia-sins/windows-bin-x86-test/
> win64: http://www.gaia-gis.it/gaia-sins/windows-bin-amd64-test/
>
> ciao Sandro
> _______________________________________________
> [hidden email]
> http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non hanno relazione diretta con le posizioni
> dell'Associazione GFOSS.it.
> 807 iscritti al 31/03/2016
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make valid - lwgeom - errori

Sandro Santilli-2
In reply to this post by Danilo Procaccini
On Thu, Jan 05, 2017 at 10:40:07AM +0100, Danilo Procaccini wrote:

> - /usr/bin/qgis.bin: undefined symbol: lwgeom_set_handlers See log for
> details

Vedi quale liblwgeom viene usata da qgis:

$ ldd /usr/bin/qgis.bin | grep lwgeom

Probabilmente e' troppo vecchia, la "lwgeom_set_handlers" e'
stata introdotta dalla versione di liblwgeom contenuta in PostGIS 2.1.0.

Debian 8 dovrebbe avere un pacchetto che si chiama liblwgeom-2.1.4,
prova ad installare quello e vedi se viene utilizzato dal qgis che
hai installato tu, o faglielo utilizzare.

Da quali repository APT hai installato qgis ? Perche' si direbbe un bug
nel packaging.

--strk;
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: make valid - lwgeom - errori

Danilo Procaccini
Il giorno 5 gennaio 2017 12:27, Sandro Santilli <[hidden email]> ha scritto:

> On Thu, Jan 05, 2017 at 10:40:07AM +0100, Danilo Procaccini wrote:
>
>
> Debian 8 dovrebbe avere un pacchetto che si chiama liblwgeom-2.1.4,
> prova ad installare quello e vedi se viene utilizzato dal qgis che
> hai installato tu, o faglielo utilizzare.
>

Risolto inserendo il percorso corretto di liblwgeom-2.1.4 (che avevo già
installato) in processing - opzioni - programmi.

Grazie

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
807 iscritti al 31/03/2016
Loading...