mapfile e wms

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

mapfile e wms

frippe12573
Salve a a tutti,

qualcuno può spiegarmi come mai il layer :

LAYER NAME 'Cnr_imaa:pyramid_5' TYPE RASTER CONNECTIONTYPE WMS

CONNECTION 'http://geoserver.nsdi.it/geoserver/wms?service=WMS&request=GetCapabilities'

METADATA

'wms_name' 'Cnr_imaa:pyramid_5'

'wms_server_version' '1.1.1'

'wms_format' 'image/png'

'wms_style' 'raster'

END

METADATA

'wms_title' 'cnr_imaa:pyramid_5'

END

STATUS DEFAULT

TRANSPARENCY 100 PROJECTION

"init=epsg:4326"

END END non riesco a visualizzarlo, mentre questo layer: LAYER

NAME 'Batimetrica' TYPE RASTER CONNECTIONTYPE WMS

CONNECTION 'http://wms.pcn.minambiente.it/cgi-bin/mapserv.exe?map=/ms_ogc/service/batimetrica.map'

METADATA 'wms_name' 'batimetrica'

'wms_server_version' '1.1.1'

'wms_format' 'image/png' 'wms_style' 'default' END METADATA 'wms_title' 'Batimetrica'

END

STATUS DEFAULT TRANSPARENCY 100 PROJECTION "init=epsg:4326"

END END

non mi da problemi? Da quello che vedo, un proviene da un geoserver (quello che non va),mentre l'altro da un mapserver (quello che va). Io utilizzo un sistema mapserver+pmapper. Possibile che il problema sia di natura sintattica per il layer di geoserver???

Grazie,

Eugenio



Solo con Messenger, nuovi gadget gratuiti per te. Vieni a scoprirli!
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: mapfile e wms

Antonio Falciano
Eugenio Trumpy ha scritto:

> Salve a a tutti,
>
> qualcuno può spiegarmi come mai il layer :
>
>
> LAYER
>     NAME 'Cnr_imaa:pyramid_5'
>    TYPE RASTER
>     CONNECTIONTYPE WMS
>
> CONNECTION
> 'http://geoserver.nsdi.it/geoserver/wms?service=WMS&request=GetCapabilities'
>
>
>
>     METADATA
>
> 'wms_name' 'Cnr_imaa:pyramid_5'
>
> 'wms_server_version' '1.1.1'
>
> 'wms_format' 'image/png'
>
> 'wms_style' 'raster'
>
> END
>
> METADATA
>
> 'wms_title' 'cnr_imaa:pyramid_5'
>
> END
>
> STATUS DEFAULT
>
> TRANSPARENCY 100 PROJECTION
>
> "init=epsg:4326"
>
> END END non riesco a visualizzarlo, mentre questo layer: LAYER
>
> NAME 'Batimetrica' TYPE RASTER CONNECTIONTYPE WMS
>
> CONNECTION
> 'http://wms.pcn.minambiente.it/cgi-bin/mapserv.exe?map=/ms_ogc/service/batimetrica.map'
>
>
>    METADATA
>       'wms_name' 'batimetrica'
>
> 'wms_server_version' '1.1.1'
>
> 'wms_format' 'image/png' 'wms_style' 'default' END METADATA 'wms_title'
> 'Batimetrica'
>
> END
>
> STATUS DEFAULT TRANSPARENCY 100 PROJECTION "init=epsg:4326"
>
> END END
>
> non mi da problemi? Da quello che vedo, un proviene da un geoserver
> (quello che non va),mentre l'altro da un mapserver (quello che va). Io
> utilizzo un sistema mapserver+pmapper. Possibile che il problema sia di
> natura sintattica per il layer di geoserver???

Eugenio,
da quello che vedo il primo tenta di stabilire una connessione mediante
una richiesta GetCapabilities (che ti restituisce un XML e non
un'immagine).
Penso che invece possa bastare semplicemente:

CONNECTION
'http://geoserver.nsdi.it/geoserver/wms?service=WMS'

o anche addirittura solo:

CONNECTION
'http://geoserver.nsdi.it/geoserver/wms?'

ciao
Antonio

--
Antonio Falciano
http://www.linkedin.com/in/antoniofalciano


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.