problema con OpenLayers

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

problema con OpenLayers

Daniele Bonaposta
Salve a tutti,
utilizzo come sfondi per le mappe il plugin OpenLayers, finché lavoro a video non ci sono problemi. Al momento di creare un layout, nonostante che le mie coperture vettoriali combacino perfettamente con l'immagine di sfondo, il pdf che vado ad estrarre presenta scostamenti anche di diverse centinaia di metri tra i miei layers e lo sfondo. 
Questo mi succede sia con vettori in ED50 che WGS84.

E' una questione di CRS? In caso come devo settare CRS del progetto e dei layers affinché tutto combaci?


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013
Reply | Threaded
Open this post in threaded view
|

Re: problema con OpenLayers

Matteo Ghetta
Succede anche a me. E anche se esporto in jpeg.
Ho risolto esportando in tif: qui non ho avuto problemi.

Matteo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013
Reply | Threaded
Open this post in threaded view
|

Re: problema con OpenLayers

Matteo Ghetta
Se sia un problema di SR non te lo so dire. Usi la versione master? In
quel caso potrebbe esserci qualche problemino di instabilità, anche se
ci capisco ben poco.

Matteo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013
Reply | Threaded
Open this post in threaded view
|

Re: problema con OpenLayers

pcav
Credo che stampare violi la licenza.

matteo <[hidden email]> ha scritto:
Se sia un problema di SR non te lo so dire. Usi la versione master? In 
quel caso potrebbe esserci qualche problemino di instabilità, anche se
ci capisco ben poco.

Matteo


[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013

--
http://faunalia.it/pc
Sorry for being short
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013
Reply | Threaded
Open this post in threaded view
|

Re: problema con OpenLayers

Andrea Peri
cosa intendi esattamente ?

Non si parlava di dati specifici in questo thread.


On 03/05/2013 17:25, Paolo Cavallini wrote:
Credo che stampare violi la licenza.

matteo [hidden email] ha scritto:
Se sia un problema di SR non te lo so dire. Usi la versione master? In 
quel caso potrebbe esserci qualche problemino di instabilità, anche se 
ci capisco ben poco.

Matteo

[hidden email] http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss Questa e' una lista di discussione pubblica aperta a tutti. I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it. 638 iscritti al 28.2.2013

--
http://faunalia.it/pc
Sorry for being short

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013
Reply | Threaded
Open this post in threaded view
|

Re: problema con OpenLayers

pcav
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Il 03/05/2013 17:51, aperi2007 ha scritto:
> cosa intendi esattamente ?
>
> Non si parlava di dati specifici in questo thread.

vero, scusate la brevita'.
se si utilizzano layers proprietari, la loro stampa probabilmente
viola la licenza.
gli scostamenti sono probabilmente dovuti al datum: tutti i layers
devono avere il datum appropriato, e devono essere riproiettati su
quella di sfondo nella proiezione di quest'ultima (in generale, la
famigerata Google Mercator).
Saluti.

- --
Paolo Cavallini - Faunalia
www.faunalia.eu
Full contact details at www.faunalia.eu/pc
Nuovi corsi QGIS e PostGIS: http://www.faunalia.it/calendario
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAlGD4WkACgkQ/NedwLUzIr4NJACghgI5L6W3utoYQbjyogj2A8hG
nQsAn1M6J+SzTphKJKjNHugat1ogpwnA
=V6Mu
-----END PGP SIGNATURE-----
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013
Reply | Threaded
Open this post in threaded view
|

Re: problema con OpenLayers

Matteo Ghetta

> gli scostamenti sono probabilmente dovuti al datum: tutti i layers
> devono avere il datum appropriato, e devono essere riproiettati su
> quella di sfondo nella proiezione di quest'ultima (in generale, la
> famigerata Google Mercator).
Questo però mi sembra strano. Come dicevo, anch'io ho avuto questo
problema con i pdf e con il jpeg, ma non con il tif.
La mappa è composta da un paio di shape in wgs84 e non sono stati
riproiettati in Google Mercator.

Saluti

Matteo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
638 iscritti al 28.2.2013