problemi plugin python in qgis

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problemi plugin python in qgis

Iacopo Zetti-2
Dato che non so più che pesci pigliare chiedo aiuto.
Ho installato qgis su una debian squeeze. nessun problema durante
l'installazione, ma al momento in cui lancio il programma mi appare questo
messaggio:

Impossibile caricare PyQGIS.
Il supporto Python verrà disabilitato.

Traceback (most recent call last):
  File "", line 1, in
RuntimeError: the sip module implements API v6.0 but the qgis.core module
requires API v7.0

Versione Python:
2.5.5 (r255:77872, Feb  1 2010, 20:16:05)
[GCC 4.4.3]

Percorso Python:
['/usr/share/qgis/python', '/home/iacopo/.qgis//python',
'/home/iacopo/.qgis//python/plugins', '/usr/share/qgis/python/plugins',
'/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2',
'/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload',
'/usr/local/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages',
'/usr/lib/python2.5/site-packages/PIL', '/usr/lib/pymodules/python2.5',
'/usr/lib/pymodules/python2.5/gtk-2.0']

I plugin che vengono installati con il programma (per esempio grass)
funzionano, gli altri non sono presenti nella finestra di gestione, anche se
scaricati e messi nella dir in cui devono stare. Non funziona neanche il
plugin installer che pure mi sono scaricato dal sito di qgis.
Dal poco che mi pare di capire c'è un problema di versione di python fra
quello chiesto da qgis e quello presente, ma sul computer ho sia la versione
2.5 che la 2.6

Qualcuno sa darmi una dritta.

Grazie mille.

Iacopo Zetti

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: problemi plugin python in qgis

Umberto Vesco
In data giovedì 11 marzo 2010 11:34:53, iacopo ha scritto:
: > Dato che non so più che pesci pigliare chiedo aiuto.

> Ho installato qgis su una debian squeeze. nessun problema durante
> l'installazione, ma al momento in cui lancio il programma mi appare questo
> messaggio:
>
> Impossibile caricare PyQGIS.
> Il supporto Python verrà disabilitato.
>
> Traceback (most recent call last):
>   File "", line 1, in
> RuntimeError: the sip module implements API v6.0 but the qgis.core module
> requires API v7.0

Avevo lo stesso problema. Non so come l'ho risolto ma l'ho risolto.
Ti dico alcune delle cose che ho fatto, non so quale abbia risolto perché ad
un certo punto ho iniziato a compilare i sorgenti e mi sono imbattuto in altri
problemi con lib sip.
Ciò che ho fatto:
apt-get purge libqgis1.4.0 python-qgis python-qgis-common qgis qgis-common
qgis-plugin-grass qgis-plugin-grass-common
aptitude update
aptitude dist-upgrade
aptitude install python-sip-dev # rimuove python-sip4 (forse la chiave)
# installazione delle dipendenze per compilare secondo
http://blog.jardinmagique.info/2009/11/how-to-build-and-install-qgis-from-
svn.html
dpkg --purge libgdal1-1.5.0-grass
# rimozione di tutto quanto non serviva tra ciò che era tra l'output di dpkg -
l|grep python
# reinstallato tutto per qgis: tieni conto che dpkg -l|grep qgis dovrebbe dare
tutto alla stessa versione

Spero che nella marmellata ci sia la soluzione anche per te.
ciao
umberto


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
Reply | Threaded
Open this post in threaded view
|

Re: problemi plugin python in qgis

pcav
Umberto Vesco ha scritto:

> aptitude install python-sip-dev # rimuove python-sip4 (forse la chiave)

La chiave dovrebbe essere il  python-sip4, che deve essere allineato alla vers di qgis.
Salulti.
--
Paolo Cavallini: http://www.faunalia.it/pc
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.