problemi upgrade ubuntu da 9.10 a 10.04

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

problemi upgrade ubuntu da 9.10 a 10.04

Giuseppe Naponiello
Salve a tutti,
ma è normale che upgradando da karmic a lucid non mi abbia aggiornato
niente di quello che mi serve e, in più, mi abbia sputtanato (passatemi
il francesismo!) tutte le seguenti configurazioni, nell'ordine:
1. php
2. apache
3. tomcat
4. postgres
5. mapserver
rendendo il sistema praticamente inutilizzabile?
In più non solo non ha aggiornato grass/qgis, ma le vecchie
installazioni non partono più!!!
Questa cosa non mi era mai successa...e non è il primo upgrade che
faccio!
Stamani giornata di lavoro persa ed ennesima nottata per cercare di
recuperare il recuperabile.
Avete una parola di conforto?!
Vi prego!

Scherzi a parte, cosa ho sbagliato? Ho seguito pedissequamente tutti i
passaggi dell'aggiornamento facendo attenzione a tenere le vecchie
configurazioni!

'notte

-beppe-


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

Giuseppe Naponiello
nel caso non fossi l'unico ad avere avuto tale problema:
1. php/apache -> nell'upgrade non è stato aggiornato libapache2-mod-php5
e quello vecchio è stato disabilitato -> l'ho ricaricato da synaptic,
riavviato il server e cancellato la cache

2. mapserver -> ho dovuto rifare tutto il processo di configurazione
(spostamenti di file, ri-creazione delle cartelle /tmp)

3. per postgresql mi sono quasi messo l'anima in pace visto che la
versione 8.3 è stata dichiarata "obsoleta" e non so se è possibile
recuperare il vecchio cluster!

...mah

-beppe-

Il giorno mar, 18/05/2010 alle 23.22 +0200, beppe ha scritto:

> Salve a tutti,
> ma è normale che upgradando da karmic a lucid non mi abbia aggiornato
> niente di quello che mi serve e, in più, mi abbia sputtanato (passatemi
> il francesismo!) tutte le seguenti configurazioni, nell'ordine:
> 1. php
> 2. apache
> 3. tomcat
> 4. postgres
> 5. mapserver
> rendendo il sistema praticamente inutilizzabile?
> In più non solo non ha aggiornato grass/qgis, ma le vecchie
> installazioni non partono più!!!
> Questa cosa non mi era mai successa...e non è il primo upgrade che
> faccio!
> Stamani giornata di lavoro persa ed ennesima nottata per cercare di
> recuperare il recuperabile.
> Avete una parola di conforto?!
> Vi prego!
>
> Scherzi a parte, cosa ho sbagliato? Ho seguito pedissequamente tutti i
> passaggi dell'aggiornamento facendo attenzione a tenere le vecchie
> configurazioni!
>
> 'notte
>
> -beppe-
>


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

Enrico Guastaldi
In reply to this post by Giuseppe Naponiello
ciao,
anche io ho problemi con l'aggiornamento di grass, oltre che con una serie di sciocchezze quali la scheda grafica non riconosciuta (pur sostenendo Asus che il chipset è aggiornato) e il microfono non va (quindi skype mi è praticamente inutile).
Credo che nei prossimi giorni ripassero al 9.10 che andava alla grande. Mi chiedo perché quando esce una nuova versione di ubuntu io ci caschi tutte le volte e aggiorni subito, quando invece dovrei aspettare almeno sei mesi...
Enrico

Il giorno 18 maggio 2010 23.22, beppe <[hidden email]> ha scritto:
Salve a tutti,
ma è normale che upgradando da karmic a lucid non mi abbia aggiornato
niente di quello che mi serve e, in più, mi abbia sputtanato (passatemi
il francesismo!) tutte le seguenti configurazioni, nell'ordine:
1. php
2. apache
3. tomcat
4. postgres
5. mapserver
rendendo il sistema praticamente inutilizzabile?
In più non solo non ha aggiornato grass/qgis, ma le vecchie
installazioni non partono più!!!
Questa cosa non mi era mai successa...e non è il primo upgrade che
faccio!
Stamani giornata di lavoro persa ed ennesima nottata per cercare di
recuperare il recuperabile.
Avete una parola di conforto?!
Vi prego!

Scherzi a parte, cosa ho sbagliato? Ho seguito pedissequamente tutti i
passaggi dell'aggiornamento facendo attenzione a tenere le vecchie
configurazioni!

'notte

-beppe-


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010


_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

Francesco P. Lovergine
On Wed, May 19, 2010 at 08:35:15AM +0200, Enrico Guastaldi wrote:

> ciao,
> anche io ho problemi con l'aggiornamento di grass, oltre che con una serie
> di sciocchezze quali la scheda grafica non riconosciuta (pur sostenendo Asus
> che il chipset è aggiornato) e il microfono non va (quindi skype mi è
> praticamente inutile).
> Credo che nei prossimi giorni ripassero al 9.10 che andava alla grande. Mi
> chiedo perché quando esce una nuova versione di ubuntu io ci caschi tutte le
> volte e aggiorni subito, quando invece dovrei aspettare almeno sei mesi...
> Enrico
>

Non mi e' chiarissimo: cosa non funziona con grass in aggiornamento?
Idem per mapserver. Mi risulta piuttosto nuovo che vengano modificate
directory utente.

--
Francesco P. Lovergine
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

Iacopo Zetti-2
Io ho fatto l'aggiornamento e non ho avuto problemi con grass e qgis.
per la verità i repository sono stati disabilitati durante l'aggiornamento, ma
è bastato riattivarli dopo. Questi intendo:
deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu lucid main
deb-src http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu lucid
main

Diversa la questione postgres invece che è rimasto alla versione 8.4, ma
cancellando tutti i database che ho dovuto recuperare dai backup fatti prima.
Adesso però si aggiorna regolarmente.
Mapserver non c'è sul mio computer quindi non saprei.

Iacopo

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

Giuseppe Naponiello
In reply to this post by Giuseppe Naponiello
Intanto mi dispiace sapere che non sono l'unico ad avere avuto problemi
di vario tipo, da quelli facilmente risolvibili a quelli decisamente più
seri tipo cancellazione dei db.

Per rispondere a Francesco:
anche a me, come è successo a Iacopo, l'aggiornamento ha disabilitato i
repository senza aggiornarli (male di poco) il problema è che ho dovuto
reinstallare tutti i software gis e rifare tutte le configurazioni...es:
grass -> non mi funzionava perché nel processo di aggiornamento mi ha
cambiato i permessi alla cartella "grassdata"; facilmente risolto.

qgis -> come per grass non mi ha aggiornato il sw, che ho dovuto
reinstallare; facilmente risolto

mapserver -> errore mio, il problema non riguardava mapserver ma
pmapper, il problema era strettamente legato al fatto che
l'aggiornamento mi ha disabilitato il modulo libapache2-mod-php5;
facilmente risolto. Un po' più antipatico è stato non trovare più le
cartelle /tmp e /var/www/tmp richieste da pmapper...facilmente
risolto...vabbé!

postgres -> il dramma; ancora non mi va giù il fatto di aver perso tutti
i db...per fortuna i più importanti riuscirò a recuperarli, ma tutti
quelli di sviluppo ciao! Ho scritto anche alla lista di psql ma ancora
non mi hanno risposto...spero ancora di riuscire a riavere i miei db.
Non ancora risolto!!!!

Ora, è vero che la maggior parte dei problemi sono "facilmente
risolvibili" ma converrete con me che è una gran rottura di scatole.
Magari prima di rilasciare una versione LTS sarebbe cosa buona e giusta
prendersi un po' più di tempo per i test.
E' vero che smanettandoci un po' e perdendo un po' di tempo in rete i
problemi si risolvono, però ci sono tantissime persone che vogliono
avvicinarsi al mondo OS e che non hanno le competenze (o l'esperienza)
per capire qual'è il problema e, di conseguenza, la soluzione da
cercare.
Insomma, W l'Open Source ... però che fatica

-beppe-

Il giorno mer, 19/05/2010 alle 10.19 +0200, [hidden email] ha
scritto:

> > ciao,
> > anche io ho problemi con l'aggiornamento di grass, oltre che con una
> serie
> > di sciocchezze quali la scheda grafica non riconosciuta (pur
> sostenendo Asus
> > che il chipset è aggiornato) e il microfono non va (quindi skype mi
> è
> > praticamente inutile).
> > Credo che nei prossimi giorni ripassero al 9.10 che andava alla
> grande. Mi
> > chiedo perché quando esce una nuova versione di ubuntu io ci caschi
> tutte le
> > volte e aggiorni subito, quando invece dovrei aspettare almeno sei
> mesi...
> > Enrico
> >
>
> Non mi e' chiarissimo: cosa non funziona con grass in aggiornamento?
> Idem per mapserver. Mi risulta piuttosto nuovo che vengano modificate
> directory utente.
>
>

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

luca.casagrande@gmail.com
Ciao,

Il 20 maggio 2010 19.31, beppe <[hidden email]> ha scritto:

> Intanto mi dispiace sapere che non sono l'unico ad avere avuto problemi
> di vario tipo, da quelli facilmente risolvibili a quelli decisamente più
> seri tipo cancellazione dei db.
>
> Per rispondere a Francesco:
> anche a me, come è successo a Iacopo, l'aggiornamento ha disabilitato i
> repository senza aggiornarli (male di poco) il problema è che ho dovuto
> reinstallare tutti i software gis e rifare tutte le configurazioni...es:
> grass -> non mi funzionava perché nel processo di aggiornamento mi ha
> cambiato i permessi alla cartella "grassdata"; facilmente risolto.

Cioè, ti avrebbe cambiato i permessi di una cartella che sta nella tua home ?
E che permessi gli avrebbe dato?

>
> qgis -> come per grass non mi ha aggiornato il sw, che ho dovuto
> reinstallare; facilmente risolto
>
> mapserver -> errore mio, il problema non riguardava mapserver ma
> pmapper, il problema era strettamente legato al fatto che
> l'aggiornamento mi ha disabilitato il modulo libapache2-mod-php5;
> facilmente risolto. Un po' più antipatico è stato non trovare più le
> cartelle /tmp e /var/www/tmp richieste da pmapper...facilmente
> risolto...vabbé!

Anche qui, lui ha rimosso una cartella dentro /var/www/ ?

>
> postgres -> il dramma; ancora non mi va giù il fatto di aver perso tutti
> i db...per fortuna i più importanti riuscirò a recuperarli, ma tutti
> quelli di sviluppo ciao! Ho scritto anche alla lista di psql ma ancora
> non mi hanno risposto...spero ancora di riuscire a riavere i miei db.
> Non ancora risolto!!!!

Il problema è l'approccio nel fare gli aggiornamenti:

- non hai letto le note di rilascio
- non hai fatto un backup dei tuoi dati ( file e dump dei db).

Ciao
Luca


> Il giorno mer, 19/05/2010 alle 10.19 +0200, [hidden email] ha
> scritto:
>> > ciao,
>> > anche io ho problemi con l'aggiornamento di grass, oltre che con una
>> serie
>> > di sciocchezze quali la scheda grafica non riconosciuta (pur
>> sostenendo Asus
>> > che il chipset è aggiornato) e il microfono non va (quindi skype mi
>> è
>> > praticamente inutile).
>> > Credo che nei prossimi giorni ripassero al 9.10 che andava alla
>> grande. Mi
>> > chiedo perché quando esce una nuova versione di ubuntu io ci caschi
>> tutte le
>> > volte e aggiorni subito, quando invece dovrei aspettare almeno sei
>> mesi...
>> > Enrico
>> >
>>
>> Non mi e' chiarissimo: cosa non funziona con grass in aggiornamento?
>> Idem per mapserver. Mi risulta piuttosto nuovo che vengano modificate
>> directory utente.
_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010
Reply | Threaded
Open this post in threaded view
|

Re: problemi upgrade ubuntu da 9.10 a 10.04

Giuseppe Naponiello
Il giorno gio, 20/05/2010 alle 19.40 +0200, Luca Casagrande ha scritto:
> Il problema è l'approccio nel fare gli aggiornamenti:
>
> - non hai letto le note di rilascio
> - non hai fatto un backup dei tuoi dati ( file e dump dei db).
>
> Ciao
> Luca
>
>

Verissimo, per carità, le note di rilascio le ho lette molto velocemente
e superficialmente ma, a parte le giustissime precauzione che
consigliano di prendere, non mi sembrava parlassero di problemi con
postgresql (ripeto, non è una scusa!Molto probabilmente non li ho letti
io!).
Non ho fatto un backup dei dati, non sono stato molto lungimirante, mea
culpa.
E' anche vero, però, che uso ubuntu dalla versione 7.10 e non ho mai
avuto questi problemi, soprattutto con postgresql (quando li ho avuti è
stato sempre perché avevo fatto casino io)

Per il discorso dei permessi non so cosa dirti, li ho cambiati e
funziona tutto, e non ricordo esattamente quali fossero.

Idem per le cartelle scomparse, non so cosa dirti.

Vorrei precisare che la mia non era polemica, sicuramente ho la mia
parte di colpa, solo che la perdita dei dati è sempre un evento
spiacevole ;)

-beppe-

_______________________________________________
Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
[hidden email]
http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non rispecchiano necessariamente
le posizioni dell'Associazione GFOSS.it.
440 iscritti al 15.3.2010