qgis 2.10

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

qgis 2.10

Filippo Dal Bosco --2
Come consigliato ho messo in source lists

deb http://qgis.org/ubuntugis   trusty main

apt-get update

apt-get install qgis python-qgis qgis-plugin-grass

ecco il risultato

I seguenti pacchetti hanno dipendenze non soddisfatte:
 qgis : Dipende: libgdal.so.1-1.11.2 ma non è installabile
        Dipende: qgis-providers (= 1:2.10.1+20trusty-ubuntugis) ma non
sta per essere installato E: Impossibile correggere i problemi, ci sono
pacchetti danneggiati bloccati.

ho una mint17.2 che di default  ha  qgis 2.00 e se guardo l' elenco dei
pacchetti trovo mescolate versioni 2.00 ( da aspettarsi)  2.10 e 2.8

--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

nformica
Ciao Filippo,

innanzitutto ti consiglio di rimuovere tutte le installazioni precedenti di QGIS, se no si crea quella confusione di pacchetti di cui parli, ed è più difficile capire se poi qualcosa non funziona.

Fatto questo se vuoi installare QGIS usando la repo "ubuntugis" (... da sources.list togli i riferimenti alle altre repo !) per risolvere il problema delle dipendenze devi anche eseguire:
deb   http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main

In ogni caso ti consiglio di seguire attentamente le istruzioni riportate nella pagina:
https://www.qgis.org/it/site/forusers/alldownloads.html#linux

Saluti !
Nino
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

Filippo Dal Bosco --2
Il giorno Wed, 28 Oct 2015 12:09:14 -0700 (MST)
nformica <[hidden email]> ha scritto:

> innanzitutto ti consiglio di rimuovere tutte le installazioni
> precedenti di QGIS,
non c' era installato nulla.

>se no si crea quella confusione di pacchetti di
> cui parli,
era  synaptic che mi elencava tutti i pacchetti disponibili

Fatto questo se vuoi installare QGIS usando la repo "ubuntugis" (...
> da sources.list togli i riferimenti alle altre repo !) per risolvere
> il problema delle dipendenze devi anche eseguire:
> deb   http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu
> trusty main

alcuni mesi fa avevo usato questo metodo.
Installa la versione 2.8  ( non la 2.10) e per di più con un bel bug.
Non soprapponeva un layer gpx su carte raster o su bing.

--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

nformica
Ciao Filippo,

se scegli la repo "ubuntugis" , come c'è scritto qui:
https://www.qgis.org/it/site/forusers/alldownloads.html#linux
devi per forza aggiungere anche:
deb   http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
per risolvere il problema delle dipendenze.

Altrimenti usa la repo "debian" !

In ogni caso se rifai l'installazione oggi, ti installi l'ultima versione di QGIS 2.12

Nino
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

pcav
Il 29/10/2015 17:32, nformica ha scritto:

> per risolvere il problema delle dipendenze.
>
> Altrimenti usa la repo "debian" !

mai, ricetta per sicuro groviglio.
sempre usare i repo giusti, mescolare il meno possibile.
saluti.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

nformica
Paolo,
... ma io gli sto dicendo proprio questo !
Per usare la repo "debian" deve cancellare da sources.list tutte le altre.
Se non mi sono spiegato bene ... Sorry !!

Ciao
Nino
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

Filippo Dal Bosco --2
Il giorno Thu, 29 Oct 2015 10:33:05 -0700 (MST)
nformica <[hidden email]> ha scritto:

> Paolo,
> ... ma io gli sto dicendo proprio questo !
> Per usare la repo "debian" deve cancellare da sources.list tutte le
> altre.
quali altre? non ci sono. Mint di default propone qgis 2,00

Mint è basata su ubuntu, devo usare versioni ubuntu

io non ho mescolato nulla.

Di default la mia distribuzione (mint 17.2) propone  qgis 2.00.

qualsiasi aggiunta a source list provoca "miscela di qgis"

Anche Virtualbox ha una versione di default se voglio l' ultima scarico
un unico pacchetto da Oracle e lo installo

sudo dpkg -i pacchetto.deb
 
Se qgis fosse distribuito come Virtualbox (unico pacchetto da scaricare
ed installare) questo problema non si avrebbe.


--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

girarsi_liste
On 29/10/2015 20:24, Filippo Dal Bosco - wrote:
> Se qgis fosse distribuito come Virtualbox (unico pacchetto da scaricare
> ed installare) questo problema non si avrebbe.
>
>

Secondo me ci sono repository da attivare che non permettono di
scaricare completamente le dipendenze.

Se tu fai da shell, come root, semplicemente:

#apt-get update

Ti restituisce qualche errore, o warning?





--
Simone Girardelli
_|_|_|_|_|_|_|_|_|_
|_|_|_|_|_|_|_|_|_|_|


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

nformica
In reply to this post by Filippo Dal Bosco --2
Filippo,
ma tu prima hai scritto :
"ho una mint17.2 che di default  ha  qgis 2.00 e se guardo l' elenco dei
pacchetti trovo mescolate versioni 2.00 ( da aspettarsi)  2.10 e 2.8 "

... e per questo ti ho detto di ripulire (apt-get remove) le diverse installazioni di QGIS.
Poi vai nel file sources.list e togli tutte le repo (o la repo se una sola) per QGIS che trovi; dopodichè ci registri solo la debian:

deb     http://qgis.org/debian trusty main
deb-src http://qgis.org/debian trusty main

ed infine rilanci l'installazione di QGIS:
sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass

In questo modi di dovresti trovarti installato solo QGIS 2.12.

... Altro non so dirti !

Ciao
Nino

Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

Filippo Dal Bosco --2
Il giorno Thu, 29 Oct 2015 14:33:28 -0700 (MST)
nformica <[hidden email]> ha scritto:


> Poi vai nel file sources.list e togli tutte le repo (o la repo se una
> sola) per QGIS che trovi;

se qgis 2.00 è di default in mint17.2 e tolgo da source.list  la sua
repo tolgo non solo qgis ma buona parte ( o tutti) i programmi di mint
17.2 !!

Non fattibile. è per questo motivo che il metodo
"VirtualBox"  ( unico pacchetto da scaricare) va molto meglio  

--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

Filippo Dal Bosco --2
In reply to this post by girarsi_liste
Il giorno Thu, 29 Oct 2015 20:31:54 +0100
girarsi_liste <[hidden email]> ha scritto:


>
> Ti restituisce qualche errore, o warning?

----------------------  taglia----------------------------

Ign http://qgis.org trusty/main Translation-it_IT                              
Ign http://archive.ubuntu.com trusty/universe Translation-it_IT                
Ign http://qgis.org trusty/main Translation-it                                
Ign http://qgis.org trusty/main Translation-en                                
Ign http://packages.linuxmint.com rafaela/import Translation-it_IT            
-------------------taglia------------------------------------------------------

Ign http://packages.linuxmint.com rafaela/upstream Translation-en
Recuperati 4.320 kB in 13s (312 kB/s)
Lettura elenco dei pacchetti... Fatto

 


--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

Filippo Dal Bosco --2
In reply to this post by nformica
Il giorno Thu, 29 Oct 2015 14:33:28 -0700 (MST)
nformica <[hidden email]> ha scritto:

 
> In questo modi di dovresti trovarti installato solo QGIS 2.12.

ho provato il pinning in /etc/atp/preferences.d

Package: qgis python-qgis qgis-plugin-grass
Pin: origin "qgis.org"
Pin-Priority: 999

questo dovrebbe dare la priorità  a qgis python-qgis qgis-plugin-grass
di  http://qgis.org/ubuntugis  sugli stessi pacchetti  di altri repo.

il risultato è sempre
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 qgis : Dipende: libgdal.so.1-1.11.2 ma non è installabile
        Dipende: qgis-providers (= 1:2.10.1+20trusty-ubuntugis) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015
Reply | Threaded
Open this post in threaded view
|

Re: qgis 2.10

Filippo Dal Bosco --2
In reply to this post by nformica
Il giorno Thu, 29 Oct 2015 14:33:28 -0700 (MST)
nformica <[hidden email]> ha scritto:


>
> deb     http://qgis.org/debian trusty main
> deb-src http://qgis.org/debian trusty main

usando debian invece che ubuntugis ecco il risultato

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 python-qgis : Dipende: python-qgis-common (= 1:2.12.0+13jessie) ma non sta per essere installato
               Dipende: python-pyspatialite ma non è installabile
               Dipende: liblwgeom-2.1.4 ma non è installabile
               Dipende: libqgispython2.12.0 ma non sta per essere installato
               Dipende: libgdal1h (>= 1.8.0) ma non è installabile
               Dipende: libgeos-c1 (>= 3.4.2) ma non è installabile
               Dipende: libproj0 (>= 4.8.0) ma non è installabile
               Dipende: libqgis-analysis2.12.0 ma non sta per essere installato
               Dipende: libqgis-core2.12.0 ma non sta per essere installato
               Dipende: libqgis-gui2.12.0 ma non sta per essere installato
               Dipende: libqgis-networkanalysis2.12.0 ma non sta per essere installato
               Dipende: libqgis-server2.12.0 ma non sta per essere installato
               Dipende: libqwt6 ma non è installabile
               Dipende: libspatialindex3 (>= 1.8.1) ma non è installabile
               Dipende: libspatialite5 (>= 2.4.0) ma non è installabile
               Dipende: libstdc++6 (>= 4.9) ma la versione 4.8.4-2ubuntu1~14.04 sta per essere installata
               Dipende: sip-api-11.1 ma non è installabile
 qgis : Dipende: libgdal1h (>= 1.8.0) ma non è installabile
        Dipende: libgeos-c1 (>= 3.4.2) ma non è installabile
        Dipende: libproj0 (>= 4.8.0) ma non è installabile
        Dipende: libqgis-analysis2.12.0 ma non sta per essere installato
        Dipende: libqgis-app2.12.0 ma non sta per essere installato
        Dipende: libqgis-core2.12.0 ma non sta per essere installato
        Dipende: libqgis-gui2.12.0 ma non sta per essere installato
        Dipende: libqgis-networkanalysis2.12.0 ma non sta per essere installato
        Dipende: libqwt6 ma non è installabile
        Dipende: libspatialindex3 (>= 1.8.1) ma non è installabile
        Dipende: libspatialite5 (>= 2.4.0) ma non è installabile
        Dipende: libstdc++6 (>= 4.9) ma la versione 4.8.4-2ubuntu1~14.04 sta per essere installata
        Dipende: qgis-providers (= 1:2.12.0+13jessie) ma non sta per essere installato
        Dipende: qgis-common (= 1:2.12.0+13jessie) ma non sta per essere installato
 qgis-plugin-grass : Dipende: qgis-provider-grass (= 1:2.12.0+13jessie) ma non sta per essere installato
                     Dipende: libgdal1h (>= 1.8.0) ma non è installabile
                     Dipende: libgeos-c1 (>= 3.4.2) ma non è installabile
                     Dipende: libproj0 (>= 4.8.0) ma non è installabile
                     Dipende: libqgis-analysis2.12.0 ma non sta per essere installato
                     Dipende: libqgis-app2.12.0 ma non sta per essere installato
                     Dipende: libqgis-core2.12.0 ma non sta per essere installato
                     Dipende: libqgis-gui2.12.0 ma non sta per essere installato
                     Dipende: libqgisgrass6-2.12.0 ma non sta per essere installato
                     Dipende: libqwt6 ma non è installabile
                     Dipende: libspatialindex3 (>= 1.8.1) ma non è installabile
                     Dipende: libspatialite5 (>= 2.4.0) ma non è installabile
                     Dipende: libstdc++6 (>= 4.9) ma la versione 4.8.4-2ubuntu1~14.04 sta per essere installata
                     Dipende: grass-core ma non è installabile
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


--
Filippo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
786 iscritti al 30.9.2015