[qgis] [linux ] Versione di libspatialite obsoleta

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[qgis] [linux ] Versione di libspatialite obsoleta

amefad
Salve a tutti,

temo di avere un po' di casino con i repository....

nel mio pc (debian wheezy) ho aggiornato qgis alla versione 2.8 e in
sources.list ho i repository di qgis stable

deb http://qgis.org/debian wheezy main
deb-src http://qgis.org/debian wheezy main

cercando di aprire un db spatialite che si apre correttamente in
Windows ottengo l'errore:

libspatialite obsoleta: la connessione a questo DB richiede la v.4.0 o superiore

Ne deduco che non viene aggiornata insieme a Qgis... oppure io non so
come forzare il repo di qgis per quel pacchetto...

che cosa è meglio? compilarla a manina o installare il pacchetto da
debian jessie?

avete qualche lettura da consigliarmi?

amefad
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: [qgis] [linux ] Versione di libspatialite obsoleta

amefad
2015-04-13 17:51 GMT+02:00 Amedeo Fadini <[hidden email]>:
[...]
>
> avete qualche lettura da consigliarmi?

Ok ho trovato il thread di quando è uscita la 4.2

http://lists.gfoss.it/pipermail/gfoss/2014-July/033928.html


Giuliano non è che puoi pubblicizzare il backport? Con te ha funzionato?

amefad
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: [qgis] [linux ] Versione di libspatialite obsoleta

a.furieri
On Mon, 13 Apr 2015 18:37:47 +0200, Amedeo Fadini wrote:
> cercando di aprire un db spatialite che si apre correttamente in
> Windows ottengo l'errore:
>
> libspatialite obsoleta: la connessione a questo DB richiede la v.4.0
> o superiore
>

ciao Amedeo,

vediamo di approfondire un pizzico giusto per chiarezza.
nella storia evolutiva di Splite c'e' un unico punto di rottura
di rilevanza critica, e coincide con il rilascio della v.4.0.0
avvenuto il  25 novembre 2012 (oltre due anni or sono).
le modifiche introdotte in seguito con la 4.1 e 4.2 non hanno
impatti tali da creare ulteriori discontinuita'.

praticamente tutte le principali distro Linux supportano gia'
da tempo qualche versione Splite v.4.x (Fedora, SUSE, Ubuntu,
la stessa Debian "testing").
rimangono tuttora ancorate a qualche versione obsoleta di
Splite solo poche distro particolarmente "conservative",
prima tra tutte la Debian Wheezy.

quel messaggio che riporti "libspatialite obsoleta" significa
semplicemente che stai utilizzando un Linux "un po' troppo
stagionato", e che si sta avvicinando l'ora di aggiornare
la piattaforma ;-)


> Ok ho trovato il thread di quando è uscita la 4.2
>
> http://lists.gfoss.it/pipermail/gfoss/2014-July/033928.html
>
> Giuliano non è che puoi pubblicizzare il backport? Con te ha
> funzionato?
>

opinione peresonalissima: quella del backporting e'
sicuramente una delle opzioni, anche se a volte i
backporting introducono piu' problemi di quanti ne
risolvono.

ma se a te interessa seguire sempre molto da vicino
tutte le successive versioni di QGIS la scelta di
Debian "stable" non pare la piu' opportuna.
presumibilmente per le tue necessita' specifiche
sarebbe piu' indicata la Debian "testing", o in
alternativa qualcosa tipo Ubuntu, Mint o magari
Fedora che ormai e' diventata una piattaforma
robusta e matura anche per tutto quel che riguarda
il GIS e dintorni.

ciao Sandro
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: [qgis] [linux ] Versione di libspatialite obsoleta

Giuliano Curti
Il giorno Mon, 13 Apr 2015 20:02:44 +0200
[hidden email] ha scritto:

> On Mon, 13 Apr 2015 18:37:47 +0200, Amedeo Fadini wrote:
> > ...
>

ciao Amedeo,


> > Ok ho trovato il thread di quando è uscita la 4.2
> >
> > http://lists.gfoss.it/pipermail/gfoss/2014-July/033928.html
> >
> > Giuliano non è che puoi pubblicizzare il backport? Con te ha
> > funzionato?

ti devo due scuse:

primo perchè mi è sfuggito il tuo messaggio, di solito non succede,
ma......

secondo perchè ricordo male la vicenda: rivedendo il msg che hai
linkato mi sembra di ricordare che chiedevo della 4.2.0 e che avevo
sentito in altra lista di una 4.1.1, ma in realtà poi non ho
approfondito e continuato; evidentemente si sono sovrapposti
altri problemi :-(

come sai, sono un utilizzatore domenicale del gis quindi devi dare un
pò di tara ai miei post: ovviamente sono ben disponibile a ricostruire
il problema se può esserti d'aiuto :-)


a presto, ciao,
giuliano



_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015
Reply | Threaded
Open this post in threaded view
|

Re: [qgis] [linux ] Versione di libspatialite obsoleta

amefad

Grazie Alessandro e Giuliano... Per quel che devi fare io il database si apre senza problemi con "aggiungi vettore"... Magari più avanti passerò a Debian testing, ma già l'ho incasinata così....

Adesso per chiudere il plugin devo solo caricare i layer e gestirli da pyqgis... Stranamente non riesco a farlo con qgsdatasource...

L'obbiettivo è scaricare, mosaicare e vestire al volo la CTR Del Veneto, in settimana conto di rilasciare.

Amefad


_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
750 iscritti al 18.3.2015