spatialite-gui su Mint18

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

spatialite-gui su Mint18

Luca Lanteri-2
Ciao a tutti,

sto cercando di compilare spatialite-gui su Mint 18 (quindi con i repo di
ubuntugis-unstable xenial), ma ottengo questo errore:

/usr/bin/ld: ResultSetView.o: undefined reference to symbol
'sqlite3_stmt_status'
//usr/lib/x86_64-linux-gnu/libsqlite3.so.0: error adding symbols: DSO
missing from command line
collect2: error: ld returned 1 exit status

qualcuno ha idea di qualce potrebbe essere il problema ? Le librerie
richieste sembrerebbero essere tutte a posto.

grazie mille
Luca

_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
808 iscritti al 07/03/2017
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: spatialite-gui su Mint18

a.furieri
On Thu, 23 Mar 2017 09:47:32 +0100, Luca Lanteri wrote:

> Ciao a tutti,
>
> sto cercando di compilare spatialite-gui su Mint 18 (quindi con i
> repo di
> ubuntugis-unstable xenial), ma ottengo questo errore:
>
> /usr/bin/ld: ResultSetView.o: undefined reference to symbol
> 'sqlite3_stmt_status'
> //usr/lib/x86_64-linux-gnu/libsqlite3.so.0: error adding symbols: DSO
> missing from command line
> collect2: error: ld returned 1 exit status
>
> qualcuno ha idea di qualce potrebbe essere il problema ? Le librerie
> richieste sembrerebbero essere tutte a posto.
>

ciao Luca,

il link symbol "sqlite3_stmt_status" e' normalmente
definito all'interno di libsqlite: e' stato introdotto
solo alcuni anni fa e potrebbe quindi non essere
supportato da versioni particolarmente obsolete di
sqlite.

l'ipotesi piu' probabile e' appunto che tu stia
utilizzando una sqlite troppo vecchia: prova un
po' a farti una tua custom-build a partire dagli
ultimi sorgenti della 3.17.0

https://www.sqlite.org/2017/sqlite-autoconf-3170000.tar.gz

(ovviamente poi dovrai riconfigurare e ricompilare
sia libspatialite che spatialite_gui)

ciao Sandro
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
808 iscritti al 07/03/2017
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: spatialite-gui su Mint18

Matteo Ghetta
In reply to this post by Luca Lanteri-2
Ciao Luca,

> sto cercando di compilare spatialite-gui su Mint 18 (quindi con i repo di
> ubuntugis-unstable xenial),

stessa distribuzione e stessi repo.. nei pacchetti vedo:

matteo@matteo-computer:~$ aptitude search spatialite | grep gui
i   spatialite-gui                  - user-friendly graphical user
interface for
p   spatialite-gui:i386             - user-friendly graphical user
interface for
p   spatialite-gui-dbg              - user-friendly graphical user
interface for
p   spatialite-gui-dbg:i386         - user-friendly graphical user
interface for



la versione è la 2.0..

c'è un motivo particolare per cui la vuoi compilare?

Matteo
_______________________________________________
[hidden email]
http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss
Questa e' una lista di discussione pubblica aperta a tutti.
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.
808 iscritti al 07/03/2017
Loading...